You are not logged in.

#1 2018-07-22 15:53:54

solstice
Member
Registered: 2006-10-27
Posts: 216
Website

[rtl8723be] loosing wifi connection and can't reconnect (using nm)

hi.
It was working fine for month. I was letting my netbook running for days long, wifi connection on. Never got a problem

Now the connection is lost after some time (19 hours this time) and never reconnects. Even doing it manually does not make it work better.
I got something like this in the log:

juil. 22 15:11:37 mimas kernel: rtlwifi: AP off, try to reconnect now
juil. 22 15:11:37 mimas kernel: wlo1: Connection to AP yy:yy:yy:xx:xx:xx lost
juil. 22 15:11:37 mimas wpa_supplicant[538]: wlo1: CTRL-EVENT-DISCONNECTED bssid=yy:yy:yy:xx:xx:xx reason=4 locally_generated=1
juil. 22 15:11:37 mimas NetworkManager[442]: <warn>  [1532265097.3192] sup-iface[0x556b4eab10c0,wlo1]: connection disconnected (reason -4)
juil. 22 15:11:37 mimas wpa_supplicant[538]: wlo1: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
juil. 22 15:11:37 mimas wpa_supplicant[538]: wlo1: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=FR
juil. 22 15:11:37 mimas NetworkManager[442]: <info>  [1532265097.3565] device (wlo1): supplicant interface state: completed -> disconnected
juil. 22 15:11:37 mimas NetworkManager[442]: <info>  [1532265097.4255] device (wlo1): supplicant interface state: disconnected -> scanning
juil. 22 15:11:38 mimas wpa_supplicant[538]: wlo1: SME: Trying to authenticate with yy:yy:yy:xx:xx:xx (SSID='mySSID' freq=2412 MHz)
juil. 22 15:11:38 mimas kernel: wlo1: authenticate with yy:yy:yy:xx:xx:xx
juil. 22 15:11:38 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 1/3)
juil. 22 15:11:38 mimas NetworkManager[442]: <info>  [1532265098.4553] device (wlo1): supplicant interface state: scanning -> authenticating
juil. 22 15:11:38 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 2/3)
juil. 22 15:11:38 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 3/3)
juil. 22 15:11:38 mimas kernel: wlo1: authentication with yy:yy:yy:xx:xx:xx timed out
juil. 22 15:11:38 mimas NetworkManager[442]: <info>  [1532265098.8043] device (wlo1): supplicant interface state: authenticating -> disconnected
juil. 22 15:11:39 mimas NetworkManager[442]: <info>  [1532265099.3031] device (wlo1): supplicant interface state: disconnected -> scanning
juil. 22 15:11:40 mimas kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
juil. 22 15:11:40 mimas kernel: wlo1: authenticate with yy:yy:yy:xx:xx:xx
juil. 22 15:11:40 mimas wpa_supplicant[538]: wlo1: SME: Trying to authenticate with yy:yy:yy:xx:xx:xx (SSID='mySSID' freq=2412 MHz)
juil. 22 15:11:40 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 1/3)
juil. 22 15:11:40 mimas NetworkManager[442]: <info>  [1532265100.3422] device (wlo1): supplicant interface state: scanning -> authenticating
juil. 22 15:11:40 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 2/3)
juil. 22 15:11:40 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 3/3)
juil. 22 15:11:40 mimas kernel: wlo1: authentication with yy:yy:yy:xx:xx:xx timed out
juil. 22 15:11:40 mimas NetworkManager[442]: <info>  [1532265100.6739] device (wlo1): supplicant interface state: authenticating -> disconnected
juil. 22 15:11:41 mimas NetworkManager[442]: <info>  [1532265101.6757] device (wlo1): supplicant interface state: disconnected -> scanning
juil. 22 15:11:42 mimas wpa_supplicant[538]: wlo1: SME: Trying to authenticate with yy:yy:yy:xx:xx:xx (SSID='mySSID' freq=2412 MHz)
juil. 22 15:11:42 mimas kernel: wlo1: authenticate with yy:yy:yy:xx:xx:xx
juil. 22 15:11:42 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 1/3)
juil. 22 15:11:42 mimas NetworkManager[442]: <info>  [1532265102.7144] device (wlo1): supplicant interface state: scanning -> authenticating
juil. 22 15:11:42 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 2/3)
juil. 22 15:11:42 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 3/3)
uil. 22 15:11:43 mimas kernel: wlo1: authentication with yy:yy:yy:xx:xx:xx timed out
juil. 22 15:11:43 mimas wpa_supplicant[538]: wlo1: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="mySSID" auth_failures=1 duration=10 reason=CON>
juil. 22 15:11:43 mimas NetworkManager[442]: <info>  [1532265103.0444] device (wlo1): supplicant interface state: authenticating -> disconnected
juil. 22 15:11:44 mimas kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
juil. 22 15:11:47 mimas kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
juil. 22 15:11:48 mimas NetworkManager[442]: <info>  [1532265108.0476] device (wlo1): supplicant interface state: disconnected -> scanning
juil. 22 15:11:51 mimas kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
juil. 22 15:11:52 mimas NetworkManager[442]: <warn>  [1532265112.2329] device (wlo1): link timed out.
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.2407] device (wlo1): state change: activated -> failed (reason 'ssid-not-found', sys>
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.2454] manager: NetworkManager state is now DISCONNECTED
juil. 22 15:11:52 mimas gnome-shell[513]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas NetworkManager[442]: <warn>  [1532265112.2869] device (wlo1): Activation: failed for connection 'mySSID'
juil. 22 15:11:52 mimas dbus-daemon[441]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm>
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.3118] device (wlo1): state change: failed -> disconnected (reason 'none', sys-iface->
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.3175] dhcp4 (wlo1): canceled DHCP transaction
juil. 22 15:11:52 mimas kernel: IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.3182] dhcp4 (wlo1): state changed bound -> done
juil. 22 15:11:52 mimas systemd[1]: Starting Network Manager Script Dispatcher Service...
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.3476] device (wlo1): set-hw-addr: set MAC address to BE:4A:E8:05:5E:CF (scanning)
juil. 22 15:11:52 mimas dbus-daemon[441]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
juil. 22 15:11:52 mimas systemd[1]: Started Network Manager Script Dispatcher Service.
juil. 22 15:11:52 mimas nm-dispatcher[21403]: find-scripts: Cannot execute '/etc/NetworkManager/dispatcher.d/99-restart-vpn': not executable by owner.
juil. 22 15:11:52 mimas nm-dispatcher[21403]: find-scripts: Cannot execute '/etc/NetworkManager/dispatcher.d/99-fix-dns-leak': not executable by owne>
juil. 22 15:11:52 mimas nm-dispatcher[21403]: req:1 'down' [wlo1]: new request (1 scripts)
juil. 22 15:11:52 mimas nm-dispatcher[21403]: req:1 'down' [wlo1]: start running ordered scripts...
juil. 22 15:11:52 mimas gnome-shell[513]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[513]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[513]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[513]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas gnome-shell[775]: An active wireless connection, in infrastructure mode, involves no access point?
juil. 22 15:11:52 mimas kernel: IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/IP>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/IP>
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.8795] device (wlo1): supplicant interface state: scanning -> disabled
juil. 22 15:11:52 mimas NetworkManager[442]: <info>  [1532265112.8811] device (wlo1): supplicant interface state: disabled -> inactive
juil. 22 15:11:52 mimas gsd-sharing[976]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit rygel.service not loaded.
juil. 22 15:11:52 mimas gsd-sharing[976]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-remote-desktop.serv>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas nmcli[21408]: gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/Ac>
juil. 22 15:11:52 mimas wpa_supplicant[538]: wlo1: Reject scan trigger since one is already pending
juil. 22 15:11:53 mimas nm-dispatcher[21403]: Chrony going offline.
juil. 22 15:11:53 mimas nm-dispatcher[21403]: 506 Cannot talk to daemon
juil. 22 15:11:53 mimas nm-dispatcher[21403]: req:1 'down' [wlo1], "/etc/NetworkManager/dispatcher.d/10-chrony": complete: failed with Script '/etc/N>
juil. 22 15:11:53 mimas NetworkManager[442]: <warn>  [1532265113.0225] dispatcher: (66) 10-chrony failed (failed): Script '/etc/NetworkManager/dispat>
juil. 22 15:11:53 mimas NetworkManager[442]: <info>  [1532265113.9711] policy: auto-activating connection 'mySSID' (7c506ac9-dee5-40e0-a03>
juil. 22 15:11:53 mimas NetworkManager[442]: <info>  [1532265113.9734] device (wlo1): Activation: starting connection 'mySSID' (7c506ac9-d>
juil. 22 15:11:53 mimas NetworkManager[442]: <info>  [1532265113.9738] device (wlo1): state change: disconnected -> prepare (reason 'none', sys-iface>
juil. 22 15:11:53 mimas NetworkManager[442]: <info>  [1532265113.9764] manager: NetworkManager state is now CONNECTING
juil. 22 15:11:54 mimas NetworkManager[442]: <info>  [1532265114.6725] device (wlo1): set-hw-addr: reset MAC address to EE:EE:EE:HH:HH:HH (preserve)
juil. 22 15:11:55 mimas kernel: IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1495] device (wlo1): supplicant interface state: inactive -> disabled
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1498] device (wlo1): supplicant interface state: disabled -> inactive
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1499] device (wlo1): state change: prepare -> config (reason 'none', sys-iface-state>
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1697] device (wlo1): Activation: (wifi) access point 'mySSID' has securit>
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1698] device (wlo1): state change: config -> need-auth (reason 'none', sys-iface-sta>
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1873] device (wlo1): state change: need-auth -> prepare (reason 'none', sys-iface-st>
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1895] device (wlo1): state change: prepare -> config (reason 'none', sys-iface-state>
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1946] device (wlo1): Activation: (wifi) connection 'mySSID' has security,>
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1947] Config: added 'ssid' value 'mySSID'
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1948] Config: added 'scan_ssid' value '1'
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1948] Config: added 'bgscan' value 'simple:30:-80:86400'
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1948] Config: added 'key_mgmt' value 'WPA-PSK'
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1949] Config: added 'auth_alg' value 'OPEN'
juil. 22 15:11:55 mimas NetworkManager[442]: <info>  [1532265115.1949] Config: added 'psk' value '<hidden>'
juil. 22 15:11:55 mimas kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
juil. 22 15:11:56 mimas NetworkManager[442]: <info>  [1532265116.1528] device (wlo1): supplicant interface state: inactive -> scanning
juil. 22 15:11:56 mimas nm-dispatcher[21403]: find-scripts: Cannot execute '/etc/NetworkManager/dispatcher.d/99-restart-vpn': not executable by owner.
juil. 22 15:11:56 mimas nm-dispatcher[21403]: find-scripts: Cannot execute '/etc/NetworkManager/dispatcher.d/99-fix-dns-leak': not executable by owne>
juil. 22 15:11:56 mimas nm-dispatcher[21403]: req:2 'connectivity-change': new request (1 scripts)
juil. 22 15:11:56 mimas nm-dispatcher[21403]: req:2 'connectivity-change': start running ordered scripts...
juil. 22 15:11:57 mimas wpa_supplicant[538]: wlo1: SME: Trying to authenticate with yy:yy:yy:xx:xx:xx (SSID='mySSID' freq=2412 MHz)
juil. 22 15:11:57 mimas kernel: wlo1: authenticate with yy:yy:yy:xx:xx:xx
juil. 22 15:11:57 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 1/3)
juil. 22 15:11:57 mimas NetworkManager[442]: <info>  [1532265117.1750] device (wlo1): supplicant interface state: scanning -> authenticating
juil. 22 15:11:57 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 2/3)
juil. 22 15:11:57 mimas kernel: wlo1: send auth to yy:yy:yy:xx:xx:xx (try 3/3)
juil. 22 15:11:57 mimas kernel: wlo1: authentication with yy:yy:yy:xx:xx:xx timed out

So I don't know if it's a problem with a networkmanager update or the wifi driver.
I am using the drivers straight from https://github.com/lwfinger/rtlwifi_new.git repo. Specifically using rtl8723be driver on a RTL8723BE PCIe Wireless Network Adapter card.

I have to reboot to get back my wifi connection. Quite a shame.

May be trying to bring down and up the interface would be enough. Just thought about that. but that's not a fix.

Another idea: or may be it's because of openwrt/LEDE that I am now using on the AP ??
Here is the system log of LEDE Reboot 17.01.4 r3560-79f57e422d

Sun Jul 22 14:28:23 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa WPA: group key handshake completed (RSN)
Sun Jul 22 14:38:23 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa WPA: group key handshake completed (RSN)
Sun Jul 22 14:48:23 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa WPA: group key handshake completed (RSN)
Sun Jul 22 14:58:23 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa WPA: group key handshake completed (RSN)
Sun Jul 22 15:08:23 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa WPA: group key handshake completed (RSN)
Sun Jul 22 15:11:37 2018 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED zz:zz:zz:aa:aa:aa
Sun Jul 22 15:19:13 2018 daemon.notice hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: did not acknowledge authentication response
Sun Jul 22 15:19:13 2018 daemon.notice hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: did not acknowledge authentication response
Sun Jul 22 15:24:16 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: disassociated due to inactivity
Sun Jul 22 15:24:17 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Jul 22 15:35:03 2018 daemon.notice hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: did not acknowledge authentication response
Sun Jul 22 15:35:14 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: authenticated
Sun Jul 22 15:40:06 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: disassociated due to inactivity
Sun Jul 22 15:40:07 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Jul 22 15:50:22 2018 daemon.notice hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: did not acknowledge authentication response
Sun Jul 22 15:55:25 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: disassociated due to inactivity
Sun Jul 22 15:55:26 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Jul 22 15:59:08 2018 daemon.notice hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: did not acknowledge authentication response
Sun Jul 22 16:04:11 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: disassociated due to inactivity
Sun Jul 22 16:04:12 2018 daemon.info hostapd: wlan0: STA zz:zz:zz:aa:aa:aa IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
[loop]

It does not seem to be a problem coming from the AP.

It times out on both side ? wtf ?
NetworkManager times out and openwrt on AP deauth the client because it got no response ??

Does the fact that my SSID has space in it can cause a problem ?

Last edited by solstice (2018-07-31 10:35:26)

Offline

#2 2018-07-22 17:07:21

seth
Member
Registered: 2012-09-03
Posts: 26,404

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

Pass rtl8723be some options:

swenc=1 ips=0 swlps=0 fwlps=0 aspm=0

If this doesn't help, also try

ant_sel=1

or

ant_sel=2

Offline

#3 2018-07-22 17:31:40

solstice
Member
Registered: 2006-10-27
Posts: 216
Website

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

Thanks for the help @Seth but I don't think this is gonna help.

I already had

fwlps=0 ant_sel=2

. I am gonna add

ips=0

. One will see. One never knows.

Last edited by solstice (2018-07-22 17:45:46)

Offline

#4 2018-07-22 18:28:01

seth
Member
Registered: 2012-09-03
Posts: 26,404

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

Notably hw ecryption is notorious for random communication failures, so ensure to try swenc and also disable aspm, since power saving could very well be an issue here.

Offline

#5 2018-07-22 19:06:56

solstice
Member
Registered: 2006-10-27
Posts: 216
Website

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

Ok. I will make another try with swenc option.

But as per the documentation, there is no aspm option https://github.com/lwfinger/rtlwifi_new … be-options
Do you mean swlps ?

I'll be back in a few days.

Offline

#6 2018-07-22 19:42:19

lo1
Member
Registered: 2017-09-25
Posts: 584

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

In order to make sure that is the driver and not your setup, I would also suggest to try it a few days without using any network manager at all.

dhcpcd is what you want here, setup a wpa_supplicant hook and you're good to go.

Offline

#7 2018-07-22 19:47:06

seth
Member
Registered: 2012-09-03
Posts: 26,404

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

But as per the documentation, there is no aspm option

modinfo rtl8723be

Offline

#8 2018-07-31 10:34:38

solstice
Member
Registered: 2006-10-27
Posts: 216
Website

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

This didn't changed much.

Moreover the reconnexion problem, I can't even switch AP or change passphrase of an AP, without a reboot now !

I have opened an issue at rtlwifi_new repo, because it seems related to a recent fix.
Stack trace have disapeared in the log about rtl8723be but I suspect that fix to be the cause of that issue I have now.

Not tried the dhcpcd solution yet.

Offline

#9 2018-09-19 16:25:21

ajaybhatia
Member
From: India
Registered: 2015-11-29
Posts: 5
Website

Re: [rtl8723be] loosing wifi connection and can't reconnect (using nm)

Use openresolv. This solves my problem.

https://wiki.archlinux.org/index.php/Ne … openresolv

Offline

Board footer

Powered by FluxBB