You are not logged in.

#1 2019-03-16 09:07:12

Pryka
Member
Registered: 2018-02-07
Posts: 80

[SOLVED]KDE Plasma - Dark Theme(breeze) broken.

After the latest updates to KDE Plasma, the dark breeze theme is unreadable in some places. Mainly notifications and KDE app menu. It's extremely bright.

Don't really know how to describe it better. I will just putt link to the screenshot below:
https://prnt.sc/myml72

How it was before(not my screen):
https://www.fossmint.com/wp-content/upl … Ubuntu.png

Again only KDE app menu and notifications are affected everything else is still dark.

Last edited by Pryka (2019-03-18 10:30:32)

Offline

#2 2019-03-16 19:12:10

prochac
Member
Registered: 2019-03-16
Posts: 1

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

Offline

#3 2019-03-16 19:47:15

bashM0nk3y
Member
From: the big she-bang
Registered: 2018-05-26
Posts: 47

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

On my system too: https://imgur.com/XCvjzmS

Still trying to work out exactly what is causing this. This started happening after this upgrade:

[2019-03-16 14:45] [PACMAN] Running 'pacman -Syu'
[2019-03-16 14:45] [PACMAN] synchronizing package lists
[2019-03-16 14:45] [PACMAN] starting full system upgrade
[2019-03-16 15:02] [ALPM] transaction started
[2019-03-16 15:02] [ALPM] upgraded bash (5.0.0-1 -> 5.0.002-1)
[2019-03-16 15:02] [ALPM] upgraded freetype2 (2.9.1-1 -> 2.10.0-1)
[2019-03-16 15:02] [ALPM] upgraded pango (1:1.42.4-1 -> 1:1.43.0-1)
[2019-03-16 15:02] [ALPM] upgraded adwaita-icon-theme (3.30.1-1 -> 3.31.91-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-base (5.12.1-3 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-script (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-x11extras (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded gst-plugins-base-libs (1.14.4-1 -> 1.14.4+18+g3cc7cc757-1)
[2019-03-16 15:02] [ALPM] upgraded gst-plugins-base (1.14.4-1 -> 1.14.4+18+g3cc7cc757-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-multimedia (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-speech (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-svg (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-declarative (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded akonadi (18.12.3-1 -> 18.12.3-2)
[2019-03-16 15:02] [ALPM] installed adobe-source-code-pro-fonts (2.030ro+1.050it-5)
[2019-03-16 15:02] [ALPM] upgraded gsettings-desktop-schemas (3.28.1-1 -> 3.32.0-2)
[2019-03-16 15:02] [ALPM] upgraded chromium (73.0.3683.75-1 -> 73.0.3683.75-2)
[2019-03-16 15:02] [ALPM] upgraded cmake (3.13.4-1 -> 3.14.0-1)
[2019-03-16 15:02] [ALPM] upgraded ethtool (1:4.19-1 -> 1:5.0-1)
[2019-03-16 15:02] [ALPM] upgraded fuse-common (3.4.1-1 -> 3.4.2-1)
[2019-03-16 15:02] [ALPM] upgraded gnome-keyring (1:3.28.2-1 -> 1:3.31.91-1)
[2019-03-16 15:02] [ALPM] upgraded gssdp (1.0.3-1 -> 1.2.0-1)
[2019-03-16 15:02] [ALPM] upgraded gst-libav (1.14.4-1 -> 1.14.4+2+gc324028-1)
[2019-03-16 15:02] [ALPM] upgraded gupnp (1.0.3-1 -> 1.2.0-1)
[2019-03-16 15:02] [ALPM] upgraded gupnp-igd (0.2.5-1 -> 0.2.5+3+gedd78a6-1)
[2019-03-16 15:02] [ALPM] upgraded libnice (0.1.15-1 -> 0.1.15-2)
[2019-03-16 15:02] [ALPM] upgraded gst-plugins-bad (1.14.4-8 -> 1.14.4+22+ge87fb02c1-1)
[2019-03-16 15:02] [ALPM] upgraded libmagick (7.0.8.33-1 -> 7.0.8.34-1)
[2019-03-16 15:02] [ALPM] upgraded imagemagick (7.0.8.33-1 -> 7.0.8.34-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-xmlpatterns (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded python2 (2.7.15-4 -> 2.7.16-1)
[2019-03-16 15:02] [ALPM] upgraded kig (18.12.3-1 -> 18.12.3-2)
[2019-03-16 15:02] [ALPM] upgraded lib32-freetype2 (2.9.1-1 -> 2.10.0-1)
[2019-03-16 15:02] [ALPM] upgraded linux-firmware (20190212.28f5f7d-1 -> 20190313.efd2c1c-1)
[2019-03-16 15:02] [ALPM] upgraded linux (5.0.1.arch1-1 -> 5.0.2.arch1-1)
[2019-03-16 15:02] [ALPM] upgraded linux-headers (5.0.1.arch1-1 -> 5.0.2.arch1-1)
[2019-03-16 15:02] [ALPM] upgraded pygobject-devel (3.30.4-1 -> 3.32.0-1)
[2019-03-16 15:02] [ALPM] upgraded python-attrs (18.2.0-1 -> 19.1.0-1)
[2019-03-16 15:02] [ALPM] upgraded python-gobject (3.30.4-1 -> 3.32.0-1)
[2019-03-16 15:02] [ALPM] upgraded python2-attrs (18.2.0-1 -> 19.1.0-1)
[2019-03-16 15:02] [ALPM] upgraded python2-gobject (3.30.4-1 -> 3.32.0-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-graphicaleffects (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-location (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-quickcontrols (5.12.1-2 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-quickcontrols2 (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-sensors (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-tools (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-webchannel (5.12.1-1 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-webengine (5.12.1-3 -> 5.12.2-1)
[2019-03-16 15:02] [ALPM] upgraded qt5-webkit (5.212.0alpha2-23 -> 5.212.0alpha2-24)
[2019-03-16 15:02] [ALPM] upgraded ruby (2.6.1-1 -> 2.6.2-1)
[2019-03-16 15:02] [ALPM] upgraded sublime-text (3176-1 -> 3200-1)
[2019-03-16 15:02] [ALPM] upgraded texinfo (6.5-2 -> 6.6-1)
[2019-03-16 15:02] [ALPM] upgraded virtualbox-host-modules-arch (6.0.4-13 -> 6.0.4-14)
[2019-03-16 15:02] [ALPM] upgraded vte-common (0.54.3-1 -> 0.56.0-1)
[2019-03-16 15:02] [ALPM] upgraded vte3 (0.54.3-1 -> 0.56.0-1)
[2019-03-16 15:02] [ALPM] upgraded xapian-core (1:1.4.10-1 -> 1:1.4.11-1)
[2019-03-16 15:02] [ALPM] transaction completed
[2019-03-16 15:02] [ALPM] running '60-linux.hook'...
[2019-03-16 15:02] [ALPM] running '90-linux.hook'...
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Starting build: 5.0.2-arch1-1-ARCH
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Starting build: 5.0.2-arch1-1-ARCH
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-03-16 15:02] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-03-16 15:02] [ALPM] running 'detect-old-perl-modules.hook'...
[2019-03-16 15:02] [ALPM] running 'fontconfig-32.hook'...
[2019-03-16 15:02] [ALPM] running 'fontconfig.hook'...
[2019-03-16 15:02] [ALPM] running 'glib-compile-schemas.hook'...
[2019-03-16 15:02] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-03-16 15:02] [ALPM] running 'remove_old_cache.hook'...
[2019-03-16 15:02] [ALPM-SCRIPTLET]
[2019-03-16 15:02] [ALPM-SCRIPTLET] ==> finished: 14 packages removed (disk space saved: 274.31 MiB)
[2019-03-16 15:02] [ALPM] running 'systemd-tmpfiles.hook'...
[2019-03-16 15:02] [ALPM] running 'systemd-udev-reload.hook'...
[2019-03-16 15:02] [ALPM] running 'systemd-update.hook'...
[2019-03-16 15:02] [ALPM] running 'texinfo-install.hook'...
[2019-03-16 15:02] [ALPM] running 'update-desktop-database.hook'...
[2019-03-16 15:02] [ALPM] running 'update-mime-database.hook'...
[2019-03-16 15:02] [ALPM] running 'xorg-mkfontscale.hook'...

Can anyone else having this issue post the relevant parts of their pacman.log?

I'm curious if we could narrow down some of the suspect packages by comparing between different systems. My first thought is that this has something to do with one of the qt5 packages, but that's purely just a guess...

Last edited by bashM0nk3y (2019-03-16 20:30:59)

Offline

#4 2019-03-16 21:59:27

Grelek
Member
Registered: 2016-02-05
Posts: 6

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

Same issue for me as well. https://i.imgur.com/4JEshz3.png

Offline

#5 2019-03-16 23:17:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,758

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

the qt 5.12.2 update is a likely candidate, what happens if you rebuild breeze against it?

Offline

#6 2019-03-17 10:08:11

hoerbert
Member
Registered: 2013-04-03
Posts: 77

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

V1del wrote:

the qt 5.12.2 update is a likely candidate

I'd second that. I have the exact same issue and the last update almost exclusively was qt  (cmake being the other part).

V1del wrote:

what happens if you rebuild breeze against it?

It seems to be a bit better (it's not as unreadable as before), but the backgrounds are still way too bright. And I don't have "before"-pictures from my machine so it can also be just my imagination, that it got better.

There is also a kde-bugreport (https://bugs.kde.org/show_bug.cgi?id=405548) with an interesting observation: If you disable compositing (Alt+Shift+F12), the colors are back to normal. So it could very well be a problem with kwin (but it is certainly related to Qt).

Offline

#7 2019-03-17 10:17:02

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 166

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

arojas assigned FS#62039 to the qt5-svg package. So the issue comes from that package.

Offline

#8 2019-03-17 12:04:09

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 166

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

plasma-framework 5.56.1-2 fixed Kickoff and notifications, but the tooltips are still light gray. https://i.imgur.com/WrISfNg.png

Offline

#9 2019-03-17 14:19:22

Nickolas0
Member
Registered: 2019-02-16
Posts: 23

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

nl6720 wrote:

plasma-framework 5.56.1-2 fixed Kickoff and notifications, but the tooltips are still light gray. https://i.imgur.com/WrISfNg.png

I can confirm above. The issue isn't completely resolved yet.

Offline

#10 2019-03-18 01:06:43

neilsimp1
Member
Registered: 2019-01-20
Posts: 12

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

Upgrading to plasma-framework 5.56.1-3 just solved this for me.

Offline

#11 2019-03-18 04:58:16

bashM0nk3y
Member
From: the big she-bang
Registered: 2018-05-26
Posts: 47

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

Upgrading to plasma-framework 5.56.1-3 fixed breeze-dark for me, but for some reason my other breeze based themes are still broken (specifically breeze-alphablack).

Will update if I can figure anything more out...

Offline

#12 2019-03-18 10:30:16

Pryka
Member
Registered: 2018-02-07
Posts: 80

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

Yeah fixed for me after the update.

@bashM0nk3y alphablack is not an official theme. So I will be marking this thread as solved.

Offline

#13 2019-03-18 13:51:49

silenf
Member
Registered: 2019-03-11
Posts: 1

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

One temporary solution I found is to select any other white theme, remove the dark theme, reinstall and apply it again. This atleast fixed the layout of BreezeAlphaBlack for me but clicking on the "Apply Colors" in the plasmoid breaks the theme once again.

Offline

#14 2019-03-19 08:52:57

unK
Member
Registered: 2008-11-16
Posts: 26

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

Its not fully fixed, backgrounds of tooltips (e.g. if you hover over the clock) are still wrong.

Offline

#15 2019-03-19 16:31:13

Nickolas0
Member
Registered: 2019-02-16
Posts: 23

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

This upstream commit is supposed to fix all issues including the tooltips.

Offline

#16 2019-03-23 10:30:46

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 166

Re: [SOLVED]KDE Plasma - Dark Theme(breeze) broken.

plasma-framework 5.56.1-4 fixed the tooltips.

Offline

Board footer

Powered by FluxBB