You are not logged in.

#1 2019-03-27 22:18:36

SploitStacks
Member
From: Virginia, USA
Registered: 2018-02-10
Posts: 5

pacstrap "failed to install packages to new root"

Hello, I am having an issue where pacstrap is unable to open file parts after downloading them. What happens to me is nearly identical to the second block of code from the OP in this post:  https://bbs.archlinux.org/viewtopic.php?id=238934

The referenced post seemed to solve the issue by formatting their partition as ext2 rather than FAT 32, however I am trying to install on a UEFI system and I was under the impression that FAT 32 was required for your EFI partition, so I am in a bit of a catch 22. I also tried updating my keyring with:

pacman -S archlinux-keyring

If the issue is as the referenced post hypothesized, and that something about the packages doesn't cooperate with FAT 32, are there other file systems I could try ? If not, I am unsure of how to proceed.

Any help would be greatly appreciated. Thanks !

An image of my screen after pacstrap downloads everything and tries to install:   
(Apologies for less than ideal quality.)

https://imgur.com/a/vYak09O

Offline

#2 2019-03-27 22:24:52

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,172
Website

Re: pacstrap "failed to install packages to new root"

Your /boot can be FAT32, not your / partition.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2019-03-27 22:31:13

SploitStacks
Member
From: Virginia, USA
Registered: 2018-02-10
Posts: 5

Re: pacstrap "failed to install packages to new root"

Right so I've got a FAT 32 formatted /dev/sda1 as the boot partition, swap space as /dev/sda2, and an ext4 formatted /dev/sda3 root partition. Is that correct ?

Offline

#4 2019-03-27 22:43:26

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,172
Website

Re: pacstrap "failed to install packages to new root"

Sure.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2019-05-03 03:01:42

MrCush
Member
Registered: 2018-10-13
Posts: 19

Re: pacstrap "failed to install packages to new root"

SploitStacks wrote:

Hello, I am having an issue where pacstrap is unable to open file parts after downloading them. What happens to me is nearly identical to the second block of code from the OP in this post:  https://bbs.archlinux.org/viewtopic.php?id=238934

The referenced post seemed to solve the issue by formatting their partition as ext2 rather than FAT 32, however I am trying to install on a UEFI system and I was under the impression that FAT 32 was required for your EFI partition, so I am in a bit of a catch 22. I also tried updating my keyring with:

pacman -S archlinux-keyring

If the issue is as the referenced post hypothesized, and that something about the packages doesn't cooperate with FAT 32, are there other file systems I could try ? If not, I am unsure of how to proceed.

Any help would be greatly appreciated. Thanks !

An image of my screen after pacstrap downloads everything and tries to install:   
(Apologies for less than ideal quality.)

https://imgur.com/a/vYak09O

Could you just walk us through each step you’ve taken so far in your install in regards to the important parts at least? Like formatting partitions, mounting, and so forth.

Offline

#6 2019-05-03 13:18:01

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,488

Re: pacstrap "failed to install packages to new root"

The OP has not been back since March 27. I am going to close this topic to keep people from wasting time in an abandoned thread.

SploitStacks, if you come back and want this reopened, use the Report button.

Offline

Board footer

Powered by FluxBB