You are not logged in.

#1 2019-05-20 08:33:16

Sweyn78
Member
From: Alpharetta, Georgia
Registered: 2016-02-07
Posts: 9

[SOLVED] NetworkManager fails to connect to WiFi

NetworkManager is failing to connect to my WiFi.
I'm on a fresh Arch install.  I'm dual-booting with Windows, and Windows is able to connect to my WiFi.  Likewise, LiveCDs of other Linux distributions are also able to connect to my WiFi.
I have verified that I am using the correct password.
I am attempting to connect to one of the stock routers AT&T provides.
Also, fwiw, ethernet works fine.  However, as this is a laptop, having functional WiFi is pretty critical.
I've just spent an hour searching for solutions, but I've had no luck.  I'm hoping someone here might know how to get this working.

Here's the relevant portion of journalctl:

May 20 04:24:15 xenotech NetworkManager[11513]: <info>  [1558340655.9955] device (wlp71s0): supplicant interface state: inactive -> scanning
May 20 04:24:15 xenotech NetworkManager[11513]: <info>  [1558340655.9955] device (p2p-dev-wlp71s0): supplicant management interface state: inactive -> scanning
May 20 04:24:16 xenotech NetworkManager[11513]: <info>  [1558340656.9717] device (wlp71s0): supplicant interface state: scanning -> authenticating
May 20 04:24:16 xenotech NetworkManager[11513]: <info>  [1558340656.9717] device (p2p-dev-wlp71s0): supplicant management interface state: scanning -> authenticating
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0193] device (wlp71s0): supplicant interface state: authenticating -> associating
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0193] device (p2p-dev-wlp71s0): supplicant management interface state: authenticating -> associating
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0406] device (wlp71s0): supplicant interface state: associating -> 4-way handshake
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0407] device (p2p-dev-wlp71s0): supplicant management interface state: associating -> 4-way handshake
May 20 04:24:17 xenotech NetworkManager[11513]: <warn>  [1558340657.0748] sup-iface[0x55b4dbcb2090,wlp71s0]: connection disconnected (reason -1)
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0803] device (wlp71s0): supplicant interface state: 4-way handshake -> disconnected
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0806] device (wlp71s0): Activation: (wifi) disconnected during association, asking for new key
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0806] device (wlp71s0): state change: config -> need-auth (reason 'supplicant-disconnect', sys-iface-state: 'managed')
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.0810] device (p2p-dev-wlp71s0): supplicant management interface state: 4-way handshake -> disconnected
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.1799] device (wlp71s0): supplicant interface state: disconnected -> inactive
May 20 04:24:17 xenotech NetworkManager[11513]: <info>  [1558340657.1799] device (p2p-dev-wlp71s0): supplicant management interface state: disconnected -> inactive

Also, here's lspci:

47:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)

And dmesg:

[ 7669.040360] wlp71s0: authenticate with c0:a0:0d:5f:8e:60
[ 7669.047823] wlp71s0: send auth to c0:a0:0d:5f:8e:60 (try 1/3)
[ 7669.090063] wlp71s0: authenticated
[ 7669.091566] wlp71s0: associate with c0:a0:0d:5f:8e:60 (try 1/3)
[ 7669.095707] wlp71s0: RX AssocResp from c0:a0:0d:5f:8e:60 (capab=0x1411 status=0 aid=1)
[ 7669.101775] wlp71s0: associated
[ 7669.132576] wlp71s0: deauthenticating from c0:a0:0d:5f:8e:60 by local choice (Reason: 1=UNSPECIFIED)

Last edited by Sweyn78 (2019-05-21 03:03:45)

Offline

#2 2019-05-20 09:03:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,520

Re: [SOLVED] NetworkManager fails to connect to WiFi

a dmesg after reproduction of the issue? FWIW NetworkManager often has issues with it's internal DHCP Client (though it doesn't look like you are even getting there), try something else

A full dmesg please, lots of context missing in these greps.

Last edited by V1del (2019-05-20 10:27:47)

Offline

#3 2019-05-21 03:03:04

Sweyn78
Member
From: Alpharetta, Georgia
Registered: 2016-02-07
Posts: 9

Re: [SOLVED] NetworkManager fails to connect to WiFi

Unfortunately, those weren't greps -- those were solid chunks I excised by hand.  I would provide you with a fuller dmesg, but it seems all the other setup I did must have magically fixed NM.  I have no clue what it would have been, perhaps one of the following?  [1] installed base-devel (Maybe NM was missing some undefined optional dependency?), [2] switched to linux-zen (Maybe there's something in this kernel that magically fixed things?), [3] installed bluetooth (They're technically the same radio, so maybe this somehow installed something I was missing?).
Anyways, thanks for the quick reply.

Last edited by Sweyn78 (2019-05-21 03:06:10)

Offline

#4 2021-04-06 12:14:06

AT046
Member
Registered: 2021-04-06
Posts: 1

Re: [SOLVED] NetworkManager fails to connect to WiFi

I have the same issue i have a dual boot system with arch and windows 10 and this issue occurs when i put my laptop on sleep or when i turn it on the solution to this is restart the pc but i am not satisfied with that.
the output of :-sudo systemctl status NetworkManager

● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Tue 2021-04-06 10:10:29 IST; 7h ago
       Docs: man:NetworkManager(8)
   Main PID: 393 (NetworkManager)
      Tasks: 3 (limit: 9399)
     Memory: 15.0M
        CPU: 12.486s
     CGroup: /system.slice/NetworkManager.service
             └─393 /usr/bin/NetworkManager --no-daemon

Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4093] Config: added 'scan_ssid' value '1'
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4093] Config: added 'bgscan' value 'simple:30:-70:86400'
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4093] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256'
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4093] Config: added 'psk' value '<hidden>'
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4241] device (wlan0): supplicant interface state: inactive -> scanning
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4241] device (p2p-dev-wlan0): supplicant management interface state: inactive -> scanning
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4883] device (wlan0): supplicant interface state: scanning -> inactive
Apr 06 17:15:22 archlinux NetworkManager[393]: <info>  [1617709522.4885] device (p2p-dev-wlan0): supplicant management interface state: scanning -> inactive
Apr 06 17:15:23 archlinux NetworkManager[393]: <info>  [1617709523.4914] device (wlan0): supplicant interface state: inactive -> scanning
Apr 06 17:15:23 archlinux NetworkManager[393]: <info>  [1617709523.4915] device (p2p-dev-wlan0): supplicant management interface state: inactive -> scanning


some  portion of journalctl(i am nube so if this is irrelevent please tell):-
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9115] device (wlan0): Activation: starting connection 'realme X2 Pro' (f8e5467b-1f12-4971-8de4-77d184df5031)
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9120] device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9138] device (wlan0): set-hw-addr: reset MAC address to 80:2B:F9:39:5D:99 (preserve)
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9197] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9200] device (wlan0): Activation: (wifi) access point 'realme X2 Pro' has security, but secrets are required.
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9201] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9220] device (wlan0): supplicant interface state: inactive -> interface_disabled
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9220] device (p2p-dev-wlan0): supplicant management interface state: inactive -> interface_disabled
Apr 06 17:31:28 archlinux kded5[709]: plasma-nm: Path: "/org/freedesktop/NetworkManager/Settings/2"
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9447] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9454] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9458] device (wlan0): Activation: (wifi) connection 'realme X2 Pro' has security, and secrets exist.  No new secrets needed.
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9458] Config: added 'ssid' value 'realme X2 Pro'
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9459] Config: added 'scan_ssid' value '1'
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9459] Config: added 'bgscan' value 'simple:30:-70:86400'
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9459] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256'
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9459] Config: added 'psk' value '<hidden>'
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9516] device (wlan0): supplicant interface state: interface_disabled -> inactive
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9517] device (p2p-dev-wlan0): supplicant management interface state: interface_disabled -> inactive
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9641] device (wlan0): supplicant interface state: inactive -> scanning
Apr 06 17:31:28 archlinux NetworkManager[393]: <info>  [1617710488.9642] device (p2p-dev-wlan0): supplicant management interface state: inactive -> scanning
Apr 06 17:31:29 archlinux NetworkManager[393]: <info>  [1617710489.0297] device (wlan0): supplicant interface state: scanning -> inactive
Apr 06 17:31:29 archlinux NetworkManager[393]: <info>  [1617710489.0298] device (p2p-dev-wlan0): supplicant management interface state: scanning -> inactive
Apr 06 17:31:30 archlinux NetworkManager[393]: <info>  [1617710490.0349] device (wlan0): supplicant interface state: inactive -> scanning
Apr 06 17:31:30 archlinux NetworkManager[393]: <info>  [1617710490.0350] device (p2p-dev-wlan0): supplicant management interface state: inactive -> scanning
Apr 06 17:31:39 archlinux NetworkManager[393]: <info>  [1617710499.8726] device (wlan0): supplicant interface state: scanning -> authenticating
Apr 06 17:31:39 archlinux NetworkManager[393]: <info>  [1617710499.8727] device (p2p-dev-wlan0): supplicant management interface state: scanning -> authenticating
Apr 06 17:31:42 archlinux NetworkManager[393]: <info>  [1617710502.8265] device (wlan0): supplicant interface state: authenticating -> disconnected
Apr 06 17:31:42 archlinux NetworkManager[393]: <info>  [1617710502.8267] device (p2p-dev-wlan0): supplicant management interface state: authenticating -> disconnected
Apr 06 17:31:52 archlinux NetworkManager[393]: <info>  [1617710512.8275] device (wlan0): supplicant interface state: disconnected -> scanning
Apr 06 17:31:52 archlinux NetworkManager[393]: <info>  [1617710512.8276] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> scanning
Apr 06 17:31:54 archlinux NetworkManager[393]: <warn>  [1617710514.3574] device (wlan0): Activation: (wifi) association took too long, failing activation
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3576] device (wlan0): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3633] device (wlan0): set-hw-addr: set MAC address to CE:7E:F4:97:DC:C9 (scanning)
Apr 06 17:31:54 archlinux NetworkManager[393]: <warn>  [1617710514.3763] device (wlan0): Activation: failed for connection 'realme X2 Pro'
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3773] device (wlan0): supplicant interface state: scanning -> interface_disabled
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3774] device (p2p-dev-wlan0): supplicant management interface state: scanning -> interface_disabled
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3775] device (wlan0): supplicant interface state: interface_disabled -> inactive
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3776] device (p2p-dev-wlan0): supplicant management interface state: interface_disabled -> inactive
Apr 06 17:31:54 archlinux NetworkManager[393]: <info>  [1617710514.3782] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Apr 06 17:31:54 archlinux DiscoverNotifier[812]: "No such interface “org.freedesktop.DBus.Properties” on object at path /org/freedesktop/NetworkManager/ActiveConnection/23"
Apr 06 17:31:54 archlinux kded5[709]: "No such interface “org.freedesktop.DBus.Properties” on object at path /org/freedesktop/NetworkManager/ActiveConnection/23"
Apr 06 17:36:58 archlinux NetworkManager[393]: <info>  [1617710818.0700] device (wlan0): set-hw-addr: set MAC address to 7A:D8:56:23:AF:A7 (scanning)
Apr 06 17:36:58 archlinux NetworkManager[393]: <info>  [1617710818.0779] device (wlan0): supplicant interface state: inactive -> interface_disabled
Apr 06 17:36:58 archlinux NetworkManager[393]: <info>  [1617710818.0780] device (p2p-dev-wlan0): supplicant management interface state: inactive -> interface_disabled
Apr 06 17:36:58 archlinux NetworkManager[393]: <info>  [1617710818.1148] device (wlan0): supplicant interface state: interface_disabled -> inactive
Apr 06 17:36:58 archlinux NetworkManager[393]: <info>  [1617710818.1149] device (p2p-dev-wlan0): supplicant management interface state: interface_disabled -> inactive


the output of lspci:-

03:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

the output of dmesg

[ 8661.665647] wlan0: authenticate with 62:98:cc:60:77:52
[ 8661.720737] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 8662.885768] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 8663.895579] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 8664.882093] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 8687.874453] wlan0: authenticate with 62:98:cc:60:77:52
[ 8687.929361] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 8688.855068] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 8689.814851] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 8690.851354] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 8703.081056] wlan0: authenticate with 62:98:cc:60:77:52
[ 8703.237025] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 8703.862704] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 8704.875838] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 8705.835736] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 8724.027722] wlan0: authenticate with 62:98:cc:60:77:52
[ 8724.082902] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 8724.796057] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 8725.825340] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 8726.845714] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 8739.866134] wlan0: authenticate with 62:98:cc:60:77:52
[ 8739.921145] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 8740.843474] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 8741.883359] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 8742.843184] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 9065.253378] wlan0: authenticate with 62:98:cc:60:77:52
[ 9065.307841] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 9066.739023] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 9067.832233] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 9068.792067] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 9090.776436] wlan0: authenticate with 62:98:cc:60:77:52
[ 9090.831789] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 9091.801759] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 9092.814925] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 9093.828067] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 9116.795737] wlan0: authenticate with 62:98:cc:60:77:52
[ 9116.850469] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 9117.770984] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 9118.810797] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 9119.824006] wlan0: authentication with 62:98:cc:60:77:52 timed out
[ 9142.788279] wlan0: authenticate with 62:98:cc:60:77:52
[ 9142.843474] wlan0: send auth to 62:98:cc:60:77:52 (try 1/3)
[ 9143.766872] wlan0: send auth to 62:98:cc:60:77:52 (try 2/3)
[ 9144.806758] wlan0: send auth to 62:98:cc:60:77:52 (try 3/3)
[ 9145.770086] wlan0: authentication with 62:98:cc:60:77:52 timed out


please tell what is the issue which service is not able to start properly after sleep or after reboot.

Offline

#5 2021-04-06 16:13:00

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,239
Website

Re: [SOLVED] NetworkManager fails to connect to WiFi

This topic is almost two years old and marked as solved. Please do not necrobump. Also, please use code tags for terminal output.

Mod note: closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB