You are not logged in.

#1 2019-08-01 12:40:41

Nagidal
Member
Registered: 2019-08-01
Posts: 6

[Solved:] netctl-auto takes over 30 seconds to connect during boot

I have a fresh Arch Linux installation after having followed the installation guide. I have used wifi-menu to create a wifi profile, which I have later modified and successfully tried with netctl. I have then decided to disable and stop netctl, to start/enable netctl-auto. It also works, but both netctl and netctl-auto need a suspiciously long time to connect to the wifi during boot. A

systemd-analyze blame

showed me that

netctl-auto@wlp2s0.service

took 31.361s. This also happens after I have given the wifi profile higher priority (Priority=1). What reasons could there be for so much time spent on the wireless connection?

I have checked its

systemctl status

here's a screenshot of it: https://imgur.com/a/k5oNOZb
There is a 20 seconds gap between loading the profile and using it.

Last edited by Nagidal (2019-08-01 16:09:27)

Offline

#2 2019-08-01 13:21:35

seth
Member
Registered: 2012-09-03
Posts: 13,073

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

Please always post text, not screenshots of text.
In this case, make the text your complete journal of a boot (sudo journalctl -b, you can use https://wiki.archlinux.org/index.php/Pastebin)

Edit: stupid autolink

Last edited by seth (2019-08-01 13:22:04)

Offline

#3 2019-08-01 13:32:33

Nagidal
Member
Registered: 2019-08-01
Posts: 6

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

I wish I had an easy way to get the text. I have not setup ssh access yet, and I did not teach it to read ntfs thumb drives. I have no GUI installed yet, it's pure command line, so I cannot use internet browser yet. My other machine is Windows which does not read ext4 file systems. Any ideas how I can easily copy paste text from there to here?

Last edited by Nagidal (2019-08-01 13:32:57)

Offline

#4 2019-08-01 13:36:04

seth
Member
Registered: 2012-09-03
Posts: 13,073

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

Try to click the link I posted…

Offline

#5 2019-08-01 14:35:21

rsmarples
Member
Registered: 2009-05-12
Posts: 229

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

Just use termbin! Only requires netcat and not some silly custom client.
Works on all OS!

nc termbin.com 9999 </path/to/some/file

or

somecommand | nc termbin.com 9999

And incase you're wondering, 9999 is the port nc connects to on the host termbin.com

Offline

#6 2019-08-01 15:00:24

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,375
Website

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

rsmarples, no "silly custom clients" have been mentioned.  But yours does require a package that isn't in a base install.  The several options in the linked wiki page require nothing other than a base install.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#7 2019-08-01 15:06:01

Nagidal
Member
Registered: 2019-08-01
Posts: 6

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

seth wrote:

Try to click the link I posted…

Thank you, that works fantastic. I had no idea there are such services! Here's the output of the journalctl -b

http://ix.io/1Qgt

Offline

#8 2019-08-01 15:20:24

seth
Member
Registered: 2012-09-03
Posts: 13,073

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

Aug 01 14:51:54 lappi systemd[1]: systemd-rfkill.service: Succeeded.
Aug 01 14:52:19 lappi kernel: random: crng init done
Aug 01 14:52:19 lappi kernel: random: 1 urandom warning(s) missed due to ratelimiting

https://wiki.archlinux.org/index.php/Haveged
Your cpu should also support https://bbs.archlinux.org/viewtopic.php … 2#p1816982

Offline

#9 2019-08-01 15:46:07

Nagidal
Member
Registered: 2019-08-01
Posts: 6

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

Wow, that helped. I have changed grub.cfg accordingly (http://ix.io/1QgD). The boot is now blazing fast. I never had such a fast-booting system. Thanks a lot, guys. I'm sure I'll be back with tons of other issues in about 10 days, when I find the time to progress with the setup.

Offline

#10 2019-08-01 15:47:46

seth
Member
Registered: 2012-09-03
Posts: 13,073

Re: [Solved:] netctl-auto takes over 30 seconds to connect during boot

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

Board footer

Powered by FluxBB