You are not logged in.

#1 2019-08-10 16:17:46

Registered: 2017-07-24
Posts: 6

No keyboard in emergency shell

So i have just installed Arch Linux on my Dell R720xd server and used ZFS for the root filesystem. ZFS is added using DKMS.
For some strange reason it does not load the ZFS kernel modules and drops into an emergency shell. This is also fine as I can then load the modules with "modprobe zfs" and then import the root zpool.
However, there is one small problem. The keyboard does not work. I have tried different USB keyboards and even through the iDRAC.
Looked around and it seemed to be an issue with systemd and that it should downgrade from 242 to 239. Tried this and no change

Using systemd-boot as the bootloader and booting with UEFI

Does anyone know how to fix the keyboard issue?

Last edited by kenneth_h93 (2019-08-11 10:53:09)


#2 2019-08-13 21:59:53

Registered: 2014-03-06
Posts: 11,247

Re: No keyboard in emergency shell

What other hooks are in mkinitcpio.conf ?


#3 2020-07-21 05:55:43

Registered: 2012-05-07
Posts: 84

Re: No keyboard in emergency shell

Sorry to hijack this thread but I'm having the very same issue currently.

I'm trying to boot in emergency mode for some tests of mine, and that works. But I get no keyboard and once there I'm stuck and forced to press the power button.
It happens with but also init=/bin/bash (which I tried earlier).

Of course I have the "keyboard" hook in my mkinitcpio.conf.
I'm a bit confused, the keyboard is working in all other contexts (X session, but also GRUB, UEFI, etc.)


Board footer

Powered by FluxBB