You are not logged in.

#1 2019-08-10 16:17:46

kenneth_h93
Member
Registered: 2017-07-24
Posts: 6

No keyboard in emergency shell

Hi
So i have just installed Arch Linux on my Dell R720xd server and used ZFS for the root filesystem. ZFS is added using DKMS.
For some strange reason it does not load the ZFS kernel modules and drops into an emergency shell. This is also fine as I can then load the modules with "modprobe zfs" and then import the root zpool.
However, there is one small problem. The keyboard does not work. I have tried different USB keyboards and even through the iDRAC.
Looked around and it seemed to be an issue with systemd and that it should downgrade from 242 to 239. Tried this and no change

Using systemd-boot as the bootloader and booting with UEFI

Does anyone know how to fix the keyboard issue?

Last edited by kenneth_h93 (2019-08-11 10:53:09)

Offline

#2 2019-08-13 21:59:53

loqs
Member
Registered: 2014-03-06
Posts: 8,823

Re: No keyboard in emergency shell

What other hooks are in mkinitcpio.conf ?

Offline

Board footer

Powered by FluxBB