You are not logged in.

#1 2019-08-11 14:47:53

l3l00
Member
Registered: 2018-01-18
Posts: 33

[Solved] NetworkManager OpenVPN VPN secrets #3: No agents we

Okay I give up, what am I doing wrong? I am importing a .ovpn, I am certain I have the user & pass correct and the .ovpn is current. When I turn it on I get the following message when checking journalctl -f NetworkManager

Aug 11 08:44:34 hName kernel: audit: type=1111 audit(1565534674.433:99): pid=582 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-activate uuid=aa0e71b1-dfa5-47ac-a341-4c0390c86a9e name="anonvpn(1)" pid=1227 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
Aug 11 08:44:34 hName NetworkManager[582]: <info>  [1565534674.4383] audit: op="connection-activate" uuid="aa0e71b1-dfa5-47ac-a341-4c0390c86a9e" name="anonvpn(1)" pid=1227 uid=1000 result="success"
Aug 11 08:44:34 hName NetworkManager[582]: <info>  [1565534674.4439] vpn-connection[0x56436866c0a0,aa0e71b1-dfa5-47ac-a341-4c0390c86a9e,"anonvpn(1)",0]: Started the VPN service, PID 6419
Aug 11 08:44:34 hName NetworkManager[582]: <info>  [1565534674.4571] vpn-connection[0x56436866c0a0,aa0e71b1-dfa5-47ac-a341-4c0390c86a9e,"anonvpn(1)",0]: Saw the service appear; activating connection
Aug 11 08:44:34 hName NetworkManager[582]: <error> [1565534674.6111] vpn-connection[0x56436866c0a0,aa0e71b1-dfa5-47ac-a341-4c0390c86a9e,"anonvpn(1)",0]: Failed to request VPN secrets #3: No agents were available for this request.
Aug 11 08:44:34 hName NetworkManager[582]: <info>  [1565534674.6173] vpn-connection[0x56436866c0a0,aa0e71b1-dfa5-47ac-a341-4c0390c86a9e,"anonvpn(1)",0]: VPN plugin: state changed: stopped (6)

I have NetworkManager, installed rtl88xxau-aircrack-dkms-git for my netgear 802.11ac.
I have installed:

$ pacman -Qs networkmanager
local/lib32-libnm-glib 1.18.2-1
    NetworkManager client library (legacy)
local/libnm 1.20.0-1
    NetworkManager client library
local/libnm-glib 1.18.2-1
    NetworkManager client library (legacy)
local/libnma 1.8.22-1
    NetworkManager GUI client library
local/networkmanager 1.20.0-1 (gnome)
    Network connection manager and user applications
local/networkmanager-openconnect 1.2.6-1
    NetworkManager VPN plugin for OpenConnect
local/networkmanager-openvpn 1.8.10-1
    NetworkManager VPN plugin for OpenVPN
local/nm-connection-editor 1.8.22-1
    NetworkManager GUI connection editor and widgets

Resources I checked:
https://bugzilla.redhat.com/show_bug.cgi?id=1394977
https://wiki.archlinux.org/index.php/NetworkManager

Checking the Arch wiki, I did come across this but had no success.

VPN not working in GNOME
When setting up OpenConnect or vpnc connections in NetworkManager while using GNOME, you will sometimes never see the dialog box pop up and the following error appears in /var/log/errors.log:

localhost NetworkManager[399]: <error> [1361719690.10506] [nm-vpn-connection.c:1405] get_secrets_cb(): Failed to request VPN secrets #3: (6) No agents were available for this request.

This is caused by the GNOME NM Applet expecting dialog scripts to be at /usr/lib/gnome-shell, when NetworkManager's packages put them in /usr/lib/networkmanager. As a "temporary" fix (this bug has been around for a while now), make the following symlink(s):
    For OpenConnect: ln -s /usr/lib/networkmanager/nm-openconnect-auth-dialog /usr/lib/gnome-shell/
    For VPNC (i.e. Cisco VPN): ln -s /usr/lib/networkmanager/nm-vpnc-auth-dialog /usr/lib/gnome-shell/

PS - Also attempting to load it on a standard user, would this be an issue as well? When hovering over the password input field on the right icon of a person it says it is storing the password only for this user.

Last edited by l3l00 (2019-08-11 20:33:56)

Offline

#2 2019-08-11 20:33:29

l3l00
Member
Registered: 2018-01-18
Posts: 33

Re: [Solved] NetworkManager OpenVPN VPN secrets #3: No agents we

Turns out saving password for everyone was the solution.

Offline

Board footer

Powered by FluxBB