You are not logged in.

#1 2019-09-07 19:20:16

honeyplease
Member
Registered: 2013-09-07
Posts: 27

[Solved] Wifi only starts if I open the networks widget (?)

* Wifi was working fine for a couple of years, I noticed this strange bug around the update to kernel 5.0, not sure if related.
* Every time I restart my laptop, fire up browser, no wifi. I have to click on the wifi widget, I see 0kb/s up and down, but immediately starts showing activity when I click on it. After some attempts of reloading my browser, it (apparently randomly) connects.
* Whenever the screensaver kicks in, same thing happens.
* As long as I'm using my laptop once it's connected, wifi works normally and doesn't drop.

3: wlp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000

It _seems_ this is somehow relate to the GUI / network manager widget but I cannot understand what is going on.

The Network Debugging section of the wiki is mostly focused on debugging a lack of wifi, unless I'm missing something there isn't anything too useful  for me there.

Haven't found much online so I'm guessing its not a very common issue. I was hoping it was some bug that would be taken care of but it has been a few months already and it is very annoying.

Anybody here with a similar issue? How can I go about troubleshooting this annoying bug?

Thanks

Last edited by honeyplease (2019-09-11 01:15:55)

Offline

#2 2019-09-07 19:32:12

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,763

Re: [Solved] Wifi only starts if I open the networks widget (?)

Are you using NetworkManager ?

It _seems_ this is somehow relate to the GUI / network manager widget

is the only clue you give us as to what you are using to control your network.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2019-09-07 19:54:44

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

My bad, yes, NetworkManager, kernel 5.2.11, all packages up to date.

Offline

#4 2019-09-08 00:13:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,763

Re: [Solved] Wifi only starts if I open the networks widget (?)

Okay, as a sanity check, what is the output of

systemctl list-unit-files --state=enabled

?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2019-09-08 00:58:04

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

UNIT FILE                                   STATE 
autovt@.service                             enabled
bluetooth.service                           enabled
bumblebeed.service                          enabled
cronie.service                              enabled
dbus-org.bluez.service                      enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
dbus-org.freedesktop.resolve1.service       enabled
getty@.service                              enabled
NetworkManager-dispatcher.service           enabled
NetworkManager.service                      enabled
systemd-resolved.service                    enabled
systemd-timesyncd.service                   enabled
sshd.socket                                 enabled
remote-fs.target                            enabled

I am using the machine at issue right now, wifi works fine once it gets going. Thanks.

Offline

#6 2019-09-08 12:12:37

d_fajardo
Member
Registered: 2017-07-28
Posts: 480

Re: [Solved] Wifi only starts if I open the networks widget (?)

This might be related to polkit.

NetworkManager (org.freedesktop.NetworkManager.policy) actions regulated by polkit include turning on and off the network, wifi or mobile broadband.

taken from here.

Offline

#7 2019-09-08 15:33:47

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

Polkit Network Manager Settings

These are my (abridged) settings in my file

 /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy

Does anything look like it might be causing this?

Thanks

Offline

#8 2019-09-08 17:56:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,600

Re: [Solved] Wifi only starts if I open the networks widget (?)

Where are you storing your connection secrets? You need to have the widget open in some way if you use gnome-keyring (or if on KDE, kwallet) so that NM can get your secrets for the connection from  there. Either way, post logs, at minimum a

journalctl -b --unit=NetworkManager

but for proper diagnosis we likely need more context and hence a

journalctl -b

would be better.

Offline

#9 2019-09-08 18:15:59

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

Here it is:

journalctl -b

Edit: I just realized I don't have the kwalletmanager GUI (but I can see the daemon), I'm not entirely sure how secrets are being saved. Every time I start my machine I input my user password to access wifi secrets, I think.

Last edited by honeyplease (2019-09-08 18:20:42)

Offline

#10 2019-09-08 18:32:29

seth
Member
Registered: 2012-09-03
Posts: 12,674

Re: [Solved] Wifi only starts if I open the networks widget (?)

Since you're not in the "wheel" group, run "sudo journalctl -b" (you only provided the session journal which doesn't help much here)

Offline

#11 2019-09-08 21:05:01

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

My bad here it is (in two parts due to kb limit in pastebin):

Part 1

Part 2

Offline

#12 2019-09-08 21:34:55

seth
Member
Registered: 2012-09-03
Posts: 12,674

Re: [Solved] Wifi only starts if I open the networks widget (?)

Sep 07 16:01:04 xxx NetworkManager[552]: <info>  [1567886464.9040] device (wlp8s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Sep 07 16:01:04 xxx NetworkManager[552]: <info>  [1567886464.9041] sup-iface[0x55da94fb4920,wlp8s0]: wps: type pbc start...
Sep 07 16:01:04 xxx NetworkManager[552]: <warn>  [1567886464.9051] device (wlp8s0): no secrets: No agents were available for this request.
Sep 07 16:01:04 xxx NetworkManager[552]: <info>  [1567886464.9051] device (wlp8s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
…
Sep 07 16:02:15 xxx dbus-daemon[638]: [session uid=1000 pid=638] Activating service name='org.kde.kwalletd5' requested by ':1.5' (uid=1000 pid=669 comm="kded5 [kdeinit5]                                  ")
Sep 07 16:02:15 xxx dbus-daemon[638]: [session uid=1000 pid=638] Successfully activated service 'org.kde.kwalletd5'
Sep 07 16:02:15 xxx kwalletd5[937]: Icon theme "gnome" not found.
Sep 07 16:02:17 xxx kwalletd5[937]: Application ' "kded5" ' using kwallet without parent window!
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.8999] device (wlp8s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.9011] device (wlp8s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.9018] device (wlp8s0): Activation: (wifi) connection 'mucho wifi' has security, and secrets exist.  No new secrets needed.
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.9018] Config: added 'ssid' value 'mucho wifi'
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.9019] Config: added 'scan_ssid' value '1'
…
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.9886] device (wlp8s0): supplicant interface state: 4-way handshake -> completed
Sep 07 16:02:21 xxx NetworkManager[552]: <info>  [1567886541.9887] device (wlp8s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "mucho wifi"

tl;dr - connection fails, kwallet gets dbus activated and immediately afterwards the connection succeeds.

=> Autostart kwalletd5 explicitly w/ the session.

Offline

#13 2019-09-09 00:55:42

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

Thanks! I enabled kwallet as suggested and it seems to be working! Lifesaver, hopefully it stays like this.

Thanks again for your time everyone.

Offline

#14 2019-09-09 23:53:42

honeyplease
Member
Registered: 2013-09-07
Posts: 27

Re: [Solved] Wifi only starts if I open the networks widget (?)

My apologies for reopening this thread. I just rebooted my laptop coming back from work and the problem persists --haven't checked what happens when system goes idle but it did happen upon booting. I thought I had explicitly enabled kwalletd5 with the session by clicking on the "Enable KDE wallet subsystem" in the KDE Wallet box under system settings.

If I run a

ps -e | grep kwalletd5

I can see the process has been started, so I'm not entirely sure what I missed. In case it helps, here is my system log (short since I just booted the computer).

journalctl -b

Thanks,

Edit: I'm sure for advanced users here this will obvious from the help I got yesterday from my logs, but I am testing the machine and I notice this: the system goes to sleep, and when I wake it up, wifi doesn't work anymore for browser (per original question), however Spotify has been playing for a good 20 minutes (so it is not possible that I was just hearing an audio buffer) while the machine was idle with a screen off. When I woke it up, Spotify was still playing even though the browser could not access wifi, so this seems to be app/process specific.

Last edited by honeyplease (2019-09-10 00:23:14)

Offline

#15 2019-09-10 06:45:42

seth
Member
Registered: 2012-09-03
Posts: 12,674

Re: [Solved] Wifi only starts if I open the networks widget (?)

Did you look at it?

Sep 09 19:32:02 xxx login[519]: pam_unix(login:session): session opened for user monorhesus by LOGIN(uid=0)
…
Sep 09 19:32:02 xxx NetworkManager[505]: <info>  [1568071922.5159] device (wlp8s0): Activation: (wifi) access point 'mucho wifi_2.4' has security, but secrets are required.
…
Sep 09 19:33:31 xxx NetworkManager[505]: <info>  [1568072011.4071] device (wlp8s0): Activation: (wifi) access point 'mucho wifi_2.4' has security, but secrets are required.
…
Sep 09 19:33:32 xxx dbus-daemon[583]: [session uid=1000 pid=583] Successfully activated service 'org.kde.kwalletd5'
…
Sep 09 19:33:40 xxx NetworkManager[505]: <info>  [1568072020.2756] device (wlp8s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "mucho wifi_2.4"

Exact same (or similar) situation. You log in, WiFi fails a couple of tiemes for creds, then kwalletd gets triggered and the next thing is your wifi gets up.
https://wiki.archlinux.org/index.php/KDE#Autostart

Offline

Board footer

Powered by FluxBB