You are not logged in.

#1 2019-09-09 16:41:07

Avocari
Member
Registered: 2019-05-04
Posts: 5

[Solved] Realtek RTL8821CE Problem with Fast Transition

Hi all,

So as of the last month, my University changed their setup for eduroam, which required me to reauthenticate with all my devices. So far so good everything works.
However on my Laptop (Lenovo IdeaPad L340-15API) I am no longer able to authenticate to the network, due to fast transition being enabled in eduroam.

I spoke to the administators and they briefly disabled this setting for the whole network, which fixed the problem, but because the traffic which the authentication at all repeaters on the whole campus will produce this way would be too big, this is no solution sadly.

I have, as the title states, a Realtek PCIe Wireless Network Adapter using RTL8821CE 802-11ac (already installed the most recent diver)
lspci:

01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

I also tried an external usb wifi adapter, but the same error happens. But my configuration for the network is working, since it was done by a "standard" script which other collegues of mine are also using.
I also  copied the exact settings (including certificates, ...) from a friend of mine, who can authenticate in the network and those also do not work.

Generally I can connect to different Wifi's though, it is just the eduroam from my campus which does not work.
EDIT: I am using NetworkManager for my connections

So my question this far would be, do you know of a method to authenticate to the network, fixing this error? I as of yet did not find any solution online to this topic.
Do you need any more information from me? Since this is one of my first forum posts I am not quite sure what else would be useful to you.

Last edited by Avocari (2019-09-10 11:11:10)

Offline

#2 2019-09-10 07:05:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,256

Re: [Solved] Realtek RTL8821CE Problem with Fast Transition

Post logs after a connection attempt

sudo journalctl -b --unit=NetworkManager #At a minimum
sudo journalctl -b #Would be better for more relevant context

Offline

#3 2019-09-10 07:36:53

seth
Member
Registered: 2012-09-03
Posts: 12,290

Re: [Solved] Realtek RTL8821CE Problem with Fast Transition

https://gitlab.freedesktop.org/NetworkM … requests/6
https://gitlab.freedesktop.org/NetworkM … r/issues/4

Seems closed upstream a month ago.

Using wpa_supplicant directly should™ work using key_mgmt either FT-PSK or FT-EAP (depending on what your network uses)

nb. that there are security risks around this feature, but that's probably not your concern.

Offline

#4 2019-09-10 10:18:03

Avocari
Member
Registered: 2019-05-04
Posts: 5

Re: [Solved] Realtek RTL8821CE Problem with Fast Transition

So thank you first of all for your replies:

My journalctl output:

Sep 10 12:15:00 cletop wpa_supplicant[786]: wlp1s0: CTRL-EVENT-DISCONNECTED bssid=a0:ec:f9:68:57:de reason=3 locally_generated=1
Sep 10 12:15:00 cletop wpa_supplicant[786]: wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="eduroam" auth_failures=1 duration=10 reason=AUTH_FAILED
Sep 10 12:15:00 cletop wpa_supplicant[786]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/0
Sep 10 12:15:00 cletop wpa_supplicant[786]: wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Sep 10 12:15:00 cletop NetworkManager[657]: <warn>  [1568110500.1837] sup-iface[0x5555fdf7f100,wlp1s0]: connection disconnected (reason -3)
Sep 10 12:15:00 cletop NetworkManager[657]: <info>  [1568110500.1890] device (wlp1s0): supplicant interface state: associated -> disconnected
Sep 10 12:15:00 cletop NetworkManager[657]: <info>  [1568110500.1891] device (p2p-dev-wlp1s0): supplicant management interface state: associated -> disconnected
Sep 10 12:15:00 cletop kernel: RTW: cfg80211_rtw_scan(wlp1s0)
Sep 10 12:15:00 cletop kernel: RTW: [HW_VAR_CHECK_TXBUF] Empty in 0 ms
Sep 10 12:15:00 cletop kernel: RTW: wlp1s0 sleep m0=0x00000002, ori reg_0x4d4=0x00000000
Sep 10 12:15:00 cletop NetworkManager[657]: <info>  [1568110500.2894] device (wlp1s0): supplicant interface state: disconnected -> scanning
Sep 10 12:15:00 cletop NetworkManager[657]: <info>  [1568110500.2895] device (p2p-dev-wlp1s0): supplicant management interface state: disconnected -> scanning

The only thing I can see for myself is that the Authentication Failed (but wrong password is not the error here, just want to state that)

Thnk you seth for your reply, I will have a look at this!

Cheers, Avocari

Last edited by Avocari (2019-09-10 10:18:24)

Offline

#5 2019-09-10 11:10:32

Avocari
Member
Registered: 2019-05-04
Posts: 5

Re: [Solved] Realtek RTL8821CE Problem with Fast Transition

@seth Thank you that gitlab issue solved it for me!

Offline

Board footer

Powered by FluxBB