You are not logged in.

#1 2019-09-21 00:07:03

nefas
Member
Registered: 2016-07-16
Posts: 11

ethernet: device not managed

Hi,

Since recently, network-manager doesn't manage to use ethernet. It print the message device not managed. Those error message started around a week ago (the 13/09/2019) and they appears seemingly randomly after some reboot.
If network-manager can connect to wired network, it will work until shutdown. If it doesn't, restarting the service doesn't do anything (I haven't try to just restart the service a lot of time when the error message appear, yet).
I've tried to use wicd to connect to the network using ethernet when network-manager didn't work but wicd didn't work either. It just failed to connect using ethernet.
At first I thought it was an issue coming from rebooting from windows 10 but deactivating fast boot and hibernation (in windows 10) changed nothing.
I've done some updates before the issue started but none of them seem to be responsible for it (pacman's log is linked below) I don't know what log file or config file would be relevant to this issue.

What is causing this issue and how could I fix it.

Thank your for taking time to help me.

files:
pacman's log from the 21/09/2019

Offline

#2 2019-09-21 07:39:30

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: ethernet: device not managed

Post the outputs of "lspci", "ip a", "sudo journalctl -b" and "systemctl list-unit-files --state=enabled" from a boot where this problem occurs.

Offline

#3 2019-09-22 01:27:04

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

Here are the output of:
lspci
ip a
sudo journalctl -b
systemctl list-unit-files --state=enabled

Last edited by nefas (2019-09-22 01:27:18)

Offline

#4 2019-09-22 06:56:28

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: ethernet: device not managed

dhcpcd.service                              enabled
…
NetworkManager-dispatcher.service           enabled
NetworkManager.service                      enabled

Don't run competing network managing daemons, as pointed out in the wiki, they'll race over the interfaces and knock each other out.
The interface is there, up and has a carrier - so there's no actual problem.

Offline

#5 2019-09-22 23:24:21

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

I still have the same issue when dhcpcd is disabled.

Offline

#6 2019-09-22 23:26:38

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: ethernet: device not managed

Updated journal?

Offline

#7 2019-09-22 23:28:36

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

updated journal

Last edited by nefas (2019-09-22 23:29:00)

Offline

#8 2019-09-23 07:38:27

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: ethernet: device not managed

sept. 23 01:15:36 marvin kernel: r8169 0000:03:00.1 eth0: RTL8411, 80:fa:5b:45:b5:d2, XID 5c800800, IRQ 126
sept. 23 01:15:36 marvin kernel: r8169 0000:03:00.1 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
…
sept. 23 01:15:36 marvin kernel: IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
sept. 23 01:15:36 marvin kernel: r8169 0000:03:00.1 eth0: Link is Down
…
sept. 23 01:15:37 marvin systemd-udevd[322]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
sept. 23 01:15:37 marvin systemd-udevd[322]: eth0: Failed to rename network interface 2 from 'eth0' to 'enp3s0f1': Device or resource busy
sept. 23 01:15:37 marvin systemd-udevd[322]: eth0: Failed to process device, ignoring: Device or resource busy
…
sept. 23 01:15:40 marvin kernel: r8169 0000:03:00.1 eth0: Link is Up - 1Gbps/Full - flow control rx/tx
sept. 23 01:15:40 marvin kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
…
sept. 23 01:15:44 marvin NetworkManager[8343]: <info>  [1569194144.6700] NetworkManager (version 1.20.2-1) is starting... (for the first time)
…
sept. 23 01:15:45 marvin NetworkManager[8343]: <info>  [1569194145.6335] device (eth0): carrier: link connected
sept. 23 01:15:45 marvin NetworkManager[8343]: <info>  [1569194145.6340] manager: (eth0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/3)

I assume NM somehow complains/fails on the unrenamed interface, but that's probably a NM config thing - it does add the device, it just doesn't do anything with it.
Did you add/edit a udev rule for the interface (involving ethtool)?

Offline

#9 2019-09-23 09:33:25

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

I haven't changed any udev rule for that interface. The interface did changed name from enp3s0f1 to eth0, I don't know when or why, but nm's tool (nmcli device for example) show the right name (eth0) for ethernet.

EDIT:


I've tried to use wicd instead of networkmanager (I've stopped nm before starting wicd). Here are the log.

nmcli device output this:

DEVICE          TYPE      STATE         CONNECTION 
wlp4s0          wifi      connected     WifiMimi   
p2p-dev-wlp4s0  wifi-p2p  disconnected  --         
eth0            ethernet  unmanaged     --         
lo              loopback  unmanaged     --  

Last edited by nefas (2019-09-23 09:59:16)

Offline

#10 2019-09-23 13:11:36

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: ethernet: device not managed

Try stopping NM and the run "sudo dhcpcd -B eth0", see whether you get a connection (wicd gets a lease on eth0, but struggles w/ wlp4s0, then commits suicide…)
idk why NM would ignore eth0 (because I don't use NM) but would suggest to inspect and/or reset its configuration. Typically this would have been enforced in /etc/NetworkManager/conf.d/unmanaged.conf but the inability to edit the NICs name is still suspicious.

Offline

#11 2019-09-23 15:38:16

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

dhcpcd get a connection. I'll try to reset NM's configuration but I don't remember having modified it (at the interface level, I've only changed some parameters like password, ...)

EDIT When I tried to use wicd, I've disabled the wifi to have an easier time finding the wired connection (I'm not used to wicd's interface and I can connect to a lot of wifi)

Last edited by nefas (2019-09-23 15:56:18)

Offline

#12 2019-09-23 17:17:05

Zod
Member
From: Hoosiertucky
Registered: 2019-03-10
Posts: 343

Re: ethernet: device not managed

/etc/networkmanager/networkmanager.conf


unmanaged-devices=mac:<hwaddr>;mac:<hwaddr>;...
Set devices that should be ignored by NetworkManager when using the keyfile plugin. Devices are specified in the following format: "mac:<hwaddr>", where <hwaddr> is MAC address of the device to be ignored, in hex-digits-and-colons notation. Multiple entries are separated by a semicolon. No spaces are allowed in the value. Example: unmanaged-devices=mac:00:22:68:1c:59:b1;mac:00:1E:65:30:D1:C4


managed=false | true
Controls whether interfaces listed in the 'interfaces' file are managed by NetworkManager. If set to true, then interfaces listed in /etc/network/interfaces are managed by NetworkManager. If set to false, then any interface listed in /etc/network/interfaces will be ignored by NetworkManager. Remember that NetworkManager controls the default route, so because the interface is ignored, NetworkManager may assign the default route to some other interface. When the option is missing, false value is taken as default.

Offline

#13 2019-09-23 18:16:41

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

Maybe it's a stupid question but should I list eth0 as unmanaged? If yes, why? It never was in that list before the issue appears

I've got nothing in /etc/network/interfaces (I don't even have /etc/network). I've tried to set managed to true but it just made nm fail to start (and it would make sense to set this option with no interface in /etc/network/interfaces (if I understood correctly what it does)).

I've completely uninstalled nm, removed the config files and installed it again (to reset it's configuration) without any effect.

Offline

#14 2019-09-23 20:02:56

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: ethernet: device not managed

No, absolutely not. But you could try to explicitly set it to managed.
Still suspecting the failing name change to be the cause.

Offline

#15 2019-10-03 11:07:06

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

Are you talking about using

managed=true

? If you are, I tried to do that but it only made nm fail to start. I can send you nm's log when I set managed to true (a bit later since I'm currently away from my computer).

Offline

#16 2020-04-04 18:08:58

ZaheenJ
Member
Registered: 2020-04-04
Posts: 18

Re: ethernet: device not managed

I have the same problem as you. My ethernet device is usually named enp3s0, but sometimes after turning on my computer I see it's name has changed to eth0. Sometimes eth0 still works, but it doesn't work a lot of the time and the only way I can fix it is by rebooting. Have you found a better way?

Offline

#17 2020-04-05 10:01:58

nefas
Member
Registered: 2016-07-16
Posts: 11

Re: ethernet: device not managed

Sadly, I haven't found any fix for this issue.

Currently, If I boot and log in without the power cord being plugged in, I have no issue and can use ethernet. If I plug the power cord before logging in, I have the "device not managed" error. I haven't had a lot of time to do research on why.

Offline

#18 2020-04-26 21:13:51

ZaheenJ
Member
Registered: 2020-04-04
Posts: 18

Re: ethernet: device not managed

After looking for Network manager in journal logs, I found a warning that "/proc/sys/net/ipv4/conf/eth0/rp_filter is set to 1. This might break connectivity checking for IPv4 on this device."  So I changed that to 0 but it didn't work. The I went to /usr/lib/sysctl.d/50-default.conf and saw that the section relating to rp_filter looked like this:

# Source route verification
net.ipv4.conf.default.rp_filter = 2
net.ipv4.conf.*.rp_filter = 2
-net.ipv4.conf.all.rp_filter

But, /proc/sys/net/ipv4/conf/eth0/rp_filter was still set to 1 even though it should be set to 2. I tried using /etc/systctl.d/90-override.conf to change those values to 0, but that didn't work either. I ended up meeting the 50-default.conf file directly and changing the 2s to 0s. After all of that it worked. What's even stranger is that /proc/sys/net/ipv4/conf/eth0/rp_filter is still set to 1 after rebooting, but it still works. The recommended value by redhat is 2, but 2 has no effect. Something is wrong here, but I don't know enough to figure out one. This is a temporary fix.
EDIT: I reinstalled systemd and networkmanager and everything just started working
EDIT 2: Not working anymore and had to change all the 2s back to 0s. Network manager still gives the rp_filter warning and the file is set to 1 but for some reason it works when the conf is 0

Last edited by ZaheenJ (2020-04-28 07:06:45)

Offline

#19 2020-05-13 08:32:28

ZaheenJ
Member
Registered: 2020-04-04
Posts: 18

Re: ethernet: device not managed

I am not sure what happened, but I haven't had the issue for a long time now(a couple weeks). I think whatever the problem was has been fixed.

Offline

Board footer

Powered by FluxBB