You are not logged in.

#1 2019-09-23 19:32:08

Xigi
Member
From: online
Registered: 2013-11-27
Posts: 15

zfs-linux cannot be upgraded due to unresolvable dependencies

I tried to update my system but got this from pacman..

6e4e79|OK  |   1.3MiB/s|/var/cache/pacman/pkg/linux-5.3.1.arch1-1-x86_64.pkg.tar.xz
ee87e7|OK  |   884KiB/s|/var/cache/pacman/pkg/firefox-69.0.1-1-x86_64.pkg.tar.xz

Status Legend:
(OK):download completed.
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "linux=5.3.arch1-1", a dependency of "zfs-linux"
:: The following package cannot be upgraded due to unresolvable dependencies:
      zfs-linux

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'linux=5.3.arch1-1' required by zfs-linux
Error installing repo packages
No pacnew files to update.

Offline

#2 2019-09-23 19:48:17

ayekat
Member
Registered: 2011-01-17
Posts: 1,347
Website

Re: zfs-linux cannot be upgraded due to unresolvable dependencies

zfs-linux is not part of the Arch Linux package repositories, which means you must have obtained it from somewhere else.

I assume you've built the package from the PKGBUILD in the AUR. As that PKGBUILD there very visibly states at the head, zfs-linux provides kernel modules, and therefore must be built for the exactly right kernel version. Whenever you upgrade your kernel, you need to rebuild and upgrade that package as well.


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#3 2019-09-23 20:44:27

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,040
Website

Re: zfs-linux cannot be upgraded due to unresolvable dependencies

Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB