You are not logged in.

#1 2019-10-26 22:44:55

curiousmitchell
Member
Registered: 2017-05-08
Posts: 20

Collabora Docker & Nextcloud Integration on apache

Hi folks, having a really difficult time getting Collabora working with Nextcloud. Would love some advice. Let me know if there's more information I haven't posted. Have spent a number of hours now scouring docs and playing with config files, but to no avail.

Here's my current setup - everything is up to date::

Apache
Docker
Nextcloud 16.0.5 (installed manually - not using arch package)
SSL via Lets Encrypt
MariaDB
Php  7.3.11

Collabora setup - have been attempting to follow instructions from the Nextcloud page re the officially supported docker container: https://nextcloud.com/collaboraonline/

Docker seems to be running fine - issue (as near as I can tell) is configuring my setup so that it works.

Under /etc/httpd/conf/extras I have the following files related to my installation:

httpd-default.conf   
httpd-ssl.conf
httpd-vhosts.conf
httpd-vhosts-le-ssl.conf

I have tried now editing versions of all these files with instructions from the nextcloud page, then restarting my httpd.service with no effect. The docker container is running, and I have enabled the collabora plugin in Nextcloud. As I am running a few domains/services on my server my main config file is: httpd-vhosts.conf

While I have tried editing all the above files in an effort to get this working, my most recent attempt was editing httpd-vhosts.conf Below is my setup in this file for the relevant section (have taken out my domain name for security):

-----------------------

<VirtualHost *:80>
    ServerAdmin "my_email"
    DocumentRoot "/srv/http"
    ServerName "my_domain_name"
    ErrorLog "/var/log/httpd/my_domain-error_log"
    CustomLog "/var/log/httpd/my_domain-access_log" common
RewriteEngine on
RewriteCond %{SERVER_NAME} =my_domain
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

# Encoded slashes need to be allowed
AllowEncodedSlashes NoDecode

# Container uses a unique non-signed certificate
SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

# keep the host
ProxyPreserveHost On

# static html, js, images, etc. served from loolwsd
# loleaflet is the client part of LibreOffice Online
ProxyPass           /loleaflet https://127.0.0.1:9980/loleaflet retry=0
ProxyPassReverse    /loleaflet https://127.0.0.1:9980/loleaflet

# WOPI discovery URL
ProxyPass           /hosting/discovery https://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse    /hosting/discovery https://127.0.0.1:9980/hosting/discovery

# Main websocket
ProxyPassMatch "/lool/(.*)/ws$" wss://127.0.0.1:9980/lool/$1/ws nocanon

# Admin Console websocket
ProxyPass   /lool/adminws wss://127.0.0.1:9980/lool/adminws

# Download as, Fullscreen presentation and Image upload operations
ProxyPass           /lool https://127.0.0.1:9980/lool
ProxyPassReverse    /lool https://127.0.0.1:9980/lool
</VirtualHost>

---------------------------

Part of the problem is I don't actually know what I'm doing. Which file do I need to be editing to get this to work? Are there additional services/processes which are Arch Specific that I'm missing here? All and any help is appreciated.

in terms of error messages and logs, I'm not able to find much. In the Nextcloud web gui, all I see is this:

In Nextcloud - "Failed to load Collabora Online, please try again later."

I've been trying to look in other logs to see any error messages, and there's nothing I can find that looks relevant. Have been looking under /var/log/httpd , and not seeing much that's useful. Neither ErrorLog or CustomLog files referenced above hold much joy.

Where do I go from here? Appreciate your advice.

Thanks

Offline

Board footer

Powered by FluxBB