You are not logged in.

#1 2019-11-09 04:13:04

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

[SOLVED] Unable to install rtl8723de drivers

Hi,

I recently installed Arch on my laptop (HP Laptop 15-db0xxx) and I tried to install the drivers following this : https://github.com/lwfinger/rtlwifi_new

And when I do the :

sudo modprobe -r <<YOUR WIRELESS DRIVER CODE>>
sudo modprobe <<YOUR WIRELESS DRIVER CODE>> 

Nothing happens, I get no output on the terminal and after reboot nothing changes

Last edited by Bojahdok (2019-11-09 19:08:11)

Offline

#2 2019-11-09 04:17:14

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,271
Website

Re: [SOLVED] Unable to install rtl8723de drivers

No output means the command was successful, the module was loaded.  Of course it is not loaded after the reboot.  So - based on what has been presented here - everything is as it should be.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2019-11-09 10:27:41

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

Re: [SOLVED] Unable to install rtl8723de drivers

Okay, so can you help me figure out why I can't use my wifi card ? Have I missed a step ? I really don't understand what I've been doing wrong, I've tried to connect to wireless network with wpa_supplicant using wpa_gui and wpa_cli (not at the same time obviously)

With wpa_gui every field is just blank, seems like it doesn't detect my card and it doesn't scan any network, and with wpa_cli I get this output :

Could not connect to wpa_supplicant: (nil) - re-trying

Thanks for your patience

Offline

#4 2019-11-09 12:54:04

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,271
Website

Re: [SOLVED] Unable to install rtl8723de drivers

First we'll need some background information.  Have you followed the wiki page?  If so, please post the results of the diagnostic/info-gathering steps there.  Specifically, the following would help:

lspci -vnn | grep -i net
ip a

The output of `ip a` from both before and after you use modprobe may also be useful.

Note that the only commands your initial post mentioned was the modprobe command, and there was no indication that this command wasn't doing precisely what it should.  The real problem, though, is that you're wireless isn't working.  But you've not provided any commands/output related to that.

Last edited by Trilby (2019-11-09 13:02:17)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2019-11-09 14:11:24

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

Re: [SOLVED] Unable to install rtl8723de drivers

I followed the first part of the wiki concerning the installation of the device driver and then I followed the WPA Supplicant page to try to connect to my network

Here's the output of lspci -vnn | grep -i net :

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
	Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:84ae]
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723DE 802.11b/g/n PCIe Adapter [10ec:d723]

And here's the output of ip a :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 10:62:e5:8c:3c:16 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 80:c5:f2:e3:5e:4b brd ff:ff:ff:ff:ff:ff
4: enp4s0f3u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 66:fc:49:37:d1:b9 brd ff:ff:ff:ff:ff:ff
    inet 192.168.42.5/24 brd 192.168.42.255 scope global enp4s0f3u2
       valid_lft forever preferred_lft forever
    inet6 fe80::64fc:49ff:fe37:d1b9/64 scope link 
       valid_lft forever preferred_lft forever

As you requested I tried to do the ip a command without the modprobe, and the wlo1 interface disappeared, so I guess that the modprobe command works and that my wireless card is recognized

Offline

#6 2019-11-09 14:31:30

seth
Member
Registered: 2012-09-03
Posts: 12,895

Re: [SOLVED] Unable to install rtl8723de drivers

The wifi chip is there, but not brought up.
Something however brought the ethernet chip up - how do you generally configure your network? (dhcpcd, networkmanager, systemd-networkd, connman, …)?
Stop that service and then attempt to connect w/ wifi-menu (part of netctl). From your output you didn't run wpa_supplicant or it failed for an unknown reason, wpa_cli cannot talk to it either way.

Offline

#7 2019-11-09 16:08:35

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

Re: [SOLVED] Unable to install rtl8723de drivers

wpa_supplicant wasn't running when I did the "ip a" command, and if you're talking about the "enp4s0f3u2" interface it's the one that comes from my phone when I share connexion via usb with it, I just plug it in, and run "sudo dhclient -v enp4s0f3u2" when I want to use it

Ok so I did what you told me to do, I released the address with "dhclient -r" and then I desactivated the card so it wouldn't interfere, I ran sudo wifi-menu and it successfully scanned networks, but here's another problem, only 3 networks appear and they are public networks provided by Free (Freewifi Secure, etc) and the "domestic" networks like mine doesn't appear, could it be a problem with the antennas ? Like their power is too weak ?

Offline

#8 2019-11-09 16:21:19

seth
Member
Registered: 2012-09-03
Posts: 12,895

Re: [SOLVED] Unable to install rtl8723de drivers

2.4GHz ./. 5GHz issue?

iw list

How far are you aware from your home AP, compared to the likely locations of the open WiFis?

Edit: Also

iw dev wlo1 scan

Last edited by seth (2019-11-09 16:23:38)

Offline

#9 2019-11-09 17:07:44

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

Re: [SOLVED] Unable to install rtl8723de drivers

Here's the output of iw list :

Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	max # scan plans: 1
	max scan plan interval: -1
	max scan plan iterations: 0
	RTS threshold: 2347
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports RSN-IBSS.
	Supported Ciphers:
		* WEP40 (00-0f-ac:1)
		* WEP104 (00-0f-ac:5)
		* TKIP (00-0f-ac:2)
		* CCMP-128 (00-0f-ac:4)
		* CCMP-256 (00-0f-ac:10)
		* GCMP-128 (00-0f-ac:8)
		* GCMP-256 (00-0f-ac:9)
		* CMAC (00-0f-ac:6)
		* CMAC-256 (00-0f-ac:13)
		* GMAC-128 (00-0f-ac:11)
		* GMAC-256 (00-0f-ac:12)
	Available Antennas: TX 0 RX 0
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 1:
		Capabilities: 0x186e
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			No RX STBC
			Max AMSDU length: 7935 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 16 usec (0x07)
		HT Max RX data rate: 150 Mbps
		HT TX/RX MCS rate indexes supported: 0-7, 32
		Bitrates (non-HT):
			* 1.0 Mbps
			* 2.0 Mbps
			* 5.5 Mbps
			* 11.0 Mbps
			* 6.0 Mbps
			* 9.0 Mbps
			* 12.0 Mbps
			* 18.0 Mbps
			* 24.0 Mbps
			* 36.0 Mbps
			* 48.0 Mbps
			* 54.0 Mbps
		Frequencies:
			* 2412 MHz [1] (20.0 dBm)
			* 2417 MHz [2] (20.0 dBm)
			* 2422 MHz [3] (20.0 dBm)
			* 2427 MHz [4] (20.0 dBm)
			* 2432 MHz [5] (20.0 dBm)
			* 2437 MHz [6] (20.0 dBm)
			* 2442 MHz [7] (20.0 dBm)
			* 2447 MHz [8] (20.0 dBm)
			* 2452 MHz [9] (20.0 dBm)
			* 2457 MHz [10] (20.0 dBm)
			* 2462 MHz [11] (20.0 dBm)
			* 2467 MHz [12] (20.0 dBm)
			* 2472 MHz [13] (20.0 dBm)
			* 2484 MHz [14] (20.0 dBm) (no IR)
	Supported commands:
		 * new_interface
		 * set_interface
		 * new_key
		 * start_ap
		 * new_station
		 * new_mpath
		 * set_mesh_config
		 * set_bss
		 * authenticate
		 * associate
		 * deauthenticate
		 * disassociate
		 * join_ibss
		 * join_mesh
		 * remain_on_channel
		 * set_tx_bitrate_mask
		 * frame
		 * frame_wait_cancel
		 * set_wiphy_netns
		 * set_channel
		 * set_wds_peer
		 * probe_client
		 * set_noack_map
		 * register_beacons
		 * start_p2p_device
		 * set_mcast_rate
		 * connect
		 * disconnect
		 * set_qos_map
		 * set_multicast_to_unicast
	Supported TX frame types:
		 * IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
	Supported RX frame types:
		 * IBSS: 0x40 0xb0 0xc0 0xd0
		 * managed: 0x40 0xd0
		 * AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * mesh point: 0xb0 0xc0 0xd0
		 * P2P-client: 0x40 0xd0
		 * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * P2P-device: 0x40 0xd0
	software interface modes (can always be added):
		 * AP/VLAN
		 * monitor
	interface combinations are not supported
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
	Device supports TX status socket option.
	Device supports HT-IBSS.
	Device supports SAE with AUTHENTICATE command
	Device supports low priority scan.
	Device supports scan flush.
	Device supports AP scan.
	Device supports per-vif TX power setting
	Driver supports full state transitions for AP/GO clients
	Driver supports a userspace MPM
	Device supports configuring vdev MAC-addr on create.
	Supported extended features:
		* [ RRM ]: RRM
		* [ FILS_STA ]: STA FILS (Fast Initial Link Setup)
		* [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211



And here's the output of iw dev wlo1 scan :

BSS f4:ca:e5:98:d3:bd(on wlo1)
	TSF: 1541117709492 usec (17d, 20:05:17)
	freq: 2412
	beacon interval: 96 TUs
	capability: ESS ShortSlotTime (0x0401)
	signal: -89.00 dBm
	last seen: 1134 ms ago
	SSID: FreeWifi
	Supported rates: 1.0* 2.0* 5.5* 11.0* 22.0 6.0 9.0 12.0 
	DS Parameter set: channel 1
	TIM: DTIM Count 0 DTIM Period 2 Bitmap Control 0x0 Bitmap[0] 0x0
	ERP: Barker_Preamble_Mode
	Extended supported rates: 18.0 24.0 36.0 48.0 54.0 
	HT capabilities:
		Capabilities: 0xec
			HT20
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			No RX STBC
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: No restriction (0x00)
		HT TX/RX MCS rate indexes supported: 0-23, 32
	HT operation:
		 * primary channel: 1
		 * secondary channel offset: no secondary
		 * STA channel width: 20 MHz
		 * RIFS: 0
		 * HT protection: no
		 * non-GF present: 1
		 * OBSS non-GF present: 0
		 * dual beacon: 0
		 * dual CTS protection: 0
		 * STBC beacon: 0
		 * L-SIG TXOP Prot: 0
		 * PCO active: 0
		 * PCO phase: 0
	Extended capabilities:
		 * Operating Mode Notification
	WMM:	 * Parameter version 1
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
BSS f4:ca:e5:98:d3:bc(on wlo1)
	TSF: 1541117706592 usec (17d, 20:05:17)
	freq: 2412
	beacon interval: 96 TUs
	capability: ESS Privacy ShortSlotTime (0x0411)
	signal: -85.00 dBm
	last seen: 1170 ms ago
	SSID: freebox_VURQDZ
	Supported rates: 1.0* 2.0* 5.5* 11.0* 22.0 6.0 9.0 12.0 
	DS Parameter set: channel 1
	TIM: DTIM Count 0 DTIM Period 2 Bitmap Control 0x0 Bitmap[0] 0x0
	ERP: Barker_Preamble_Mode
	Extended supported rates: 18.0 24.0 36.0 48.0 54.0 
	WPA:	 * Version: 1
		 * Group cipher: TKIP
		 * Pairwise ciphers: CCMP TKIP
		 * Authentication suites: PSK
	HT capabilities:
		Capabilities: 0xec
			HT20
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			No RX STBC
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: No restriction (0x00)
		HT TX/RX MCS rate indexes supported: 0-23, 32
	HT operation:
		 * primary channel: 1
		 * secondary channel offset: no secondary
		 * STA channel width: 20 MHz
		 * RIFS: 0
		 * HT protection: no
		 * non-GF present: 1
		 * OBSS non-GF present: 0
		 * dual beacon: 0
		 * dual CTS protection: 0
		 * STBC beacon: 0
		 * L-SIG TXOP Prot: 0
		 * PCO active: 0
		 * PCO phase: 0
	Extended capabilities:
		 * Operating Mode Notification
	WMM:	 * Parameter version 1
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec

I don't really know where the open WiFis are but my home AP is like 5-6 meters away behind a thin wall, it should'nt be a problem to detect it, I have a really good signal with my phone

Offline

#10 2019-11-09 17:12:09

seth
Member
Registered: 2012-09-03
Posts: 12,895

Re: [SOLVED] Unable to install rtl8723de drivers

The NIC only does 2.4GHz and (therefore) only finds 2.4GHz networks (with lousy signals)
Do you have any access (from your phone) to the desired AP? Can you inspect it from such device (or better: configure it)? Ensure it has 2.4GHz enabled.

Offline

#11 2019-11-09 17:27:59

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

Re: [SOLVED] Unable to install rtl8723de drivers

I'm connected to it with my phone, and it's on 2.4Ghz so it shouldn't be a problem

Offline

#12 2019-11-09 17:32:51

progandy
Member
Registered: 2012-05-17
Posts: 3,580

Re: [SOLVED] Unable to install rtl8723de drivers

could it be a problem with the antennas ?

Yes, it might be necessary for you to manually select the correct antenna with ant_sel=2 (or maybe ant_sel=1). HP is known for sometimes only connecting one antenna to the secondary antenna port instead of the first one.

This can be done with an options entry in modprobe.d

https://bbs.archlinux.org/viewtopic.php?id=208472
https://h30434.www3.hp.com/t5/Notebook- … -p/6477307

Last edited by progandy (2019-11-09 17:33:32)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#13 2019-11-09 19:07:56

Bojahdok
Member
Registered: 2019-06-27
Posts: 36

Re: [SOLVED] Unable to install rtl8723de drivers

Thanks !! I did that and now I'm able to connect to my home network

You guys rock I love this forum

Offline

Board footer

Powered by FluxBB