You are not logged in.

#1 2019-11-12 00:10:23

From: .nz
Registered: 2019-11-11
Posts: 1

Another LVM on LUKS booting problem using systemd

Very similar problem and attempted setup to Kernel Panic on Install with Encrypted Root except the solution did not work for me. I'm installing on a new SSD on a T420 laptop.

The wiki is great, have generally been following encrypting an entire LVM on LUKS system guide and I feel like I've now tried every combination of settings and possible interpretation of the docs. The testing cycle is arduous, because to do further research and reading, I pretty much need to swap the hard drive out again. It's arduous! I'll spare you the most of the details. I have my smartphone but it's not great for the wiki or forum.

I am trying new options by booting into the live environment, mounting my partitions (so yes successfully opening the encrypted ones), chrooting, then hacking. I run `mkinitcpio -P` when I make changes to mkinitcpio.conf and it runs with only a couple of warnings about wireless modules I may need. I don't generally run scripts like bootctl or genfstab unless I think I've changed something relevant to them. I have these packages explicitly installed: base linux linux-firmware lvm2 cryptsetup nano intel-ucode.

The message I see at boot is:

SHA256 validated
Failed to acquire RNG protocol: Not Found

and it hangs there.

After adding `debug` to the bootloader options, I see plenty that I don't know how to capture, the end of which is:

---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

So I'm just hoping it's something obvious to someone, so herewith follows my setup and configs. I've left some commented out lines in to show some of what I've tried and tested:

  • UEFI / GPT

  • systemd-boot with ESP == /boot

  • systemd init (have also tried busybox/udev and the bootloader options that required)

Reformatted, relevant output of `lsblk -f` (arrows did not encode):

NAME                      FSTYPE      LABEL       UUID                                   FSAVAIL FSUSE% MOUNTPOINT
  -> sda1                    vfat                    66D5-1E8A                                             
  -> sda2                    crypto_LUKS             dde6df6a-af19-47b8-aede-937369182db2                  
       -> sda2_crypt     LVM2_member             z1VnLS-Ykvw-1gad-ADr3-XHJ9-hJM7-4dR8DQ                
            -> VolGroup00-lvolroot ext4        ROOT        f255380f-5e83-4de8-a2a8-ac953e2e5b10                  
            -> VolGroup00-lvolvar  ext4        VAR         300082cc-2786-471b-8a68-7c2deaabe098                  
            -> VolGroup00-lvolswap swap                    78e05299-286a-4360-866c-dfae02822792                  
            -> VolGroup00-lvolhome ext4        HOME        2c9b0627-3577-4375-a821-f4bb6390f657                  

(also note these were not mounted when I captured this, mount points are predictable under /mnt)


title	Arch Linux
efi	/vmlinuz-linux
initrd	/intel-ucode.img
initrd	/initramfs-linux.img
# options	root=/dev/VolGroup00/lvolroot resume=/dev/VolGroup00/lvolswap
# options root=/dev/VolGroup00/lvolroot resume=/dev/VolGroup00/lvolswap
# options	rd.luks.uuid=dde6df6a-af19-47b8-aede-937369182db2=sda2_crypt root=/dev/VolGroup00/lvolroot resume=/dev/VolGroup00/lvolswap debug
# options	cryptdevice=UUID=dde6df6a-af19-47b8-aede-937369182db2:sda2_crypt root=/dev/VolGroup00/lvolroot resume=/dev/VolGroup00/lvolswap debug
options	rd.luks.uuid=dde6df6a-af19-47b8-aede-937369182db2=sda2_crypt root=/dev/VolGroup00/lvolroot debug


# Static information about the filesystems.
# See fstab(5) for details.

# /dev/mapper/VolGroup00-lvolroot LABEL=ROOT      /               ext4            rw,relatime     0 1   
UUID=f255380f-5e83-4de8-a2a8-ac953e2e5b10	/         	ext4      	rw,relatime	0 1

# /dev/mapper/VolGroup00-lvolvar LABEL=VAR        /var            ext4            rw,relatime     0 2
UUID=300082cc-2786-471b-8a68-7c2deaabe098	/var      	ext4      	rw,relatime	0 2

# /dev/mapper/VolGroup00-lvolhome LABEL=HOME      /home           ext4            rw,relatime     0 2
UUID=2c9b0627-3577-4375-a821-f4bb6390f657	/home     	ext4      	rw,relatime	0 2

# /dev/sda1       	/boot      	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2
UUID=66D5-1E8A      	/boot      	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2

# /dev/mapper/VolGroup00-lvolswap         	none      	swap      	defaults  	0 0
UUID=78e05299-286a-4360-866c-dfae02822792	none      	swap      	defaults  	0 0

crypttab, although I have hidden this since reading this resolution

# sda2_crypt     UUID=z1VnLS-Ykvw-1gad-ADr3-XHJ9-hJM7-4dR8DQ  none                    luks
sda2_crypt      UUID=dde6df6a-af19-47b8-aede-937369182db2

edited (hooks) part of mkinitcpio.conf:

HOOKS=(base systemd autodetect keyboard modconf block sd-encrypt sd-lvm2 filesystems fsck)
# HOOKS=(base udev autodetect keyboard keymap modconf block encrypt lvm2 filesystems fsck)

Oh, first time installer / newbie in case that's not clear from my post. Any leads greatly appreciated :)


Board footer

Powered by FluxBB