You are not logged in.

#1 2019-12-06 22:06:23

cootcraig
Member
Registered: 2014-07-20
Posts: 6

[Solved]help with Broadcom BCM43142

Computer is Toshiba Satellite C55-C5390

Installing with archlinux-2019.12.01-x86_64.iso

running from iso:

ip link -> wlan0
I edited /etc/netctl/examples/wireless-wpa and started with
netctl start wireless-wpa
wireless is working

running from HD with ethernet cable:

kernel 5.4.2-arch1-1

systemctl |grep wlp1s0
sys-subsystem-net-devices-wlp1s0.service     loaded active plugged  BCM43142 802.11b/g/n

systemctl start/enable dhcpcd.service
pacman -S broadcom-wl-dkms linux-headers

reboot HD without ethernet cable:

ip link
wlp1s0

lspci
Network Controller: Broadcom  BCM43142

Edit /etc/netctl/wireless-wpa
Interface=wlp1s0

lspci -vnn -d 14e4:
Broadcom ... BCM43142 [14e4:4365]
 ...
kernel driver in use: wl
kernel modules: wl

What next? I am stuck and need help with trouble shooting.

Last edited by cootcraig (2019-12-11 19:46:17)

Offline

#2 2019-12-08 16:30:30

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,861

Re: [Solved]help with Broadcom BCM43142

You should not enable dhcpcd yourself if you intend to use netctl/wifi-menu let netctl handle that.

That said what do you need help with, it seems everything is set up correctly? Post logs from the actual service responsible, and complete ones not random snippets.

Offline

#3 2019-12-08 17:46:49

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,941
Website

Re: [Solved]help with Broadcom BCM43142

I can't make heads or tails of your post.  You seem to be using code tags, but they don't contain actual code and output, rather it's just a random listing of some commands you've tried without the resulting output, and some vague commentary / description.

https://bbs.archlinux.org/viewtopic.php?id=57855

I don't see anything suggesting that you've enabled any networking management service other than dhcpcd.  Dhcpcd, per it's defaults, does not start wpa_supplicant.  You can, however, add the wpa_supplicant hook for dhcpcd then it will (this is how I manage network services).

Last edited by Trilby (2019-12-08 17:48:42)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2019-12-08 20:04:29

cootcraig
Member
Registered: 2014-07-20
Posts: 6

Re: [Solved]help with Broadcom BCM43142

Trilby wrote:

I can't make heads or tails of your post.  You seem to be using code tags, but they don't contain actual code and output, rather it's just a random listing of some commands you've tried without the resulting output, and some vague commentary / description.
https://bbs.archlinux.org/viewtopic.php?id=57855

OK. I'm struggling to pull information out of all the fine manuals. Good advice on posting for help.

Offline

#5 2019-12-08 20:11:59

cootcraig
Member
Registered: 2014-07-20
Posts: 6

Re: [Solved]help with Broadcom BCM43142

Trilby wrote:

I don't see anything suggesting that you've enabled any networking management service other than dhcpcd.  Dhcpcd, per it's defaults, does not start wpa_supplicant.  You can, however, add the wpa_supplicant hook for dhcpcd then it will (this is how I manage network services).

Thank you, I will check this out.

Offline

#6 2019-12-11 19:49:46

cootcraig
Member
Registered: 2014-07-20
Posts: 6

Re: [Solved]help with Broadcom BCM43142

installed these packages:
dhcpcd
wpa_supplicant
broadcom-wl-dkms

ip link -> shows network interface names

create/edit config files:
systemctl start systemd-networkd.service
ln -sf /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf
systemctl stop systemd-networkd.service
edit /etc/systemd/network/20-wired.network
edit /etc/systemd/network/25-wireless.network
ln -s /usr/share/dhcpcd/hooks/10-wpa_supplicant /usr/lib/dhcpcd/dhcpcd-hooks/
wpa_passphrase MYSSID passphrase > /etc/wpa_supplicant/wpa_supplicant-wirelessinterface.conf

enabled these services:
systemd-networkd.service
systemd-resolved.service
dhcpcd@wired-interface.service
dhcpcd@wireless-interface.service
wpa_supplicant@wireless-interface.service

Offline

Board footer

Powered by FluxBB