You are not logged in.

#1 2006-09-15 16:18:19

From: Ontario, Canada
Registered: 2005-06-28
Posts: 63

MySQL error on fresh install [solved]

I just did a fresh install of MySql (mysql-5.0.24a-1) from current, and am getting an error when attempting to set the root password, using

/usr/bin/mysqladmin -u root password 'MyPassword' 

The error that returns is

/usr/bin/mysqladmin: Could not determine old_passwords setting from server; error: 'Commands out of sync; you can't run this command now'

I've never run into this before, so I'm not sure what is going on. I have the same version installed on other boxes, but they were upgraded rather than a fresh install.   Has anyone else seen this?

Okay, it seems that I had to install the libmysqlclient.

pacman -S libmysqlclient
:: libmysqlclient-5.0.24-1: local version is newer.  Upgrade anyway? [Y/n] y

Targets: libmysqlclient-5.0.24a-1

Total Package Size:   2.7 MB

Proceed with upgrade? [Y/n]

That fixed it.  I don't know if it broke the depends for cyrus-sasl-plugin, but I'm not using that yet.


Board footer

Powered by FluxBB