You are not logged in.

#1 2020-01-03 19:29:19

mororor
Member
Registered: 2020-01-03
Posts: 2

[SOLVED] new surplus nmcli device and wifi not working

Hello,

recently my wifi stopped working. According to my nm-applet there was a connection, however

$ ping 8.8.8.8

ping: connect: network not accessible

translated output

I discovered a surplus device (p2p-dev-wlp3s0) in nmcli:

$ nmcli device

DEVICE          TYPE      STATE            CONNECTION
enp0s31f6       ethernet  connected       Ethernet-Verbindung 1
wlp3s0          wifi      connected        khNet HBW
p2p-dev-wlp3s0  wifi-p2p  nicht connected  --
lo              loopback  not managed  --

translated output

which has no physical correspondence and does not show up in

$ ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether e8:6a:64:33:9c:34 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 18:1d:ea:c5:06:43 brd ff:ff:ff:ff:ff:ff

So I assume this device is responsible for things getting mixed up. I have no idea in how this device was created and i would really like it to be removed. However, my primary goal is to get network manager running again. Any ideas by someone? I would be very glad!

For completeness some more output:

$ systemctl list-unit-files --state=enabled

UNIT FILE                                   STATE
org.cups.cupsd.path                         enabled
acpid.service                               enabled
autovt@.service                             enabled
avahi-daemon.service                        enabled
bluetooth.service                           enabled
dbus-org.bluez.service                      enabled
dbus-org.freedesktop.Avahi.service          enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
display-manager.service                     enabled
getty@.service                              enabled
lightdm.service                             enabled
NetworkManager-dispatcher.service           enabled
NetworkManager-wait-online.service          enabled
NetworkManager.service                      enabled
ntpd.service                                enabled
org.cups.cupsd.service                      enabled
tlp-sleep.service                           enabled
tlp.service                                 enabled
avahi-daemon.socket                         enabled
org.cups.cupsd.socket                       enabled
remote-fs.target                            enabled
fstrim.timer                                enabled

23 unit files listed.
$ ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether e8:6a:64:33:9c:34 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.163/24 brd 10.0.0.255 scope global dynamic noprefixroute enp0s31f6
       valid_lft 2603sec preferred_lft 2603sec
    inet6 fde2:b65c:9f24::bc1/128 scope global dynamic noprefixroute
       valid_lft 85406sec preferred_lft 85406sec
    inet6 fde2:b65c:9f24:0:251:e3d4:e843:9f2a/64 scope global dynamic noprefixroute
       valid_lft 6901sec preferred_lft 1501sec
    inet6 fe80::c73c:87ca:5230:d630/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 18:1d:ea:c5:06:43 brd ff:ff:ff:ff:ff:ff
    inet6 fde2:b65c:9f24::3fc/128 scope global dynamic noprefixroute
       valid_lft 85102sec preferred_lft 85102sec
    inet6 fde2:b65c:9f24:0:fd90:8efa:3d7:dafc/64 scope global deprecated dynamic noprefixroute
       valid_lft 4787sec preferred_lft 0sec
    inet6 fe80::9384:1887:4c86:2076/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

Last edited by mororor (2020-01-03 20:00:47)

Offline

#2 2020-01-03 19:41:10

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,382

Re: [SOLVED] new surplus nmcli device and wifi not working

Post the journal, this additional device is irrelevant and mostly normal and read this thread  posted a few minutes ago: https://bbs.archlinux.org/viewtopic.php?id=251861

Offline

#3 2020-01-03 20:00:09

mororor
Member
Registered: 2020-01-03
Posts: 2

Re: [SOLVED] new surplus nmcli device and wifi not working

Thanks for the help!

Exchanging the dhcp client as suggested in the other thread solved the problem. Did not thought of it to be related, since the network manager indicated to be connected and wired networking worked.

Offline

Board footer

Powered by FluxBB