You are not logged in.

#1 2020-01-10 13:56:08

rezad
Member
Registered: 2014-09-17
Posts: 67

wpa3 with archlinux

does archlinux networkmanager with kde support wpa3?

in network manager security setting for wifi I don't see an option as wpa3.

Offline

#2 2020-01-10 14:02:47

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 872
Website

Re: wpa3 with archlinux

No. NetworkManager does not know about WPA.
It uses an external program to handle WPA authentication.
The default ist wpa_supplicant, which supports WPA3 in the current version afaik.
An alternative would be iwd, which I don't have any experience with.

Offline

#3 2020-01-10 18:27:55

rezad
Member
Registered: 2014-09-17
Posts: 67

Re: wpa3 with archlinux

I see the wpa3 configured AP on my openwrt as wep on my laptop.
also in the list of wifi security there is no wpa3 available.

Offline

#4 2020-01-10 18:32:26

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,476
Website

Offline

#5 2020-01-10 18:38:26

rezad
Member
Registered: 2014-09-17
Posts: 67

Re: wpa3 with archlinux

will test that thanks.
why is this disabled by default?

Offline

#6 2020-01-10 18:49:58

rezad
Member
Registered: 2014-09-17
Posts: 67

Re: wpa3 with archlinux

I tested with this in wpa_supplicant-git

"prepare() {
  cd "$srcdir"

  echo "CONFIG_OWE=y" >> "$srcdir/config"
        echo "CONFIG_SAE=y" >> "$srcdir/config"
}
"

but now the type of wpa3 configured one is shown as unknown and the security dropdown still doesnt have wpa3.

Offline

#7 2020-01-10 19:06:09

rezad
Member
Registered: 2014-09-17
Posts: 67

Re: wpa3 with archlinux

and also tested with the
https://git.archlinux.org/svntogit/pack … supplicant
and edited the config and added CONFIG_SAE=y
still the same.

Last edited by rezad (2020-01-10 19:07:46)

Offline

#8 2020-01-16 11:30:11

lucki1000
Member
Registered: 2019-01-29
Posts: 13

Re: wpa3 with archlinux

rezad wrote:

and also tested with the
https://git.archlinux.org/svntogit/pack … supplicant
and edited the config and added CONFIG_SAE=y
still the same.

i've download this tree and made makepkg -Si after i added CONFIG_SAE=y in config, then i installed it with pacman -U, but nothing changed after that, can you help me too?

Last edited by lucki1000 (2020-01-16 11:37:57)

Offline

#9 2020-01-16 12:33:39

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,083

Re: wpa3 with archlinux

plasma-nm will only have UI support in the next 5.18 release: https://cgit.kde.org/plasma-nm.git/comm … 2709ea6194 This commit was made last november and isn't yet part of a 5.17 branch.

Connecting/listing with nmcli/nmtui should work.

Last edited by V1del (2020-01-16 12:34:22)

Offline

#10 2020-01-16 12:38:30

lucki1000
Member
Registered: 2019-01-29
Posts: 13

Re: wpa3 with archlinux

V1del wrote:

plasma-nm will only have UI support in the next 5.18 release: https://cgit.kde.org/plasma-nm.git/comm … 2709ea6194 This commit was made last november and isn't yet part of a 5.17 branch.

Connecting/listing with nmcli/nmtui should work.

Can i only use plasma-nm from this branch?

Offline

#11 2020-01-16 12:50:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,083

Re: wpa3 with archlinux

On top of the old plasma? Don't know, if no API/ABI breaks happened you could try, however at least as far as AUR packages go https://aur.archlinux.org/packages/plasma-nm-git would pull in the whole suite as git which is probably not the best bet just to fix a minor visual issue.

Offline

#12 2020-01-16 13:40:32

lucki1000
Member
Registered: 2019-01-29
Posts: 13

Re: wpa3 with archlinux

V1del wrote:

On top of the old plasma? Don't know, if no API/ABI breaks happened you could try, however at least as far as AUR packages go https://aur.archlinux.org/packages/plasma-nm-git would pull in the whole suite as git which is probably not the best bet just to fix a minor visual issue.

that's not only a visual problem it doesn't let me connect to my wlan, i get the message from kde connection can't be added 802-11-wireless-security: WPA isn't compatible with static WEP

Last edited by lucki1000 (2020-01-16 13:59:48)

Offline

#13 2020-01-16 13:45:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,083

Re: wpa3 with archlinux

As mentioned, did you try with nmcli/wpa_supplicant directly? Plasma shouldn't inherently prevent you from doing that.

Last edited by V1del (2020-01-16 13:46:22)

Offline

#14 2020-01-16 14:00:26

lucki1000
Member
Registered: 2019-01-29
Posts: 13

Re: wpa3 with archlinux

V1del wrote:

As mentioned, did you try with nmcli/wpa_supplicant directly? Plasma shouldn't inherently prevent you from doing that.

No how to do this?

Offline

#15 2020-01-16 14:18:50

seth
Member
Registered: 2012-09-03
Posts: 15,662

Re: wpa3 with archlinux

https://wiki.archlinux.org/index.php/Ne … i_examples
https://wiki.archlinux.org/index.php/Ne … n/Wireless - don't forget to stop all network managing services (networkmanager in particular). Post the I/O of your approach.

Offline

#16 2020-01-19 20:14:23

J4ke
Member
Registered: 2017-12-10
Posts: 6

Re: wpa3 with archlinux

So i recently upgraded my AP to OpenWRT 19.07 and created a SSID with WPA3 only.

Compiled also wpa_supplicant-git with the SAE config option. But if i look at the wifi list with NetworkManager it does not recognize it:

$ nmcli dev wifi list
... MODE   CHAN  RATE        SIGNAL  BARS  SECURITY 
... Infra  40    405 Mbit/s  87      ▂▄▆█  --    

Then if it try to connect with "nmcli dev wifi con SSID PASSWORD" it says "Error: invalid extra argument 'mypassword'." as if the network is not encrypted. Without password it also fails, because it could not determine the AP Security Information.
I am using the current version 1.22.4, in theory it should be supported since 1.16...

In this (https://gist.github.com/est31/d92d17acb … 38764cd791) over a year old gist was written that networkmanager does not support WPA3 so far, so he used the wpa_supplicant directly, but i can't even get wpa_cli working:

$ sudo wpa_cli status
Failed to connect to non-global ctrl_ifname: (nil)  error: No such file or directory

wpa_supplicant is of course running in the background. Stopping NetworkManger.service does not make a difference. Don't know how to proceed now.

Anyone got this working on Arch?

Offline

#17 2020-01-19 20:20:49

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,476
Website

Re: wpa3 with archlinux

J4ke wrote:

he used the wpa_supplicant directly, but i can't even get wpa_cli working:

$ sudo wpa_cli status
Failed to connect to non-global ctrl_ifname: (nil)  error: No such file or directory

The wpa_supplicant configuration file needs to explicitly set permission for wpa_cli so just use the command directly: https://wiki.archlinux.org/index.php/WP … ant#Manual

Kill any running instances of wpa_supplicant before trying that though.

Offline

#18 2020-01-19 22:43:17

J4ke
Member
Registered: 2017-12-10
Posts: 6

Re: wpa3 with archlinux

Thanks, my wpa_supplicant.conf now looks like this:

ctrl_interface=/run/wpa_supplicant
update_config=1

network={
	ssid="WPA3"
	psk="PASSWORD"
	key_mgmt=SAE
}

Doing a "wpa_cli scan" shows that it gets recognized as SAE at least:

$ sudo wpa_cli scan_results
... / flags / ssid
... [WPA2-SAE-CCMP][ESS][UTF-8] WPA3

But it still does not connect if i run it:

$ sudo wpa_supplicant -i wlp3s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
wlp3s0: SME: Trying to authenticate with xx:xx:xx:xx:xx:xx (SSID='WPA3' freq=2462 MHz)
wlp3s0: SME: Trying to authenticate with xx:xx:xx:xx:xx:xx (SSID='WPA3' freq=2462 MHz)
wlp3s0: PMKSA-CACHE-ADDED xx:xx:xx:xx:xx:xx 0
wlp3s0: Trying to associate with xx:xx:xx:xx:xx:xx (SSID='WPA3' freq=2462 MHz)
wlp3s0: CTRL-EVENT-ASSOC-REJECT bssid=xx:xx:xx:xx:xx:xx status_code=31
wlp3s0: SME: Deauth request to the driver failed
... repeats a few times ...
wlp3s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="WPA3" auth_failures=2 duration=20 reason=CONN_FAILED

In the router system log the tries are visible without any errors:

daemon.info hostapd: wlan1-2: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated

Same if i switch the AP to WPA2/WPA3 mixed mode... and then if i don't specify key_mgmt=SAE it does work but uses only key_mgmt=WPA2-PSK.

Edit: Seems like the auth works, but the association fails. I have also run wpa_supplicant with -d which reveals the section:

nl80211: Association request send successfully
nl80211: Ignored event 20 (NL80211_CMD_DEL_STATION) for foreign interface (ifindex 3 wdev 0x0)
nl80211: Drv Event 20 (NL80211_CMD_DEL_STATION) received for wlp3s0
nl80211: Delete station xx:xx:xx:xx:xx:xx
nl80211: Ignored event 38 (NL80211_CMD_ASSOCIATE) for foreign interface (ifindex 3 wdev 0x0)
nl80211: Drv Event 38 (NL80211_CMD_ASSOCIATE) received for wlp3s0
nl80211: Associate event
wlp3s0: Event ASSOC_REJECT (12) received
wlp3s0: CTRL-EVENT-ASSOC-REJECT bssid=xx:xx:xx:xx:xx:xx status_code=31
wlp3s0: SME: Association with xx:xx:xx:xx:xx:xx failed: status code 31
wpa_driver_nl80211_deauthenticate(addr=xx:xx:xx:xx:xx:xx reason_code=3)
wlp3s0: nl80211: MLME command failed: reason=3 ret=-107 (Transport endpoint is not connected)

So i looked up what the status codes mean and found this table: https://support.google.com/chrome/a/ans … 2038?hl=en -> 31    Robust management frame policy violation
Has it something to do with 802.11w (PMF)?
I have set it to "Optional" in OpenWRT. Now i tried also "Disabled" and "Required" and with this i don't even get a log output and again no connection...

Last edited by J4ke (2020-01-19 23:24:33)

Offline

#19 2020-01-20 10:47:09

J4ke
Member
Registered: 2017-12-10
Posts: 6

Re: wpa3 with archlinux

I got it finally working!
The trick was to ditch wpa_supplicant altogether and use iwd instead. Needs no special compilation, i just installed from the community repo. Then it can be also controlled through NetworkManger: https://wiki.archlinux.org/index.php/Ne … Fi_backend so it even works with KDE and others GUIs. They still show it as unknown, but it just works.
In KDE were some commits to fix this, probably comes with 5.18: https://phabricator.kde.org/D24691?id=68035
nmcli shows it as WPA2, would be nice to get some more information, also in iwctl it is listed as psk.

Last edited by J4ke (2020-01-20 10:57:56)

Offline

#20 2020-06-14 15:17:18

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,015
Website

Re: wpa3 with archlinux


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB