You are not logged in.

#1 2020-01-18 22:42:46

lu6fer
Member
Registered: 2020-01-18
Posts: 5

[SOLVED] NetworkManager dhcp4 "unsable"

Hi all,
I've juste setup a pihole dns/dhcp on my network, and since my NetworkManager (Arch/cinnamon) sometime give me an IPV4 and sometimes not
I get "expire" from NM journalctl log.
All of my home devices get IPsv4 on my network, and I don't find anything elsewhere

Last edited by lu6fer (2020-01-21 20:24:23)

Offline

#2 2020-01-18 22:46:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,367

Re: [SOLVED] NetworkManager dhcp4 "unsable"

Is there a question in there?  Or are you  providing us a status report?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2020-01-18 22:50:49

lu6fer
Member
Registered: 2020-01-18
Posts: 5

Re: [SOLVED] NetworkManager dhcp4 "unsable"

not working logs :

janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.7758] device (wlp2s0b1): state change: activated -> deactivating (reason 'new-activation', sys-iface-state: 'managed')
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.7767] manager: NetworkManager state is now DISCONNECTING
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.7798] device (wlp2s0b1): disconnecting for new activation request.
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.7801] audit: op="connection-activate" uuid="0de36d2f-895f-4064-a6bd-3d09c92fa195" name="Auto Chez_FloEtFlo" pid=47055 uid=1000 result="success"
janv. 18 23:43:35 maupiti NetworkManager[517]: <warn>  [1579387415.8486] sup-iface[0x5648fb7e4400,wlp2s0b1]: connection disconnected (reason -3)
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.8490] device (wlp2s0b1): supplicant interface state: completed -> disconnected
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.8493] device (wlp2s0b1): state change: deactivating -> disconnected (reason 'new-activation', sys-iface-state: 'managed')
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.8735] dhcp4 (wlp2s0b1): canceled DHCP transaction
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.8735] dhcp4 (wlp2s0b1): state changed bound -> done
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.8741] dhcp6 (wlp2s0b1): canceled DHCP transaction
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.8741] dhcp6 (wlp2s0b1): state changed bound -> done
janv. 18 23:43:35 maupiti NetworkManager[517]: <info>  [1579387415.9272] device (wlp2s0b1): set-hw-addr: set MAC address to 22:E6:E7:55:25:2B (scanning)
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.2522] manager: NetworkManager state is now DISCONNECTED
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.2536] device (wlp2s0b1): Activation: starting connection 'Auto Chez_FloEtFlo' (0de36d2f-895f-4064-a6bd-3d09c92fa195)
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.2578] device (wlp2s0b1): supplicant interface state: disconnected -> disabled
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.2593] device (wlp2s0b1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.2599] manager: NetworkManager state is now CONNECTING
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.3161] device (wlp2s0b1): set-hw-addr: reset MAC address to 60:D8:19:33:A7:21 (preserve)
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6395] device (wlp2s0b1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6400] device (wlp2s0b1): Activation: (wifi) access point 'Auto Chez_FloEtFlo' has security, but secrets are required.
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6401] device (wlp2s0b1): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6487] device (wlp2s0b1): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6494] device (wlp2s0b1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6500] device (wlp2s0b1): Activation: (wifi) connection 'Auto Chez_FloEtFlo' has security, and secrets exist.  No new secrets needed.
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6501] Config: added 'ssid' value 'Chez_FloEtFlo'
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6501] Config: added 'scan_ssid' value '1'
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6501] Config: added 'bgscan' value 'simple:30:-65:300'
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6502] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK'
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6502] Config: added 'psk' value '<hidden>'
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6795] device (wlp2s0b1): supplicant interface state: disabled -> disconnected
janv. 18 23:43:36 maupiti NetworkManager[517]: <info>  [1579387416.6955] device (wlp2s0b1): supplicant interface state: disconnected -> scanning
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.2733] device (wlp2s0b1): supplicant interface state: scanning -> authenticating
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.2794] device (wlp2s0b1): supplicant interface state: authenticating -> associating
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.2848] device (wlp2s0b1): supplicant interface state: associating -> completed
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.2848] device (wlp2s0b1): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Chez_FloEtFlo"
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.2856] device (wlp2s0b1): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.2862] dhcp4 (wlp2s0b1): activation: beginning transaction (timeout in 45 seconds)
janv. 18 23:43:39 maupiti NetworkManager[517]: <info>  [1579387419.3451] dhcp4 (wlp2s0b1): state changed unknown -> expire
janv. 18 23:43:40 maupiti NetworkManager[517]: <info>  [1579387420.7747] dhcp6 (wlp2s0b1): activation: beginning transaction (timeout in 45 seconds)
janv. 18 23:43:40 maupiti NetworkManager[517]: <info>  [1579387420.7812] dhcp6 (wlp2s0b1): option dhcp6_domain_search  => 'home'
janv. 18 23:43:40 maupiti NetworkManager[517]: <info>  [1579387420.7816] dhcp6 (wlp2s0b1): option dhcp6_name_servers   => 'fe80::a21b:29ff:fe93:890'
janv. 18 23:43:40 maupiti NetworkManager[517]: <info>  [1579387420.7817] dhcp6 (wlp2s0b1): state changed unknown -> bound

working logs:

janv. 18 23:47:44 maupiti NetworkManager[517]: <info>  [1579387664.6081] manager: rfkill: Wi-Fi hardware radio set enabled
janv. 18 23:47:44 maupiti NetworkManager[517]: <warn>  [1579387664.6083] platform-linux: do-change-link[3]: failure changing link: failure 132 (Opération impossible du fait de RF-kill)
janv. 18 23:47:44 maupiti NetworkManager[517]: <info>  [1579387664.6086] audit: op="radio-control" arg="wireless-enabled" pid=970 uid=1000 result="success"
janv. 18 23:47:48 maupiti NetworkManager[517]: <info>  [1579387668.5522] manager: rfkill: Wi-Fi now enabled by radio killswitch
janv. 18 23:47:50 maupiti NetworkManager[517]: <info>  [1579387670.9440] sup-iface[0x5648fb7e4310,wlp2s0b1]: supports 4 scan SSIDs
janv. 18 23:47:50 maupiti NetworkManager[517]: <info>  [1579387670.9462] device (wlp2s0b1): supplicant interface state: starting -> ready
janv. 18 23:47:50 maupiti NetworkManager[517]: <info>  [1579387670.9464] device (wlp2s0b1): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.3410] policy: auto-activating connection 'Auto Chez_FloEtFlo' (0de36d2f-895f-4064-a6bd-3d09c92fa195)
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.3430] device (wlp2s0b1): Activation: starting connection 'Auto Chez_FloEtFlo' (0de36d2f-895f-4064-a6bd-3d09c92fa195)
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.3436] device (wlp2s0b1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.3447] manager: NetworkManager state is now CONNECTING
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.4697] device (wlp2s0b1): set-hw-addr: reset MAC address to 60:D8:19:33:A7:21 (preserve)
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7825] device (wlp2s0b1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7831] device (wlp2s0b1): Activation: (wifi) access point 'Auto Chez_FloEtFlo' has security, but secrets are required.
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7831] device (wlp2s0b1): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7836] sup-iface[0x5648fb7e4310,wlp2s0b1]: wps: type pbc start...
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7857] device (wlp2s0b1): supplicant interface state: ready -> disabled
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7888] device (wlp2s0b1): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7895] device (wlp2s0b1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7901] device (wlp2s0b1): Activation: (wifi) connection 'Auto Chez_FloEtFlo' has security, and secrets exist.  No new secrets needed.
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7901] Config: added 'ssid' value 'Chez_FloEtFlo'
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7901] Config: added 'scan_ssid' value '1'
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7902] Config: added 'bgscan' value 'simple:30:-65:300'
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7902] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK'
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.7902] Config: added 'psk' value '<hidden>'
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.8452] device (wlp2s0b1): supplicant interface state: disabled -> inactive
janv. 18 23:47:53 maupiti NetworkManager[517]: <info>  [1579387673.8598] device (wlp2s0b1): supplicant interface state: inactive -> scanning
janv. 18 23:47:56 maupiti NetworkManager[517]: <info>  [1579387676.4125] device (wlp2s0b1): supplicant interface state: scanning -> authenticating
janv. 18 23:47:56 maupiti NetworkManager[517]: <info>  [1579387676.4275] device (wlp2s0b1): supplicant interface state: authenticating -> associating
janv. 18 23:47:56 maupiti NetworkManager[517]: <info>  [1579387676.4322] device (wlp2s0b1): supplicant interface state: associating -> completed
janv. 18 23:47:56 maupiti NetworkManager[517]: <info>  [1579387676.4322] device (wlp2s0b1): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Chez_FloEtFlo"
janv. 18 23:47:56 maupiti NetworkManager[517]: <info>  [1579387676.4337] device (wlp2s0b1): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:56 maupiti NetworkManager[517]: <info>  [1579387676.4343] dhcp4 (wlp2s0b1): activation: beginning transaction (timeout in 45 seconds)
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.4726] dhcp4 (wlp2s0b1): state changed unknown -> expire
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.7763] dhcp6 (wlp2s0b1): activation: beginning transaction (timeout in 45 seconds)
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.7944] dhcp6 (wlp2s0b1): option dhcp6_domain_search  => 'home'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.7945] dhcp6 (wlp2s0b1): option dhcp6_name_servers   => 'fe80::a21b:29ff:fe93:890'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.7945] dhcp6 (wlp2s0b1): state changed unknown -> bound
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9885] dhcp4 (wlp2s0b1): option dhcp_lease_time      => '86400'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9886] dhcp4 (wlp2s0b1): option domain_name          => 'home'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9886] dhcp4 (wlp2s0b1): option domain_name_servers  => '192.168.0.253'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9887] dhcp4 (wlp2s0b1): option expiry               => '1579474078'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9887] dhcp4 (wlp2s0b1): option host_name            => 'maupiti'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9888] dhcp4 (wlp2s0b1): option ip_address           => '192.168.0.3'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9888] dhcp4 (wlp2s0b1): option next_server          => '192.168.0.253'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9889] dhcp4 (wlp2s0b1): option requested_broadcast_address => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9889] dhcp4 (wlp2s0b1): option requested_dhcp_server_identifier => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9890] dhcp4 (wlp2s0b1): option requested_domain_name => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9890] dhcp4 (wlp2s0b1): option requested_domain_name_servers => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9891] dhcp4 (wlp2s0b1): option requested_domain_search => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9891] dhcp4 (wlp2s0b1): option requested_host_name  => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9892] dhcp4 (wlp2s0b1): option requested_interface_mtu => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9892] dhcp4 (wlp2s0b1): option requested_ms_classless_static_routes => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9892] dhcp4 (wlp2s0b1): option requested_nis_domain => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9893] dhcp4 (wlp2s0b1): option requested_nis_servers => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9893] dhcp4 (wlp2s0b1): option requested_ntp_servers => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9894] dhcp4 (wlp2s0b1): option requested_rfc3442_classless_static_routes => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9894] dhcp4 (wlp2s0b1): option requested_root_path  => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9895] dhcp4 (wlp2s0b1): option requested_routers    => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9895] dhcp4 (wlp2s0b1): option requested_static_routes => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9896] dhcp4 (wlp2s0b1): option requested_subnet_mask => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9896] dhcp4 (wlp2s0b1): option requested_time_offset => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9897] dhcp4 (wlp2s0b1): option requested_wpad       => '1'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9897] dhcp4 (wlp2s0b1): option routers              => '192.168.0.254'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9898] dhcp4 (wlp2s0b1): option subnet_mask          => '255.255.255.0'
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9898] dhcp4 (wlp2s0b1): state changed expire -> bound
janv. 18 23:47:58 maupiti NetworkManager[517]: <info>  [1579387678.9939] device (wlp2s0b1): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0056] device (wlp2s0b1): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0064] device (wlp2s0b1): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0079] manager: NetworkManager state is now CONNECTED_LOCAL
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0127] manager: NetworkManager state is now CONNECTED_SITE
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0131] policy: set 'Auto Chez_FloEtFlo' (wlp2s0b1) as default for IPv4 routing and DNS
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0141] policy: set 'Auto Chez_FloEtFlo' (wlp2s0b1) as default for IPv6 routing and DNS
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0181] device (wlp2s0b1): Activation: successful, device activated.
janv. 18 23:47:59 maupiti NetworkManager[517]: <info>  [1579387679.0956] manager: NetworkManager state is now CONNECTED_GLOBAL

Offline

#4 2020-01-18 22:52:27

lu6fer
Member
Registered: 2020-01-18
Posts: 5

Re: [SOLVED] NetworkManager dhcp4 "unsable"

ewaller wrote:

Is there a question in there?  Or are you  providing us a status report?

The question is why ? and haow can I get rid of this annoying behaviour.
But this can be both smile

Last edited by lu6fer (2020-01-18 22:54:49)

Offline

#5 2020-01-18 23:38:05

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,367

Re: [SOLVED] NetworkManager dhcp4 "unsable"

Okay.  BTW, welcome to the Arch Linux forums.   For openers, what is the output of:
ip addr
and of
systemctl list-unit-files --state=enabled
??


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#6 2020-01-18 23:44:03

lu6fer
Member
Registered: 2020-01-18
Posts: 5

Re: [SOLVED] NetworkManager dhcp4 "unsable"

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 5c:26:0a:6c:06:21 brd ff:ff:ff:ff:ff:ff
3: wlp2s0b1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 60:d8:19:33:a7:21 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.250/24 brd 192.168.0.255 scope global noprefixroute wlp2s0b1
       valid_lft forever preferred_lft forever
    inet6 2a01:cb08:87e8:f400:7667:4c96:ebba:72ee/64 scope global dynamic noprefixroute 
       valid_lft 1788sec preferred_lft 588sec
    inet6 fe80::f506:d214:ffbd:f124/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

This is a non working situation with static IP addr (250 is the statis and 3 is the DHCP)

UNIT FILE                                   STATE  
org.cups.cupsd.path                         enabled
autovt@.service                             enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
display-manager.service                     enabled
getty@.service                              enabled
lightdm-plymouth.service                    enabled
NetworkManager-dispatcher.service           enabled
NetworkManager.service                      enabled
org.cups.cupsd.service                      enabled
systemd-timesyncd.service                   enabled
org.cups.cupsd.socket                       enabled
remote-fs.target                            enabled
fstrim.timer                                enabled
pamac-cleancache.timer                      enabled

15 unit files listed

Offline

#7 2020-01-18 23:56:35

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,367

Re: [SOLVED] NetworkManager dhcp4 "unsable"

Okay, that looks rational.

NetworkManager has been having a few issues with its internal DHCP client.  https://wiki.archlinux.org/index.php/Ne … HCP_client
You might try changing clients in NetworkManager using the methods described in that link.

Also, can you explain your network topology in a bit more detail?  Does your router have a DHCP server?  Where is pihole running?  Are there now multiple DHCP servers on the domain?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#8 2020-01-21 20:23:58

lu6fer
Member
Registered: 2020-01-18
Posts: 5

Re: [SOLVED] NetworkManager dhcp4 "unsable"

Hello,
After reading you, I recheck my setup, and find my router DHCP enable.
I was sure I stopped it, but it seems not.
By the way, the NM issue is gonne, so probleme solved wink

Offline

Board footer

Powered by FluxBB