You are not logged in.

#1 2020-02-06 03:49:32

From: Astral World
Registered: 2013-01-31
Posts: 37

[SOLVED] No Internet, Temporary Failure In Name Resolution

In chroot, I have already enabled systemd-networkd.service.
Several day before, it all just worked fine.

But today as I am practicing the installation (in VirtualBox), I found out that by just enabling systemd-networkd.service is not enough anymore.
After exiting the chroot and reboot, I am stuck with no internet.

Ping to and I get that temporary failure in name resolution.

I have followed Networking Guide to no avail.

Do I need to edit the /etc/resolv.conf manually?
It's weird, because I don't have to do that before.

As of now I'm falling back to DHCP (I installed dhcpcd and enabled dhcpcd.service in chroot).
So I'm good for now.

But the thing is, why the default systemd-networkd.service doesn't worked at all, now?
Kinda dissappointed because I prefer it over DHCP.

EDIT: I have solved it.
Finally after all day long trying to figure it out. The solution is very simple.
In a fresh install just now, I just have to install networkmanager and then enable it (in chroot).

Last edited by Archer1X (2020-02-06 06:39:13)

Arch Linux all the way..


Board footer

Powered by FluxBB