You are not logged in.

#1 2020-02-10 11:12:38

solstice
Member
Registered: 2006-10-27
Posts: 205
Website

lxd container does not start until security.privileged is set to true

hi.
I followed the wiki to try lxd.

I tried to start an arch and an ubuntu image. Both failed.

I finally found out I needed to setup /etc/subuid and /etc/subgid. Not better
Then, I did what's on the lxc page of the wiki
- added a line in /etc/pam.d/system-login (is it needed for privileged container ?)
- added lx.idmap in /etc/lxc/default.conf

So even after that, try to start those priviliged containers as root did not work either.

I finally found out that I had to use security.privileged=true in the conf of the container.

So is the unprivileged way to run container a new default in lxd ? Because that setting is said to be needed for container without CONFIG_USER_NS, but arch and ubuntu do have that configured to yes.
Or the wiki is wrong, or not clear ? I don't understand

Last edited by solstice (2020-02-10 11:39:39)

Offline

#2 2020-02-10 11:19:11

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 758
Website

Re: lxd container does not start until security.privileged is set to true

Well, I have no experience with lxd myself, but this is documented in the Wiki:
https://wiki.archlinux.org/index.php/LX … IG_USER_NS

Offline

Board footer

Powered by FluxBB