You are not logged in.

#1 2020-02-18 11:34:24

Registered: 2019-08-02
Posts: 24

[SOLVED] Drill Error: error sending query: No (valid) nameservers

I am trying to chase a somewhat odd problem.

When I run drill on my Arch server I get the below:

$ drill                         
Error: error sending query: No (valid) nameservers defined in the resolver

$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=56 time=16.8 ms

The server goes out directly to a public DNS server. Neither the target address nor the DNS server seem to matter, I tried and Cloudflare.

Ping requests resolve just fine on the server and I don't see any apps having problems.
Nevertheless I'd like to get on top of this though because, first of all, drill is a useful command, and second, one never knows what side effects this issue may have now or in the future.

systemd-resolved --status doesn't show anything worrying and the DNS server is in the network settings:

Link 2 (enp5s0)
      Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
DefaultRoute setting: yes
       LLMNR setting: yes
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: allow-downgrade
    DNSSEC supported: yes
  Current DNS Server:
         DNS Servers:

cat /etc/systemd/network/


cat /etc/resolv.conf                            
# Resolver configuration file.
# See resolv.conf(5) for details.

Anyone got any thoughts as to what else to check?

Let me close this one quickly, because the solution is let's say embarassing.
My resolv.conf was missing the nameserver tag, apparently this is not a problem for most applications but not for drill, and apparently the Matrix server Synapse as well, which like magic started to work after this change.
"nameserver" instead of ""

Oh well...

Last edited by tomz12 (2020-02-18 14:34:26)


Board footer

Powered by FluxBB