You are not logged in.

#1 2020-03-14 20:45:49

sinkingpoint
Member
Registered: 2020-03-14
Posts: 2

Doesn't show SDDM screen on boot after update

I use KDE Plasma, SDDM and Xorg. Back in December, I updated and was met with the 'Starting version xxx-x-arch' screen instead of the usual SDDM login. I wasn't in a position to fix it at the time so I ended up reverting the update and it went back to normal. Now, I am giving it another go, but it's stumping me.

SDDM is shown as active and running in systemctl. Xorg exits immediately with no error if I try to run it with startx. Any pointers would be greatly appreciated.

Offline

#2 2020-03-14 20:52:42

sinkingpoint
Member
Registered: 2020-03-14
Posts: 2

Re: Doesn't show SDDM screen on boot after update

This may be relevant, I did follow the instructions for it though: https://bugs.archlinux.org/task/64892

Offline

#3 2020-03-14 21:01:18

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,455
Website

Re: Doesn't show SDDM screen on boot after update

Your journal will contain relevant information. As will your xorg.log. Also, details about your hardware and graphics stack would be helpful.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2020-03-19 06:04:27

Skaper
Member
Registered: 2020-03-02
Posts: 10

Re: Doesn't show SDDM screen on boot after update

Hey!

I'm having the exact same issue. This morning when I booted my system running Plasma and tried to update it I got a bunch of Plasma related updates. So I did and then I restarted the system only to find myself stuck at "Starting version 245-3-arch"

I can use the other virtual consoles by pressing alt+function keys except the first one where the message is displayed. SDDM is also running.

Did you find a way to fix this? If not how did you roll back to the previous version? Any help would be appreciated!

Thanks!


I like to do things a certain way, even if there's a simpler solution available.

Offline

Board footer

Powered by FluxBB