You are not logged in.

#1 2020-04-25 13:58:15

Archonian
Member
Registered: 2020-04-25
Posts: 3

[SOLVED] Can't connect to protected wifi - connection timed out

Hello all!

I have an issue with my wifi, this issue was here months ago when I first installed arch on this laptop, I managed to fix it but now, sadly, I can't remember how I did it...

This laptop as go through hell after I managed to wipe all the partitions a few weeks ago, doing a dd command on sda in place of sdb when formating a raspberry pi sd card (this is my punishment).
After system recovery, this wifi problem is back and after weeks of trial and errors, I can't manage to find the culprit...So here I am, asking for your help fellows smile

My problem seems similar to this post, in case it helps: https://bbs.archlinux.org/viewtopic.php?id=231987

I'm using connman and cmst as a gui (back in the time when it worked i was using wicd but i left it because of it is python2 based and not active), when I connect to a protected wifi (tried on different routers) it gives me that message: "The agent request failed before a reply was returned."
I've swhitched to linux-lts kernel with no success.
I can connect to ethernet, usb modem, and to an unprotected wifi hotspot on my smartphone(same result on it with auth set)
Tried different type of encryption for the wifi, no results.

Laptop: Asus vivobook S14 S412DA-EK005T

Hardware infos:

lspci -kvnn | sed -n '/Network/,/^$/ p'
01:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
	Subsystem: Intel Corporation Wireless 8265 / 8275 [8086:0110]
	Physical Slot: 0
	Flags: bus master, fast devsel, latency 0, IRQ 52
	Memory at fea00000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

systemctl list-units| grep -iE '(net|conn|dhcp|wicd)' result:

  sys-devices-pci0000:00-0000:00:01.2-0000:01:00.0-net-wlp1s0.device                                       loaded active plugged   Wireless 8265 / 8275                                                                     
  sys-devices-virtual-net-docker0.device                                                                   loaded active plugged   /sys/devices/virtual/net/docker0                                                         
  sys-subsystem-net-devices-docker0.device                                                                 loaded active plugged   /sys/subsystem/net/devices/docker0                                                       
  sys-subsystem-net-devices-wlp1s0.device                                                                  loaded active plugged   Wireless 8265 / 8275                                                                     
  sys-fs-fuse-connections.mount                                                                            loaded active mounted   FUSE Control File System                                                                 
  connman-vpn.service                                                                                      loaded active running   ConnMan VPN service                                                                      
  connman.service                                                                                          loaded active running   Connection service                                                                       
  network-online.target                                                                                    loaded active active    Network is Online                                                                        
  network.target                                                                                           loaded active active    Network  

dmesg relevant part:

 49.422080] wlp1s0: authenticate with 94:27:90:13:cf:ce
[   49.432716] wlp1s0: send auth to 94:27:90:13:cf:ce (try 1/3)
[   49.447337] wlp1s0: authenticated
[   49.451539] wlp1s0: associate with 94:27:90:13:cf:ce (try 1/3)
[   49.554559] wlp1s0: associate with 94:27:90:13:cf:ce (try 2/3)
[   49.658258] wlp1s0: associate with 94:27:90:13:cf:ce (try 3/3)
[   49.771139] wlp1s0: association with 94:27:90:13:cf:ce timed out

Thanks a lot in advance, I'm here to add any asked information wink
Have a good day!

Last edited by Archonian (2020-05-20 14:19:44)

Offline

#2 2020-04-25 21:47:52

daniloanp
Member
Registered: 2016-12-08
Posts: 1

Re: [SOLVED] Can't connect to protected wifi - connection timed out

I'm facing the same issue. I'm using my current hardware setup since last year, and the same wireless adapter since 2015. Always with archlinux and without issues. But now this is happening.

I've tried connect from a pendrive with an old manjaro's version and everything is fine.

However in my current pure archlinux setup the issue happens.

[  321.648283] wlp41s0: associate with 74:da:88:e9:94:1e (try 1/3)
[  321.753288] wlp41s0: associate with 74:da:88:e9:94:1e (try 2/3)
[  321.857277] wlp41s0: associate with 74:da:88:e9:94:1e (try 3/3)
[  321.961286] wlp41s0: association with 74:da:88:e9:94:1e timed out
[  331.871861] wlp41s0: authenticate with 74:da:88:e9:94:1e
[  331.886206] wlp41s0: send auth to 74:da:88:e9:94:1e (try 1/3)
[  331.888871] wlp41s0: authenticated
[  331.889276] wlp41s0: associate with 74:da:88:e9:94:1e (try 1/3)
[  331.993299] wlp41s0: associate with 74:da:88:e9:94:1e (try 2/3)
[  332.002396] wlp41s0: RX AssocResp from 74:da:88:e9:94:1e (capab=0x431 status=0 aid=3)
[  332.002529] wlp41s0: associated
[  334.123920] wlp41s0: deauthenticated from 74:da:88:e9:94:1e (Reason: 6=CLASS2_FRAME_FROM_NONAUTH_STA)
[  335.421061] wlp41s0: authenticate with 74:da:88:e9:94:1e
[  335.431875] wlp41s0: send auth to 74:da:88:e9:94:1e (try 1/3)
[  335.434578] wlp41s0: authenticated
[  335.436278] wlp41s0: associate with 74:da:88:e9:94:1e (try 1/3)
[  335.561280] wlp41s0: associate with 74:da:88:e9:94:1e (try 2/3)
[  335.665279] wlp41s0: associate with 74:da:88:e9:94:1e (try 3/3)
[  335.769300] wlp41s0: association with 74:da:88:e9:94:1e timed out

I've tried switch from networkmanager + wpa_suplicant to connman + iwd. But it keeps buggy.

I'm using a desktop with the following adapter

 Network controller: Qualcomm Atheros AR93xx Wireless Network Adapter (rev 01) 

If a try reconnect several times, eventually it works. Eventually the connections is broken and I had to attempt dozens times again. :-(

Last edited by daniloanp (2020-04-25 21:51:52)

Offline

#3 2020-05-20 11:24:07

Archonian
Member
Registered: 2020-04-25
Posts: 3

Re: [SOLVED] Can't connect to protected wifi - connection timed out

Hello folks!
Sorry to bump the thread, but still nothing on my side and update after update this problem remains.

Dani and I could use a little help, I'm sure the solution isn't far because I already solved before (thanks brain to not remember that).

Cheers!

Offline

#4 2020-05-20 12:49:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,082

Re: [SOLVED] Can't connect to protected wifi - connection timed out

If I google for the error message when deauthing I find quite a few references to potential fixes. For example: https://askubuntu.com/a/471492 and maybe also try the swcrypto=1 module option.

Offline

#5 2020-05-20 12:53:56

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: [SOLVED] Can't connect to protected wifi - connection timed out

daniloanp seems to have a different problem (other HW, other error, other behavior)

Cut out connman, can you connect w/ wifi-menu?
Next: there seems to be a running docker instance? Does "ip a" show a bunch of docker related bridge devices?
If so, get docker out of the way and see whether that improves stuff.
Last, pass

iwlwifi.swcrypto=1 iwlwifi.11n_disable=1 iwlwifi.disable_11ac=true iwlwifi.disable_11ax=true

to the kernel. If this works, isolate the critical parameter.

Offline

#6 2020-05-20 14:19:12

Archonian
Member
Registered: 2020-04-25
Posts: 3

Re: [SOLVED] Can't connect to protected wifi - connection timed out

Thanks for your reply guys !
@seth cutting out connman and using only wifi-menu does not work, and about docker I already tried without it and it doesn't change anything unfortunatly. Plus, docker is needed for my work.
@V1del I already had a look to this link and unfortunatly the showed workaround does not work either.

But you both send me in the right direction because it is the software encryption which is causing trouble,

With the swcrypto=1 option (who's enabling software encryption) passed to the /etc/modprobe.d/iwlwifi.conf file it works!
I can now connect to a protected wifi network, thanks to both of you!

Many thanks to you, this problem is solved!

Offline

Board footer

Powered by FluxBB