You are not logged in.

#1 2020-09-04 21:00:46

lightdot
Member
Registered: 2014-04-22
Posts: 22

Latest xorg-server update, nonfuctioning laptop keyboard and touchpad

I mostly use my laptop connected to an external monitor, keyboard and mouse. Several days can pass before it is used on its own.

Today it got unplugged, carried away, far far away...  and lo an behold, upon starting Plasma, laptop's keyboard and touchpad suddenly weren't working. yikes

External USB mouse worked, but... no external keyboard at hand. hmm

Since laptop's keyboard worked just fine in terminal before starting X, I immediately ruled out faulty hardware. Also, special key combinations such as Fn-F4 worked. Lighting up the keyboard backlight immediately made me feel better. big_smile

I started troubleshooting:

- system logs showed no definitive indications as to what's going on
- went through recent updates but couldn't spot the culprit right away (due to having had laptop tethered to external peripherals for at least a week...)
- tried Enlightenment with the same result, nonfunctioning keyboard and touchpad.

At this point, I also ruled out anything specific to a DE, as both Plasma and Enlightenment behaved the same. That left xorg as the most likely culprit...

I just went ahead and downgraded a recent xorg-server and xorg-server-common update, from 1.20.9-2 back to 1.20.9-1.

Which solved the issue..!

Now off to check bug reports... with a working keyboard & mouse... cool

BTW, I don't think this is hardware related, but just in case, it's ASUS ZenBook UX310UAK.

Last edited by lightdot (2020-09-04 21:04:05)

Offline

#2 2020-09-05 11:36:27

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,380

Re: Latest xorg-server update, nonfuctioning laptop keyboard and touchpad

Was the laptop suspended / hibernated or shutdown when it was unplugged ?

The difference between 1.20.9-1 and 1.20.9-2 is one patch that changes suspend / resume behaviour .
see https://bugs.archlinux.org/task/67774 and https://github.com/archlinux/svntogit-p … d9db127101


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-09-05 20:44:43

lightdot
Member
Registered: 2014-04-22
Posts: 22

Re: Latest xorg-server update, nonfuctioning laptop keyboard and touchpad

Thanks for responding. The laptop wasn't suspended or hybernated and I have to correct myself completely, the reason is not Xorg (or at least not only Xorg). I did more tests and it turns out the reason lies in the kernel.

I usually use linux-lts but I had booted into standard linux on this day. What really solved the issue for me was rebooting into linux-lts again, not the xorg-server downgrade.

I should have thought of this sooner, apologies to everybody for the initial false conclusions...

After realizing the above, I quickly found similar reports by other users:

Keyboard doesn't work in linux 5.8 due to Asus hotkeys
Internal Keyboard and touchpad not working in X after update

Seems to be ASUS related after all...

Offline

Board footer

Powered by FluxBB