You are not logged in.

#1 2020-09-12 02:29:00

jzS6qNc_DDH
Member
Registered: 2020-09-12
Posts: 7

High packet loss rate

Few days ago I updated my system after a long time. Since then I have problems with my connection. For a minute or so it works perfectly then connection just stops working. Ping packets get lost (anything from 30% to 70%) but I'm still connected to my network. journalctl isn't showing anything. I switched from NetworkManager to netctl but I still have the same problem. Restarting netctl profile connects me again until I'm disconnected again.

wifi card details:

Network controller: Intel Corporation Wireless 8260 (rev 3a)
Subsystem: Intel Corporation Device 1130
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

Last edited by jzS6qNc_DDH (2020-09-12 02:34:37)

Offline

#2 2020-09-12 06:10:44

seth
Member
Registered: 2012-09-03
Posts: 16,263

Re: High packet loss rate

Mandatory read: https://wiki.archlinux.org/index.php/Ne … ss#iwlwifi
Then please post the outputs of

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f
iw dev

Also a complete system journal ("sudo journalctl -b") covering the event (see first link in my signature on how to do that conveniently)

Offline

#3 2020-09-12 19:30:44

jzS6qNc_DDH
Member
Registered: 2020-09-12
Posts: 7

Re: High packet loss rate

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

output:

bluetooth-autoconnect.service            | bluetooth.service.wants
bluetooth.service                        | bluetooth.target.wants
dbus-fi.w1.wpa_supplicant1.service       | system
dbus-org.bluez.service                   | system
dirmngr.socket                           | sockets.target.wants
getty@tty1.service                       | getty.target.wants
gpg-agent-browser.socket                 | sockets.target.wants
gpg-agent-extra.socket                   | sockets.target.wants
gpg-agent.socket                         | sockets.target.wants
gpg-agent-ssh.socket                     | sockets.target.wants
lm_sensors.service                       | multi-user.target.wants
netctl-ifplugd@enp0s31f6.service         | sys-subsystem-net-devices-enp0s31f6.device.wants
netctl.service                           | multi-user.target.wants
p11-kit-server.socket                    | sockets.target.wants
pulseaudio.socket                        | sockets.target.wants
remote-fs.target                         | multi-user.target.wants
wpa_supplicant.service                   | multi-user.target.wants
xdg-user-dirs-update.service             | default.target.wants
iw dev

outout

phy#0
        Unnamed/non-netdev interface
                wdev 0x3
                addr e4:a7:a0:32:b5:a0
                type P2P-device
                txpower 0.00 dBm
        Interface wlan0
                ifindex 3
                wdev 0x1
                addr e4:a7:a0:32:b5:9f
                ssid <<name-of-my-wifi>>
                type managed
                channel 10 (2457 MHz), width: 20 MHz, center1: 2457 MHz
                txpower 22.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0

journal:
http://ix.io/2xkS

I will try to solutions from the wiki but I don't think they will solve anything because everything worked fine for months.

Offline

#4 2020-09-12 19:50:04

seth
Member
Registered: 2012-09-03
Posts: 16,263

Re: High packet loss rate

Right of the bat:
You've wpa_supplicant explicitly enabled? Disable the service.

Sep 12 21:04:47 <<myhostname>> kernel: Linux version 5.7.4-arch1-1 (linux@archlinux) (gcc version 10.1.0 (GCC), GNU ld (GNU Binutils) 2.34.0) #1 SMP PREEMPT Thu, 18 Jun 2020 16:01:07 +0000

You're running a old kernel - if you updated the system "few days ago" there must have been some update error.

pacman -Qs linux

2.4GHz can get you in conflict w/ BT, can you try the 5GHz behavior?

Offline

#5 2020-09-12 20:32:53

jzS6qNc_DDH
Member
Registered: 2020-09-12
Posts: 7

Re: High packet loss rate

I've only enabled wpa_supplicant today, nothing changed since I've enabled it but I will disable it.

I'm not sure I have 5GHz router and wifi is bad with or without bluetooth, no matter how close to the router I sit.

It's probably an update error, thanks for spotting that. I updated it again and it seems like it's fine for now. I'll report back, maybe it breaks again.

Offline

#6 2020-09-13 17:32:20

jzS6qNc_DDH
Member
Registered: 2020-09-12
Posts: 7

Re: High packet loss rate

I tried all the fixes from the wiki, nothing changed.

Offline

#7 2020-09-13 19:49:11

seth
Member
Registered: 2012-09-03
Posts: 16,263

Re: High packet loss rate

Including disabling power saving? (Be aware that the sublink talks about activating it, but you actually want to deactive it, hence have to reverse the values to "off"/"0" - also runtime power management tools can reverse the "iw dev" config)

Offline

#8 2020-09-14 01:27:50

jzS6qNc_DDH
Member
Registered: 2020-09-12
Posts: 7

Re: High packet loss rate

yes, that's the one of first thing I've tried to do

my problem is a bit weird, I'm not disconnected, and when it works my wifi works fine
it's just that half of the time it doesn't work

I'm using static IP, I don't know if that matters

Offline

#9 2020-09-14 20:59:41

seth
Member
Registered: 2012-09-03
Posts: 16,263

Re: High packet loss rate

sysctl net.core.netdev_max_backlog net.ipv4.tcp_max_syn_backlog net.ipv4.tcp_congestion_control
ip a

If the congestion is "cubic" and the mtu is 1500, raising the backlog size might help (but obviously i'm just poking around here…)

You could also wireshark the network to inspect the lost ICMP packages (ping fails)
And though you apparently didn't update the kernel, trying the LTS kernel to see whether there's a regression might be worth a shot (again: poking)

If the network was failing completely, I'd try dhcp in case the router "silently" discards your lease, but don't see how this would lead to a slowdown/partial failure.

Offline

#10 2020-09-17 11:51:56

jzS6qNc_DDH
Member
Registered: 2020-09-12
Posts: 7

Re: High packet loss rate

thank you for your suggestions

I didn't try them out because I found something that works (for now)

I manually do power on - power off - power on of BT using bluetoothctl and then I restart the netctl module

Offline

#11 2020-09-17 14:09:47

seth
Member
Registered: 2012-09-03
Posts: 16,263

Re: High packet loss rate

jzS6qNc_DDH wrote:

I'm not sure I have 5GHz router and wifi is bad with or without bluetooth, no matter how close to the router I sit.

You could try to play with

parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
…
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
…
parm:           disable_11ac:Disable VHT capabilities (default: false) (bool) # actually 5GHz only, i don't think this is related
…
parm:           disable_11ax:Disable HE capabilities (default: false) (bool)

and see whether sth. is related since you apparently are hitting some BT interference.

Offline

Board footer

Powered by FluxBB