You are not logged in.

#1 2020-11-19 09:39:11

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,020
Website

Encoding error in auto correction of Evolution

Hi all,

since a couple of days, my email client, Evolution, suggests autocorrections of words with non-ASCII characters, such as Umlauts, with broken encoding.
E.g. it suggests to replace möglicherweise with möglicherweise.
This is annoying, since I use the autocorrect to detect possible spelling errors and thusly get a lot of false-positives when writing emails in German.
Here are my locales:

$ localectl
   System Locale: LANG=de_DE.UTF-8
                  LC_COLLATE=C
       VC Keymap: de
      X11 Layout: de

And the installed spell checkers:

$ pacman -Qs "hunspell|aspell"
local/aspell 0.60.8-2
    A spell checker designed to eventually replace Ispell
local/aspell-de 20161207-3
    German dictionary for aspell
local/hunspell 1.7.0-3
    Spell checker and morphological analyzer library and program
local/hunspell-de 20161207-6
    German hunspell dictionaries

How can I fix the false-positives with broken encoding?

Offline

#2 2020-11-19 10:35:41

mpan
Member
Registered: 2012-08-01
Posts: 601
Website

Re: Encoding error in auto correction of Evolution

There were some encoding issues with hunspell-* packages lately.

Possibly related: Incorrect character encoding. There I have assumed it wasn’t hunspell-related, because the report does not indicate the problem occurs in autocorrection only. But — re-reading the question — it may be interpreted as such.


Sometimes I seem a bit harsh — don’t get offended too easily! PGP: 7C848198AE93D3BB

Offline

#3 2020-11-19 12:42:24

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,020
Website

Re: Encoding error in auto correction of Evolution

Thanks. Indeed the errors seem to be related.
The solution seems to be to wait for an upstream fix then.

Offline

Board footer

Powered by FluxBB