You are not logged in.

#1 2020-12-16 15:20:49

TheStroyer
Member
Registered: 2018-08-28
Posts: 34

[SOLVED] HP Zbook Studio G5 microphone not immediately detected

On my Hp Zbook Studio G5 laptop, the (directional) internal microphone is not detected on boot.
When plugging in a set of earphones (with microphone) and unplugging it again, the microphone shows up
and works. When I restart pulseaudio, I have to do the same thing to get it working.

I have tried a few solutions I found on the forums:
- Installing sof-firmware and alsa-ucm-conf
- Setting `options snd-intel-dspcfg dsp_driver=1` in modprobe.d (before and after installing sof-firmaware)
- Setting `options snd_hda_intel dmic_detect=0` in modprobe.d
- Blacklisting snd_hda_intel (this disables all audio)

None of them seemed to work. Does anyone have something else I could try?

lsmod before plugging in earphones
https://pastebin.com/AbVWSVFC
lsmod after plugging in earphones
https://pastebin.com/2gzw4ShS

> arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: Generic Analog [Generic Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Edit: I found a solution. I put the following line in ~/.config/pulse/default.pa and it detected the microphone immidiately after boot.

 load-module module-alsa-sink device=hw:0,0 channels=2 

Last edited by TheStroyer (2020-12-16 15:38:51)

Offline

Board footer

Powered by FluxBB