You are not logged in.

#1 2020-12-20 13:18:11

pirogornian
Member
Registered: 2013-06-09
Posts: 6

Unable to use wifi, interface present and up

Hello. I have new-old PC with Usb wifi device tp-link tl-wn722n. There is no system for now, I boots from newest installation iso on pendrive.

It seems card is detected and activated properly, as is listed by both ifconfig (as up and multicast) and iwconfig. Iwconfig can operate an it, at least set mode, iwlist can scan and properly detect nearby networks. But that's all I can do. I've try both iwd and wpa-supplicant.

wpa_cli could not connect to service, which is running without errors (according to logs). iwcli just dont show any devices. I've tried google it, but no method was useful. I've tried to stop systemd-networkd, replugging card, loading modulws by hand (ath9k and ath9k_htc, it wasnt loaded automatically, but interface was present anyway). I've read something about firmware, but dmesg dont show any hint about it's mssing or loaded.

Anyone had similar issues? Could it be the device or archiso is broken in this area?

Edit:
After another boot I stopped iwd and run wpa_supplicant by hand as described on the Wiki, applying config file and interface name. Now it throwed something useful:

nl80211: driver deas not support authentication/association or connect commends
deinit ifname=wlan0 disabled_11b_rates=0.

After loading both mentioned modules, the same.
So, firmware indeed?

Last edited by pirogornian (2020-12-20 14:48:07)

Offline

#2 2020-12-21 09:42:15

Ferdinand
Member
From: Norway
Registered: 2020-01-02
Posts: 44

Re: Unable to use wifi, interface present and up

Uhm... I'm probably not going to be much help here, but the commands you are referring to belongs to the net-tools package, which is deprecated, hence the Installation guide does not use them.

That doesn't mean the commands doesn't work, of course, it only means you're straying from the guides, which may make it harder for people to help.

It seems to me the driver you're using doesn't support something you're trying to do, so I'd check the firmware section of the Network configuration/Wireless guide.


Xfce on Arch Linux on HP EliteBook 840 G3 with Intel i7-6500U, Skylake GT2 (HD Graphics 520), 8GB RAM, SanDisk SD8SN8U-512G-1006 and dual monitors @ WUXGA & FHD
---
"Don't walk in front of me; I may not follow. Don't walk behind me; I may not lead. Just walk beside me and be my friend."
- Albert Camus

Offline

Board footer

Powered by FluxBB