You are not logged in.

#1 2021-01-03 14:34:01

jemadux
Member
From: Thessaloniki City / Greece
Registered: 2010-07-17
Posts: 58

libreoffice cant run

backstory .
i created new user and still cant run showing a window.
that happend also in libreoffice still and libreoffice-fresh .

I am using kde.

i runned libreoffice --safe-mode nothing happned ...

also i deleted the ~/.config/libreoffice .

same issue ... any way to fix that problem ?

Offline

#2 2021-01-03 14:42:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,887

Re: libreoffice cant run

Try running /usr/bin/loffice from a X-terminal .

If that also fails without output, check journactl -b output for clues.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-01-03 15:20:38

jemadux
Member
From: Thessaloniki City / Greece
Registered: 2010-07-17
Posts: 58

Re: libreoffice cant run

i rebooted the machine ... i opened the libreoffice in safe mode again ... but it works ...
it works ..
but in non-safe mode not even working .. any clues .


 
❯ journalctl -b -p 3
-- Journal begins at Tue 2020-11-24 20:25:44 EET, ends at Sun 2021-01-03 17:20:20 EET. --
Ιαν 03 17:13:50 cryptolab kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/-.mount, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/home.mount, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/swapfile.swap, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/-.mount, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/boot-efi.mount, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/home.mount, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd-fstab-generator[213]: Failed to create unit file /run/systemd/generator/swapfile.swap, as it already exists. Duplicate entry in /etc/fstab?
Ιαν 03 17:13:50 cryptolab systemd[207]: /usr/lib/systemd/system-generators/systemd-fstab-generator failed with exit status 1.
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:9 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:10 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:12 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:13 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:15 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:17 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab systemd-udevd[248]: /etc/udev/rules.d/99-simtrace2.rules:18 Unknown group 'plugdev', ignoring
Ιαν 03 17:13:50 cryptolab kernel: tpm_crb MSFT0101:00: can't request region for resource [mem 0x4f76f000-0x4f772fff]
Ιαν 03 17:14:24 cryptolab libvirtd[480]: direct firewall backend requested, but /usr/bin/ebtables is not available: Δεν υπάρχει τέτοιο αρχείο ή κατάλογος
Ιαν 03 17:14:24 cryptolab libvirtd[480]: internal error: Failed to initialize a valid firewall backend
Ιαν 03 17:14:24 cryptolab systemd-backlight[530]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
Ιαν 03 17:14:24 cryptolab systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
Ιαν 03 17:14:58 cryptolab pipewire[1665]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: Could not get PID of name 'org.freedesktop.portal.Desktop': no such name
Ιαν 03 17:17:50 cryptolab systemd-coredump[2141]: Process 834 (baloo_file) of user 1000 dumped core.
                                                     
                                                     Stack trace of thread 1041:
                                                     #0  0x00007fb785927396 n/a (liblmdb.so + 0x4396)
                                                     #1  0x00007fb785929efe n/a (liblmdb.so + 0x6efe)
                                                     #2  0x00007fb78592a644 n/a (liblmdb.so + 0x7644)
                                                     #3  0x00007fb78592ac50 mdb_get (liblmdb.so + 0x7c50)
                                                     #4  0x00007fb786e012a5 _ZN5Baloo12IdFilenameDB3getEy (libKF5BalooEngine.so.5 + 0x152a5)
                                                     #5  0x00007fb786dfb2fc _ZNK5Baloo13DocumentUrlDB3getEy (libKF5BalooEngine.so.5 + 0xf2fc)
                                                     #6  0x00007fb786e0c085 _ZNK5Baloo11Transaction11documentUrlEy (libKF5BalooEngine.so.5 + 0x20085)
                                                     #7  0x00005592fd5228e4 n/a (baloo_file + 0x1d8e4)
                                                     #8  0x00007fb786e134ff _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x274ff)
                                                     #9  0x00007fb786e13557 _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x27557)
                                                     #10 0x00007fb786e13557 _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x27557)
                                                     #11 0x00007fb786e13557 _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x27557)
                                                     #12 0x00007fb786e13557 _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x27557)
                                                     #13 0x00007fb786e13557 _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x27557)
                                                     #14 0x00007fb786e13557 _ZN5Baloo16WriteTransaction17removeRecursivelyEyRKSt8functionIFbyEE (libKF5BalooEngine.so.5 + 0x27557)

PS the Ιaν  meaning  Jan

Last edited by jemadux (2021-01-03 15:22:28)

Offline

#4 2021-01-03 15:29:55

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: libreoffice cant run

Nothing in that jorunal excerpt relates to libreoffice - did you try to run loffice from konsole as the abandoned puppy has suggested?

Offline

#5 2021-01-03 15:40:40

jemadux
Member
From: Thessaloniki City / Greece
Registered: 2010-07-17
Posts: 58

Re: libreoffice cant run

when i try to open libreoffice ... then the screen go black ...

https://i.imgur.com/RFuwBw2.png

Mod Edit: removed oversized inline image.

Last edited by HalosGhost (2021-01-03 16:34:36)

Offline

#6 2021-01-03 15:44:14

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: libreoffice cant run

That's not an answer to the question, but sounds OpenGL related - try to disabele the HW acceleration of LibreOffice.

Offline

#7 2021-01-03 16:35:07

HalosGhost
Forum Moderator
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,844
Website

Re: libreoffice cant run

jemadux,

Please reread the Code of Conduct (specifically, the section regarding image sizes).

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#8 2021-01-07 09:06:48

Uzuki007
Member
Registered: 2019-04-21
Posts: 4

Re: libreoffice cant run

i don't know if this is related, but latest update of libreoffice-fresh(7.0.4-3) seems broken The error is

/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/libreoffice/program/libskialo.so: undefined symbol: FT_Palette_Select

In this post

1. https://bbs.archlinux.org/viewtopic.php?id=259420

it's related with double freetype installation. But i found another solution in

2. https://askubuntu.com/questions/1237381 … untu-20-04

maybe you can try one of them. In my case, I use no 2 because i don't have double freetype installation, and now libreoffice is working again.

Offline

#9 2021-01-07 14:56:54

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: libreoffice cant run

@Uzuki007, he's getting a black window (though the screenshot doesn't seem to refelct that?), not a startup error libreoffice
For your case

pacman -Qs '(freetype|libreoffice)'

If you don't use an AUR FT package, chances are that you conducted a partial update.

Offline

#10 2021-01-22 16:36:09

Uzuki007
Member
Registered: 2019-04-21
Posts: 4

Re: libreoffice cant run

@seth, pacman -Syu went normal, no error. After googling, i found that it has been reported here. In the mean time, i'll just use this.

LD_PRELOAD=/usr/lib/libfreetype.so.6 /usr/bin/soffice

Offline

#11 2021-01-22 17:09:23

loqs
Member
Registered: 2014-03-06
Posts: 12,949

Re: libreoffice cant run

@Uzuki007 did you notice the bug was closed as "Not a bug Additional comments about closing:  /usr/lib/libreoffice/program/libfreetype .so.6 is not in the repos "?

Offline

#12 2021-01-22 17:16:23

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: libreoffice cant run

@Uzuki007

pacman -Qs libreoffice

And that just stresses that your problem differs from the OP.

Offline

Board footer

Powered by FluxBB