You are not logged in.

#1 2021-01-18 19:01:29

Registered: 2016-10-31
Posts: 2

[SOLVED][BUG] NetworkManager can't resolve addresses after update

Hey, I've updated yesterday and my computer got offline.
Every applet said I was connected and well and my phone could browse the internet but my laptop wouldn't.

Temporary failure in name resolution

After some investigation /var/log/pacman.log showed me my computer decided to upgrade NetworkManager to version "1.28.1dev+7+g3f5df3cdc6-1".
I am not using the testing repositories.

My solution:
I cd into /var/cache/pacman/pkg and ls networkmanager* to find what packages I have:

cd /var/cache/pacman/pkg
ls networkmanager*

this shows me I have two packages:


From there I downgrade the package to version 1.26.4-1:

pacman -U networkmanager-1.26.4-1-x86_64.pkg.tar.zst

I'm posting this here to report the bug that a dev package managed to get into the stable repositories and to inform any helpless soul that upgraded and restarted their computer to find this on their phone.

Thank you!

PS: How do I contact heftig about this?

Last edited by SparkCrz (2021-01-18 19:07:27)


#2 2021-01-18 19:29:04

Registered: 2021-01-18
Posts: 1

Re: [SOLVED][BUG] NetworkManager can't resolve addresses after update

Thanks so much for this post. I was in the exact same position and this solution worked for me as well. I was about to try to reconfigure the resolv.conf setup but fortunately found this post through the IRC bot's help smile
All the best.


Board footer

Powered by FluxBB