You are not logged in.

#1 2021-01-19 20:38:46

From: Germany
Registered: 2021-01-18
Posts: 1

No ethernet via displaylink

Hey all,

after following the instructions from the wiki to install displaylink from the AUR, it broke my ethernet connection over my docking station.

I'm using this dock from i-tech with displaylink technology.

I connected my second monitor directly to my laptop (Acer swift 3 (2019)) so there was no need for the displaylink driver. My ethernet over this dock worked out of the box. I then wanted to connect my display with the dock and, as said before, installed displaylink from the AUR and followed the wiki instructions. My display now works over the dock, but the ethernet is now unable to connect to any address other than localhost or

Weirdly the the connection shows as connected in networkmanager:

enp0s20f0u2u2i5: connected to Wired connection 1
        "DisplayLink USB3.0 5K Graphic Docking"
        ethernet (cdc_ncm), DA:DE:CF:E7:A7:44, hw, mtu 1500
        inet6 2003:e3:ff19:b100:12f5:d172:809d:1c29/64
        inet6 fe80::8b07:ce58:c847:1835/64
        route6 2003:e3:ff19:b100::/56
        route6 2003:e3:ff19:b100::/64
        route6 ::/0
        route6 ff00::/8
        route6 fe80::/64 

But when I try to ping my default gateway it throws an error:

ping: connect: Network is unreachable 

The journal -fu NetworkManager output can be found here ( and it takes the network manager 47 seconds before showing the ethernet connected.

Wifi (Intel Cannon Point-LP CNVi) works and using the same setup with Windows 10 (booted from same SSD) and Majaro Live USB works perfectly fine.

What I already tried:

  • Installing, uninstalling and reinstalling:

    • NetworkManager

    • systemd-resolvconf (because some other users had problems with the newest nm version resolving hostnames. It is now uninstalled)

    • Displaylink and evdi
      Weiredly uninstalling evdi and displaylink didn't solve the problem

    • connman (ethernet also didn't work. Currently connman is uninstalled)

  • switching to lts-kernel (breaks evdi and displaylink completly)

  • downgrading to network manager version 1.26.4

  • rebooting several times

Running services, that might be relevant are:

  • displaylink

  • NetworkManager-wait-online
    (Needs to be restarted manually to run, because it fails to start on startup bebause it cannot reach a website over ethernet and wifi is encrypted by Kwallet)

  • NetworkManager

  • systemd-resolved

  • systemd-udev-trigger

  • systemd-udevd

  • wpa_supplicant

The full list of all services that are running can be found here:

I'm using up to date repositories and AUR packages.

My System is configured with:

  • linux 5.10.8.arch1-1

  • KDE plasma

  • lightdm

  • NetworkManager

Any help is very appreciated!


Board footer

Powered by FluxBB