You are not logged in.

#1 2021-01-25 14:08:32

Registered: 2021-01-25
Posts: 1

OpenVPN fails to start while starting namespaces

Hello, I have an intermittent problem with OpenVPN client failing to start in a VM with the following error logged in journal:

 openvpn-client@openvpn.service: Failed to set up mount namespacing: /run/systemd/unit-root/home: Transport endpoint is not cot connected
 openvpn-client@openvpn.service: Failed at step NAMESPACE spawning /usr/bin/openvpn: Transport endpoint is not connected

And the following audit record in dmesg:

 audit: type=1130 audit(1611571207.940:33): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=openvpn-client@openvpn comm="systemd"
 exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

The systemd version is 247.2-1 and openvpn version is 2.5.0-3, just in case.

The problem is quite strange, since I have two machines, one with FX-8350 processor, and another one with Core i7-2600. The VM boots over PXE with same root image.
However, on FX the VPN client starts without any issues, while the other machine fails to start it. I removed "user" and "group" from the OpenVPN client config file and checked
permissions in the '/etc/openvpn/client/'. The configs of the VM were same when the problem started, only then I started tweaking them in an attempt to find the cause of this

I tried tweaking the unit file for VPN client (run as root instead of openvpn, remove some protects), which is probably a bad idea in terms of security and was done to just investigate.
Installing or removing qemu-guest-agent package (obviously with enabling the service) did not fix the issue. I also tried setting the CPU type in VM to kvm64 or Opteron_G5, but
that did not help sad

Another detail is that after the login prompt appears, I can restart the VPN client without any problems. Which suggests that client starts too early for some reason (maybe?).

In short, OpenVPN starts in a VM on one machine, but fails to start with same VM on another one for some reason.

Sorry if I didn't provide enough log info, I am confused now in terms of where to look sad

Last edited by Telephonmaster (2021-01-25 14:10:41)


Board footer

Powered by FluxBB