You are not logged in.

#1 2021-02-01 17:54:55

From: Manchester, UK
Registered: 2011-05-11
Posts: 129

[Solved] Can’t connect to ssh-agent, even though its running

I‘m not entirely sure whats going on, I’m starting the agent via systemd, and have added the env value to my `~/.pam_environment` file, but still no success:

jonny in jmb-hetzner in ~
❯ systemctl --user status ssh-agent.service
● ssh-agent.service - SSH Agent
     Loaded: loaded (/home/jonny/.config/systemd/user/ssh-agent.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-02-01 18:48:44 CET; 3min 24s ago
   Main PID: 25026 (ssh-agent)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/ssh-agent.service
             └─25026 /usr/bin/ssh-agent -D -a /run/user/1000/ssh-agent.sock

Feb 01 18:48:44 jmb-hetzner systemd[15868]: Started SSH Agent.
Feb 01 18:48:44 jmb-hetzner ssh-agent[25026]: SSH_AUTH_SOCK=/run/user/1000/ssh-agent.sock; export SSH_AUTH_SOCK;
Feb 01 18:48:44 jmb-hetzner ssh-agent[25026]: echo Agent pid 25026;

jonny in jmb-hetzner in ~

jonny in jmb-hetzner in ~
❯ ssh-add ~/.ssh/id_deploy_jmbhetz
Error connecting to agent: No such file or directory

Any idea on how to debug what’s going on?

Edit: in my copy/pasting/typing I’d ended up with a `.sock` file and referencing a .socket` file :face palm:

all working now

Last edited by jonnybarnes (2021-02-01 17:57:32)


Board footer

Powered by FluxBB