You are not logged in.

#1 2021-02-15 13:29:24

workingwitharch
Member
Registered: 2021-02-15
Posts: 12

[SOLVED] Broadcom Wifi Driver Issues ; Can't Understand Errors

Macbook Air 2017 13"
Broadcom bmc4360 rev03 (14e443a0) card

Read the Arch Wiki on Broadcom Wireless and found "broadcom-wl" would work. Would prefer to use DKMS version, but have tried both unsucessfully.
(Have installed BOTH iwd and wpa_supplicant . Would prefer iwd but neither are currently working because of driver issues. Mentioned this in case there are known issues of either one with my hw.)

Outputs of relevant commands are hard to provide exactly , since Arch is not connected to a network so I'd have to copy them by hand, so I have paraphrased them.

ip addr , ip link

  and similar : Only the lo shows.

uname -r : 5.4.98-1-lts
lspci -nnk | grep -i -A3 net

: For `kernel moudles` it only shows `bcma` , not `wl` as it probably should, so I feel that the wl driver is for some reason not loaded ?

dmesg | grep -i firmware

gives :

Spectre V2 : Enabling Restricted Speculation for firmware calls
ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-9b] only partially covers this bridge
platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

I believe the last two outputs can be useful to people with a better understanding of this; I'm not quite sure what its trying to tell me and what I can do to fix it. If there are more commands that I can try that will help, please let me know and I will add the outputs ASAP if I'm online !

Some other bg info : I've been installing and configging Arch since last two days after school , have installed and configged to my liking, works with ethernet on my desktop , is prepped for my C and Python development, has no GUI (I have Ubuntu for that). Been doing development in and playing around with GNU/Linux for a year or so now smile This driver was an issue on my Ubuntu install too (from where I'm posting this) but was fixed by following an AskUbuntu forum answer ; by `dpkg`-ing what they call "bcmwl-kernel-source" , basically the same thing.

Thanks in advance , hope I can fix this.

Last edited by workingwitharch (2021-02-15 17:31:51)

Offline

#2 2021-02-15 15:22:02

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,211

Re: [SOLVED] Broadcom Wifi Driver Issues ; Can't Understand Errors

For the LTS kernel you need to install broadcom-wl-dkms and linux-lts-headers so the modules can be built against the kernel you are using.

Offline

#3 2021-02-15 17:28:00

workingwitharch
Member
Registered: 2021-02-15
Posts: 12

Re: [SOLVED] Broadcom Wifi Driver Issues ; Can't Understand Errors

Thanks a LOT !
It worked, and now I'm using iwd successfully , wifi works. The lts specific headers for my  linux-lts kernel was the missing piece in he puzzle , and once dkms was done building the driver, I popped it into my mac, wlan0 shower up , and then from there it was a breeze following the wiki.

Arch install and customisation  done in 2 days and just one "issue" which came up only because I didn't know what i was doing smile

How exactly did Arch get a difficult-to-install rep ? Its not...

Thanks a lot again to you, everyone making Arch possible , the brilliant people doing the mans and wikis and forums ! smile

Last edited by workingwitharch (2021-02-15 17:29:52)

Offline

Board footer

Powered by FluxBB