You are not logged in.

#1 2021-02-21 03:53:45

queenmedley
Member
From: Busan / S.Korea Busan
Registered: 2005-06-15
Posts: 56

[solved] guest? nobody? can't connect to sharing folder.

My smb.conf is set

 [global]
   workgroup = WORKGROUP
   netbios name = office1
   client min protocol = SMB2
   client max protocol = SMB3
   map to guest = Bad user
   server string = Office1 Samba Server
   server role = standalone server
   log file = /var/log/samba/%m.log
   wins support = no
   dns proxy = no
   guest ok = yes
   usershare path = /var/lib/samba/usershares
   usershare max shares = 100
   usershare allow guests = yes
   security = USER
   guest account = nobody

/home/user1/scan" folder is sharing to everyone

@office1$ net usershare info
[scan]
path=/home/office1/scan
comment=
usershare_acl=Everyone:F,
guest_ok=y

but not permission error happen.

office1$ smbclient -N //localhost/scan
Anonymous login successful
Try "help" to get a list of possible commands.
smb: \> ls
NT_STATUS_ACCESS_DENIED listing \*

so changed permisson of folder

office1$ chmod 777 scan
office1$ ls -l 
drwxrwxrwx  2 office1 office1  4096  Feb 18 10:47  scan

But still it 's not solved.

when I try to connect from linux client with pcmanfm (I check anoymous), error message is " faied to mount windows share: Permisson denied"
Windows 10 is also same error.

I can see nobody account in /etc/passwd and /etc/group and added nobody to samba user. Actually I don't know it is necessary but did.

office1$ sudo pdbedit -L -v
[sudo] queenmedley의 암호: 
---------------
Unix username:        nobody
NT username:          
Account Flags:        [U          ]
User SID:             S-1-5-21-1107082303-1242155204-156839429-501
Primary Group SID:    S-1-5-21-1107082303-1242155204-156839429-513
Full Name:            Nobody
Home Directory:       
HomeDir Drive:        (null)
Logon Script:         
Profile Path:         
Domain:               OFFICE1
Account desc:         
Workstations:         
Munged dial:          
Logon time:           0
Logoff time:          never
Kickoff time:         never
Password last set:    0
Password can change:  0
Password must change: 0
Last bad password   : 0
Bad password count  : 0
Logon hours         : FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

Is there any other way to try??

Last edited by queenmedley (2021-02-27 12:00:30)


- Queen Medley

Offline

#2 2021-02-21 11:57:24

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,894

Re: [solved] guest? nobody? can't connect to sharing folder.

The scan folder is in someones home-folder and requires special setup that can not be done through chmod .

Re-check https://wiki.archlinux.org/index.php/Sa … Usershares .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-02-27 11:59:33

queenmedley
Member
From: Busan / S.Korea Busan
Registered: 2005-06-15
Posts: 56

Re: [solved] guest? nobody? can't connect to sharing folder.

This is solution.
https://wiki.archlinux.org/index.php/Sa … s_by_guest

I also need to change permisson of home folder.
$chmod 744 /home/office1


- Queen Medley

Offline

Board footer

Powered by FluxBB