You are not logged in.

#1 2021-03-18 16:13:22

Registered: 2012-07-05
Posts: 91

Mullvad-vpn - working than failing - broadcom-dl-dkms module - netctl

I've been having ongoing--yet intermittent--problems with mullvad-vpn working.  I suspect they're similar to what others are describing here, but I'm hoping my additional input will help pinpoint what seems to be affecting so many people.

When I try to use the app to establish a vpn connection, it responds "Blocked Connection" (and my awesome wm icon shows a green lock with a red circle in the middle).  This happens even if I use wireguard only, instead of automatic or openvpn (under the app's advanced settings).

Also note that I have already tried the suggestions others have posted on the AUR comments:
-I always do a clean build
-I've tried the beta--no difference
-I've enabled and started systemd-resolved, installed systemd-resolveconf and linked /etc/resolv.conf to /run/systemd/resolv/stub-resolv.conf
-none of these seem to help (though when I first set up systemd-resolved, after a reboot it worked for a while)

However, it happens only intermittently.  Sometimes after having problems (and just running without the vpn for a while), I'll reboot and it will work.  It will keep working for day or even a week or so (with some reboots) and then later it stops working again.

I believe each time it has stopped working, it is after I run a pacman update (and AUR update with yay) and the kernel has been updated.  The update has to run hooks for my wireless kernel:   the broadcom-wl-dkms module, which has long-standing issues that were eventually solved with the new hook system.  So the first idea to consider is that the problem is related to 

1) broadcom-wl-dkms and hooks

Another possibility that might help isolate the issue is that I'm not using network manager.  I'm using

2) netctl

Note:  Just today I tried using NetworkManager instead.  It appears to work; but given the intermittent nature of the problem, I'm not sure yet.

Is there any journal info or other data I could collect to help troubleshoot it?
[Note, I've posted this to the AUR maintainer, but it doesn't look like anyone is making a serious effort to get to the heart of the issue there.  I suspect that is because it is not directly a mullvad-vpn issue, but its interaction with one of these other issues.]

Last edited by rabarrett (2021-03-18 17:21:15)


#2 2021-05-03 20:48:39

Registered: 2020-06-28
Posts: 23

Re: Mullvad-vpn - working than failing - broadcom-dl-dkms module - netctl

I've had something similar which started recently. It used to be the case for me that Mullvad worked fine, but now on first boot (or on waking from sleep) it thinks the device is offline and the only way to get it working is to `systemctl restart mullvad-daemon.service`. Unfortunately their customer support is utterly useless on this front as they "don't support archlinux" so I'm about to try the native wireguard support in netctl (I use netctl-auto to manage my wifi connections).


Board footer

Powered by FluxBB