You are not logged in.

#1 2021-06-01 08:58:43

hammad1029
Member
Registered: 2021-05-11
Posts: 8

Pamac broke and now installation fails

Pamac suddenly stopped working today, so I uninstalled it in hopes of reinstalling. now when i try to run makepkg -si in the build files directory, I get a whole page of errors which I have no idea what to do with. The same is happening when I try to install it with Yay. Any other package (aur or offical) installs fine with both makepkg and yay. pacman is working fine too.

here's the pastebin for the error since it's too big to post here: https://pastebin.com/sJxRwxL6

Offline

#2 2021-06-01 09:03:29

loqs
Member
Registered: 2014-03-06
Posts: 13,862

Re: Pamac broke and now installation fails

Did you read the comment from the package maintainer https://aur.archlinux.org/packages/pama … ent-810639 ?

Offline

#3 2021-06-01 09:31:49

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,451
Website

Re: Pamac broke and now installation fails

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2021-06-01 12:19:39

hammad1029
Member
Registered: 2021-05-11
Posts: 8

Re: Pamac broke and now installation fails

loqs wrote:

Did you read the comment from the package maintainer https://aur.archlinux.org/packages/pama … ent-810639 ?

so the issue is with pamac itself and not my system? that's a releif

Offline

#5 2021-06-01 12:26:03

Valso
Member
Registered: 2021-04-22
Posts: 38

Re: Pamac broke and now installation fails

loqs wrote:

Did you read the comment from the package maintainer https://aur.archlinux.org/packages/pama … ent-810639 ?

That comment makes me ask the question why was pacman 6.0 released for stable when it's not stable yet? I got the update several hours ago, all pamac versions (pamac-classic included) now don't work. Good thing I have a backup image with the old pacman, though.

Offline

#6 2021-06-01 12:29:35

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,611

Re: Pamac broke and now installation fails

There's nothing wrong with pacman, it's perfectly stable. It's all of the 3rd party applications that rely on libalpm that need updating.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2021-06-01 12:46:04

Valso
Member
Registered: 2021-04-22
Posts: 38

Re: Pamac broke and now installation fails

OK, I stand corrected - "I have a backup image from before that major update". But just in case I've disabled updates of pacman and all packages related to package management (better safe than sorry) until that problem is fixed.

Offline

#8 2021-06-01 13:50:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,439

Re: Pamac broke and now installation fails

https://wiki.archlinux.org/title/System … nsupported

If you really can't miss pamac (hard to believe...) , delay updating anything for a few weeks.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#9 2021-06-02 19:44:31

chris35
Member
Registered: 2021-06-02
Posts: 4

Re: Pamac broke and now installation fails

i got this compilation problem, really not sure its a specific pacman problem :
when i makepkg -si in the pamac-aur directory, all is starting good, except at the end of the script i get this error :
Compilation succeeded - 9 warning(s)
[32/92] Compiling C object src/pamac-daemon.p/meson-generated_daemon.c.o
ninja: build stopped: subcommand failed.

and of course i cant lauch pamac-aur

If we can no longer use pamac-aur, what would you advise me to use instead? I am not an advanced user ... ?

Last edited by chris35 (2021-06-02 19:50:46)

Offline

#10 2021-06-02 19:48:58

loqs
Member
Registered: 2014-03-06
Posts: 13,862

Re: Pamac broke and now installation fails

https://bbs.archlinux.org/viewtopic.php?id=57855
Edit:
Compare the full output with the output from https://gitlab.manjaro.org/applications … ssues/1047

The Meson build system
Version: 0.58.0
Source dir: /build/pamac-aur/src/pamac-bd6b8e8cf727cf94a1c9f4467a9157d94cad781f
Build dir: /build/pamac-aur/src/pamac-bd6b8e8cf727cf94a1c9f4467a9157d94cad781f/builddir
Build type: native build
WARNING: Unknown options: "enable-appindicator"
The value of new options can be set with:
meson setup <builddir> --reconfigure -Dnew_option=new_value ...
Project name: pamac
Project version: 10.0
C compiler for the host machine: cc (gcc 11.1.0 "cc (GCC) 11.1.0")
C linker for the host machine: cc ld.bfd 2.36.1
Vala compiler for the host machine: valac (valac 0.52.3)
Host machine cpu family: x86_64
Host machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (1.7.3)
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Found pkg-config: /usr/bin/pkg-config (1.7.3)
Run-time dependency gobject-2.0 found: YES 2.68.2
Run-time dependency gio-2.0 found: YES 2.68.2
Run-time dependency gthread-2.0 found: YES 2.68.2
Run-time dependency libalpm found: YES 13.0.0
Run-time dependency json-glib-1.0 found: YES 1.6.2
Run-time dependency libsoup-2.4 found: YES 2.72.0
Run-time dependency polkit-gobject-1 found: YES 0.118
Run-time dependency libnotify found: YES 0.7.9
Run-time dependency appstream-glib found: YES 0.7.18
Run-time dependency gio-unix-2.0 found: YES 2.68.2
Run-time dependency gtk+-3.0 found: YES 3.24.29
Run-time dependency libhandy-1 found: YES 1.2.2
Run-time dependency gmodule-2.0 found: YES 2.68.2
Library posix found: YES
Library m found: YES
Program g-ir-compiler found: YES (/usr/bin/g-ir-compiler)
Configuring org.manjaro.pamac.manager.service using configuration
Configuring org.manjaro.pamac.daemon.service using configuration
Configuring pamac-daemon.service using configuration
Configuring pamac-cleancache.service using configuration
Program pacman-mirrors found: NO
Program a2x found: YES (/usr/bin/a2x)
Program gzip found: YES (/usr/bin/gzip)
Build targets in project: 24

Found ninja-1.10.2 at /usr/bin/ninja
[1/92] Generating installer_resources_h with a custom command
[2/92] Generating installer_resources_c with a custom command
[3/92] Generating transaction_resources_h with a custom command
[4/92] Generating transaction_resources_c with a custom command
[5/92] Generating manager_resources_h with a custom command
[6/92] Generating manager_resources_c with a custom command
[7/92] Compiling Vala source ../src/alpm_config.vala ../src/dependency_checker.vala
../src/alpm_config.vala:349.2-349.18: warning: Method `AlpmConfig.write' never used
	public void write (HashTable<string,Variant> new_conf) {
	^^^^^^^^^^^^^^^^^
Compilation succeeded - 1 warning(s)
[8/92] Compiling Vala source ../src/alpm_config.vala ../src/outdated_checker.vala
../src/alpm_config.vala:349.2-349.18: warning: Method `AlpmConfig.write' never used
	public void write (HashTable<string,Variant> new_conf) {
	^^^^^^^^^^^^^^^^^
Compilation succeeded - 1 warning(s)
[9/92] Compiling C object src/dependency-checker.p/meson-generated_dependency_checker.c.o
[10/92] Compiling C object src/outdated-checker.p/meson-generated_outdated_checker.c.o
[11/92] Generating pamac.conf.5 manpage with a custom command
[12/92] Generating gzip pamac.conf.5 manpage with a custom command
[13/92] Generating org.manjaro.pamac.policy_data@polkit_merge with a custom command
[14/92] Compiling Vala source ../src/version.vala ../src/package.vala ../src/alpm_package.vala ../src/aur.vala ../src/alpm_utils.vala ../src/alpm_config.vala ../src/pamac_config_daemon.vala ../src/daemon.vala ../src/plugin_loader.vala ../src/snap_interface.vala ../src/flatpak_interface.vala
../src/alpm_package.vala:127.3-127.26: warning: Method `Pamac.AlpmPackage.set_as_app' never used
		internal void set_as_app (As.App? as_app) {
		^^^^^^^^^^^^^^^^^^^^^^^^
../src/alpm_package.vala:1276.3-1276.36: warning: Method `Pamac.AURPackageLinked.initialise_from_json' never used
		internal void initialise_from_json (Json.Object? json_object, AUR? aur, Alpm.Package? local_pkg, bool is_update = false) {
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/aur.vala:119.3-119.50: warning: Method `Pamac.AUR.get_multi_infos' never used
		public GenericArray<Json.Object> get_multi_infos (string[] pkgnames) {
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/aur.vala:148.3-148.41: warning: Method `Pamac.AUR.search' never used
		public GenericArray<Json.Object> search (string search_string) {
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/alpm_utils.vala:903.3-903.33: warning: Method `Pamac.AlpmUtils.trans_check_prepare' never used
		public bool trans_check_prepare (bool sysupgrade,
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:30.3-30.35: warning: Method `Pamac.SnapPlugin.search_snaps' never used
		public abstract void search_snaps (string search_string, ref GenericArray<unowned SnapPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:31.3-31.52: warning: Method `Pamac.SnapPlugin.search_uninstalled_snaps_sync' never used
		public abstract void search_uninstalled_snaps_sync (string search_string, ref GenericArray<unowned SnapPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:32.3-32.40: warning: Method `Pamac.SnapPlugin.is_installed_snap' never used
		public abstract bool is_installed_snap (string name);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:33.3-33.39: warning: Method `Pamac.SnapPlugin.get_snap' never used
		public abstract SnapPackage? get_snap (string name);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:34.3-34.49: warning: Method `Pamac.SnapPlugin.get_snap_by_app_id' never used
		public abstract SnapPackage? get_snap_by_app_id (string app_id);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:35.3-35.42: warning: Method `Pamac.SnapPlugin.get_installed_snaps' never used
		public abstract void get_installed_snaps (ref GenericArray<unowned SnapPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:36.3-36.48: warning: Method `Pamac.SnapPlugin.get_installed_snap_icon' never used
		public abstract string get_installed_snap_icon (string name) throws Error;
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:37.3-37.41: warning: Method `Pamac.SnapPlugin.get_category_snaps' never used
		public abstract void get_category_snaps (string category, ref GenericArray<unowned SnapPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:41.3-41.30: warning: Method `Pamac.SnapPlugin.refresh' never used
		public abstract void refresh ();
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:29.3-29.45: warning: Method `Pamac.FlatpakPlugin.refresh_appstream_data' never used
		public abstract bool refresh_appstream_data ();
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:30.3-30.42: warning: Method `Pamac.FlatpakPlugin.load_appstream_data' never used
		public abstract void load_appstream_data ();
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:31.3-31.40: warning: Method `Pamac.FlatpakPlugin.get_remotes_names' never used
		public abstract void get_remotes_names (ref GenericArray<unowned string> remotes_names);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:32.3-32.38: warning: Method `Pamac.FlatpakPlugin.search_flatpaks' never used
		public abstract void search_flatpaks (string search_string, ref GenericArray<unowned FlatpakPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:33.3-33.55: warning: Method `Pamac.FlatpakPlugin.search_uninstalled_flatpaks_sync' never used
		public abstract void search_uninstalled_flatpaks_sync (string[] search_terms, ref GenericArray<unowned FlatpakPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:34.3-34.43: warning: Method `Pamac.FlatpakPlugin.is_installed_flatpak' never used
		public abstract bool is_installed_flatpak (string name);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:35.3-35.55: warning: Method `Pamac.FlatpakPlugin.get_flatpak_by_app_id' never used
		public abstract FlatpakPackage? get_flatpak_by_app_id (string app_id);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:36.3-36.45: warning: Method `Pamac.FlatpakPlugin.get_flatpak' never used
		public abstract FlatpakPackage? get_flatpak (string id);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:37.3-37.45: warning: Method `Pamac.FlatpakPlugin.get_installed_flatpaks' never used
		public abstract void get_installed_flatpaks (ref GenericArray<unowned FlatpakPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:38.3-38.44: warning: Method `Pamac.FlatpakPlugin.get_category_flatpaks' never used
		public abstract void get_category_flatpaks (string category, ref GenericArray<unowned FlatpakPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:39.3-39.42: warning: Method `Pamac.FlatpakPlugin.get_flatpak_updates' never used
		public abstract void get_flatpak_updates (ref GenericArray<unowned FlatpakPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:42.3-42.30: warning: Method `Pamac.FlatpakPlugin.refresh' never used
		public abstract void refresh ();
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 26 warning(s)
[15/92] Compiling C object src/pamac-daemon.p/meson-generated_version.c.o
[16/92] Generating pamac.8 manpage with a custom command
[17/92] Generating gzip pamac.8 manpage with a custom command
[18/92] Compiling C object src/pamac-daemon.p/meson-generated_plugin_loader.c.o
[19/92] Compiling C object src/pamac-daemon.p/meson-generated_package.c.o
[20/92] Compiling C object src/pamac-daemon.p/meson-generated_flatpak_interface.c.o
[21/92] Compiling C object src/pamac-daemon.p/meson-generated_snap_interface.c.o
[22/92] Compiling C object src/outdated-checker.p/meson-generated_alpm_config.c.o
[23/92] Compiling C object src/dependency-checker.p/meson-generated_alpm_config.c.o
[24/92] Linking target src/outdated-checker
FAILED: src/outdated-checker 
cc  -o src/outdated-checker src/outdated-checker.p/meson-generated_alpm_config.c.o src/outdated-checker.p/meson-generated_outdated_checker.c.o -Wl,--as-needed -Wl,--no-undefined -Wl,-O1 -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -Wl,--start-group /usr/lib/libgobject-2.0.so /usr/lib/libglib-2.0.so /usr/lib/libalpm.so /usr/lib/libgio-2.0.so -Wl,--end-group
/usr/bin/ld: src/outdated-checker.p/meson-generated_alpm_config.c.o: in function `alpm_config_get_handle':
alpm_config.c:(.text+0x23af): undefined reference to `alpm_option_set_arch'
/usr/bin/ld: alpm_config.c:(.text+0x2679): undefined reference to `alpm_option_get_arch'
collect2: error: ld returned 1 exit status
[25/92] Linking target src/dependency-checker
FAILED: src/dependency-checker 
cc  -o src/dependency-checker src/dependency-checker.p/meson-generated_alpm_config.c.o src/dependency-checker.p/meson-generated_dependency_checker.c.o -Wl,--as-needed -Wl,--no-undefined -Wl,-O1 -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -Wl,--start-group /usr/lib/libgobject-2.0.so /usr/lib/libglib-2.0.so /usr/lib/libalpm.so /usr/lib/libgio-2.0.so -Wl,--end-group
/usr/bin/ld: src/dependency-checker.p/meson-generated_alpm_config.c.o: in function `alpm_config_get_handle':
alpm_config.c:(.text+0x23af): undefined reference to `alpm_option_set_arch'
/usr/bin/ld: alpm_config.c:(.text+0x2679): undefined reference to `alpm_option_get_arch'
collect2: error: ld returned 1 exit status
[26/92] Compiling C object src/pamac-daemon.p/meson-generated_aur.c.o
[27/92] Compiling C object src/pamac-daemon.p/meson-generated_alpm_utils.c.o
FAILED: src/pamac-daemon.p/meson-generated_alpm_utils.c.o 
cc -Isrc/pamac-daemon.p -Isrc -I../src -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/json-glib-1.0 -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/polkit-1 -I/usr/include/libappstream-glib -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/uuid -fdiagnostics-color=always -w -O3 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -pthread '-DGETTEXT_PACKAGE="pamac"' -D_FILE_OFFSET_BITS=64 -MD -MQ src/pamac-daemon.p/meson-generated_alpm_utils.c.o -MF src/pamac-daemon.p/meson-generated_alpm_utils.c.o.d -o src/pamac-daemon.p/meson-generated_alpm_utils.c.o -c src/pamac-daemon.p/alpm_utils.c
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_get_handle’:
src/pamac-daemon.p/alpm_utils.c:1691:25: error: too few arguments to function ‘alpm_option_set_eventcb’
 1691 |                         alpm_option_set_eventcb (_tmp7_, (alpm_cb_event) cb_event);
      |                         ^~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1586:5: note: declared here
 1586 | int alpm_option_set_eventcb(alpm_handle_t *handle, alpm_cb_event cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:1693:25: error: too few arguments to function ‘alpm_option_set_progresscb’
 1693 |                         alpm_option_set_progresscb (_tmp8_, (alpm_cb_progress) cb_progress);
      |                         ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1626:5: note: declared here
 1626 | int alpm_option_set_progresscb(alpm_handle_t *handle, alpm_cb_progress cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:1695:25: error: too few arguments to function ‘alpm_option_set_questioncb’
 1695 |                         alpm_option_set_questioncb (_tmp9_, (alpm_cb_question) cb_question);
      |                         ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1606:5: note: declared here
 1606 | int alpm_option_set_questioncb(alpm_handle_t *handle, alpm_cb_question cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:1697:25: error: too few arguments to function ‘alpm_option_set_fetchcb’
 1697 |                         alpm_option_set_fetchcb (_tmp10_, (alpm_cb_fetch) cb_fetch);
      |                         ^~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1566:5: note: declared here
 1566 | int alpm_option_set_fetchcb(alpm_handle_t *handle, alpm_cb_fetch cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:1699:62: error: ‘alpm_cb_totaldl’ undeclared (first use in this function)
 1699 |                         alpm_option_set_totaldlcb (_tmp11_, (alpm_cb_totaldl) cb_totaldownload);
      |                                                              ^~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:1699:62: note: each undeclared identifier is reported only once for each function it appears in
src/pamac-daemon.p/alpm_utils.c:1699:78: error: expected ‘)’ before ‘cb_totaldownload’
 1699 |                         alpm_option_set_totaldlcb (_tmp11_, (alpm_cb_totaldl) cb_totaldownload);
      |                                                   ~                          ^~~~~~~~~~~~~~~~~
      |                                                                              )
src/pamac-daemon.p/alpm_utils.c:1701:25: error: too few arguments to function ‘alpm_option_set_logcb’
 1701 |                         alpm_option_set_logcb (_tmp12_, (alpm_cb_log) cb_log);
      |                         ^~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1526:5: note: declared here
 1526 | int alpm_option_set_logcb(alpm_handle_t *handle, alpm_cb_log cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_update_dbs’:
src/pamac-daemon.p/alpm_utils.c:1962:21: error: too few arguments to function ‘alpm_db_update’
 1962 |                 if (alpm_db_update (force, _tmp6_) < 0) {
      |                     ^~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1373:5: note: declared here
 1373 | int alpm_db_update(alpm_handle_t *handle, alpm_list_t *dbs, int force);
      |     ^~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_download_pkg_priv’:
src/pamac-daemon.p/alpm_utils.c:3190:18: error: too few arguments to function ‘alpm_fetch_pkgurl’
 3190 |         _tmp0_ = alpm_fetch_pkgurl (alpm_handle, url);
      |                  ^~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:2318:5: note: declared here
 2318 | int alpm_fetch_pkgurl(alpm_handle_t *handle, const alpm_list_t *urls,
      |     ^~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:3206:26: error: too few arguments to function ‘alpm_fetch_pkgurl’
 3206 |                 _tmp6_ = alpm_fetch_pkgurl (alpm_handle, _tmp5_);
      |                          ^~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:2318:5: note: declared here
 2318 | int alpm_fetch_pkgurl(alpm_handle_t *handle, const alpm_list_t *urls,
      |     ^~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:3212:18: error: too few arguments to function ‘alpm_fetch_pkgurl’
 3212 |         _tmp8_ = alpm_fetch_pkgurl (alpm_handle, url);
      |                  ^~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:2318:5: note: declared here
 2318 | int alpm_fetch_pkgurl(alpm_handle_t *handle, const alpm_list_t *urls,
      |     ^~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_trans_check_prepare’:
src/pamac-daemon.p/alpm_utils.c:4321:9: error: too few arguments to function ‘alpm_option_set_questioncb’
 4321 |         alpm_option_set_questioncb (_tmp2_, (alpm_cb_question) cb_question);
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1606:5: note: declared here
 1606 | int alpm_option_set_questioncb(alpm_handle_t *handle, alpm_cb_question cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_trans_check_prepare_real’:
src/pamac-daemon.p/alpm_utils.c:4582:9: error: too few arguments to function ‘alpm_option_set_eventcb’
 4582 |         alpm_option_set_eventcb (tmp_handle, (alpm_cb_event) cb_event);
      |         ^~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1586:5: note: declared here
 1586 | int alpm_option_set_eventcb(alpm_handle_t *handle, alpm_cb_event cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4583:9: error: too few arguments to function ‘alpm_option_set_progresscb’
 4583 |         alpm_option_set_progresscb (tmp_handle, (alpm_cb_progress) cb_progress);
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1626:5: note: declared here
 1626 | int alpm_option_set_progresscb(alpm_handle_t *handle, alpm_cb_progress cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4584:9: error: too few arguments to function ‘alpm_option_set_logcb’
 4584 |         alpm_option_set_logcb (tmp_handle, (alpm_cb_log) cb_log);
      |         ^~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1526:5: note: declared here
 1526 | int alpm_option_set_logcb(alpm_handle_t *handle, alpm_cb_log cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_trans_run_real’:
src/pamac-daemon.p/alpm_utils.c:4796:9: error: too few arguments to function ‘alpm_option_set_questioncb’
 4796 |         alpm_option_set_questioncb (_tmp2_, (alpm_cb_question) cb_question);
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1606:5: note: declared here
 1606 | int alpm_option_set_questioncb(alpm_handle_t *handle, alpm_cb_question cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4825:33: error: too few arguments to function ‘alpm_option_set_eventcb’
 4825 |                                 alpm_option_set_eventcb (_tmp10_, (alpm_cb_event) cb_event);
      |                                 ^~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1586:5: note: declared here
 1586 | int alpm_option_set_eventcb(alpm_handle_t *handle, alpm_cb_event cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4827:33: error: too few arguments to function ‘alpm_option_set_progresscb’
 4827 |                                 alpm_option_set_progresscb (_tmp11_, (alpm_cb_progress) cb_progress);
      |                                 ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1626:5: note: declared here
 1626 | int alpm_option_set_progresscb(alpm_handle_t *handle, alpm_cb_progress cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4829:33: error: too few arguments to function ‘alpm_option_set_fetchcb’
 4829 |                                 alpm_option_set_fetchcb (_tmp12_, (alpm_cb_fetch) cb_fetch);
      |                                 ^~~~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1566:5: note: declared here
 1566 | int alpm_option_set_fetchcb(alpm_handle_t *handle, alpm_cb_fetch cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4831:70: error: ‘alpm_cb_totaldl’ undeclared (first use in this function)
 4831 |                                 alpm_option_set_totaldlcb (_tmp13_, (alpm_cb_totaldl) cb_totaldownload);
      |                                                                      ^~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c:4831:86: error: expected ‘)’ before ‘cb_totaldownload’
 4831 |                                 alpm_option_set_totaldlcb (_tmp13_, (alpm_cb_totaldl) cb_totaldownload);
      |                                                           ~                          ^~~~~~~~~~~~~~~~~
      |                                                                                      )
src/pamac-daemon.p/alpm_utils.c:4833:33: error: too few arguments to function ‘alpm_option_set_logcb’
 4833 |                                 alpm_option_set_logcb (_tmp14_, (alpm_cb_log) cb_log);
      |                                 ^~~~~~~~~~~~~~~~~~~~~
In file included from src/pamac-daemon.p/alpm_utils.c:30:
/usr/include/alpm.h:1526:5: note: declared here
 1526 | int alpm_option_set_logcb(alpm_handle_t *handle, alpm_cb_log cb, void *ctx);
      |     ^~~~~~~~~~~~~~~~~~~~~
src/pamac-daemon.p/alpm_utils.c: In function ‘pamac_alpm_utils_download_files’:
src/pamac-daemon.p/alpm_utils.c:7653:60: error: ‘ALPM_EVENT_RETRIEVE_START’ undeclared (first use in this function); did you mean ‘ALPM_EVENT_DB_RETRIEVE_START’?
 7653 |                 pamac_alpm_utils_emit_event (self, (guint) ALPM_EVENT_RETRIEVE_START, (guint) 0, _tmp14_, (gint) 0);
      |                                                            ^~~~~~~~~~~~~~~~~~~~~~~~~
      |                                                            ALPM_EVENT_DB_RETRIEVE_START
src/pamac-daemon.p/alpm_utils.c:7767:60: error: ‘ALPM_EVENT_RETRIEVE_DONE’ undeclared (first use in this function); did you mean ‘ALPM_EVENT_DB_RETRIEVE_DONE’?
 7767 |                 pamac_alpm_utils_emit_event (self, (guint) ALPM_EVENT_RETRIEVE_DONE, (guint) 0, _tmp37_, (gint) 0);
      |                                                            ^~~~~~~~~~~~~~~~~~~~~~~~
      |                                                            ALPM_EVENT_DB_RETRIEVE_DONE
src/pamac-daemon.p/alpm_utils.c: In function ‘cb_event’:
src/pamac-daemon.p/alpm_utils.c:10812:22: error: ‘ALPM_EVENT_PKGDOWNLOAD_START’ undeclared (first use in this function); did you mean ‘ALPM_EVENT_KEY_DOWNLOAD_START’?
10812 |                 case ALPM_EVENT_PKGDOWNLOAD_START:
      |                      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
      |                      ALPM_EVENT_KEY_DOWNLOAD_START
[28/92] Compiling C object src/pamac-daemon.p/meson-generated_pamac_config_daemon.c.o
[29/92] Compiling Vala source ../src/package.vala ../src/alpm_package.vala ../src/pamac_config.vala ../src/version.vala ../src/alpm_config.vala ../src/aur.vala ../src/database.vala ../src/transaction_interface.vala ../src/alpm_utils.vala ../src/transaction_interface_root.vala ../src/daemon_interface.vala ../src/transaction_interface_daemon.vala ../src/transaction.vala ../src/updates_checker.vala ../src/plugin_loader.vala ../src/snap_interface.vala ../src/flatpak_interface.vala
../src/alpm_config.vala:349.2-349.18: warning: Method `AlpmConfig.write' never used
	public void write (HashTable<string,Variant> new_conf) {
	^^^^^^^^^^^^^^^^^
../src/alpm_utils.vala:637.3-637.28: warning: Method `Pamac.AlpmUtils.download_pkg' never used
		public string download_pkg (string sender, string url) {
		^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:31.3-31.52: warning: Method `Pamac.SnapPlugin.search_uninstalled_snaps_sync' never used
		public abstract void search_uninstalled_snaps_sync (string search_string, ref GenericArray<unowned SnapPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:38.3-38.32: warning: Method `Pamac.SnapPlugin.trans_run' never used
		public abstract bool trans_run (string sender, string[] to_install, string[] to_remove);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:39.3-39.37: warning: Method `Pamac.SnapPlugin.switch_channel' never used
		public abstract bool switch_channel (string sender, string name, string channel);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/snap_interface.vala:40.3-40.35: warning: Method `Pamac.SnapPlugin.trans_cancel' never used
		public abstract void trans_cancel (string sender);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:33.3-33.55: warning: Method `Pamac.FlatpakPlugin.search_uninstalled_flatpaks_sync' never used
		public abstract void search_uninstalled_flatpaks_sync (string[] search_terms, ref GenericArray<unowned FlatpakPackage> pkgs);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:40.3-40.32: warning: Method `Pamac.FlatpakPlugin.trans_run' never used
		public abstract bool trans_run (string sender, string[] to_install, string[] to_remove, string[] to_upgrade);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/flatpak_interface.vala:41.3-41.35: warning: Method `Pamac.FlatpakPlugin.trans_cancel' never used
		public abstract void trans_cancel (string sender);
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 9 warning(s)
[30/92] Compiling C object src/pamac-daemon.p/meson-generated_alpm_config.c.o
[31/92] Compiling C object src/pamac-daemon.p/meson-generated_alpm_package.c.o
[32/92] Compiling C object src/pamac-daemon.p/meson-generated_daemon.c.o
ninja: build stopped: subcommand failed.

Last edited by loqs (2021-06-02 19:53:11)

Offline

#11 2021-06-02 20:57:50

chris35
Member
Registered: 2021-06-02
Posts: 4

Re: Pamac broke and now installation fails

Thanks Ioqs !
it seems to be a libalpm problem, that needs an update... will wait for it.

Offline

#12 2021-06-02 21:13:41

loqs
Member
Registered: 2014-03-06
Posts: 13,862

Re: Pamac broke and now installation fails

chris35 wrote:

Thanks Ioqs !
it seems to be a libalpm problem, that needs an update... will wait for it.

Just to be clear the update will need to come from pamac to make it compatible with libalm 13.

Last edited by loqs (2021-06-03 12:27:40)

Offline

#13 2021-06-03 10:54:49

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,439

Re: Pamac broke and now installation fails

chris35 wrote:

If we can no longer use pamac-aur, what would you advise me to use instead? I am not an advanced user ... ?

https://wiki.archlinux.org/title/AUR_helpers

I don't use one, but pacman wrappers / graphical clients tend to give the most problems.

Start with looking at the "Search and download" and "Search and build" comparison tables .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#14 2021-06-03 12:52:52

chris35
Member
Registered: 2021-06-02
Posts: 4

Re: Pamac broke and now installation fails

I think I'll do like you ... less is better, according to Arch's philosophy wink

Offline

Board footer

Powered by FluxBB