You are not logged in.

#1 2021-06-25 16:24:12

BHReach
Member
Registered: 2008-12-28
Posts: 21

Problem with Realtek USB wifi adapter

My adapter (rtl3072) drops out from time to time but does not reconnect.

dmesg shows these errors.

dmesg |grep -i error
[588933.871056] ieee80211 phy0: rt2800usb_fill_rxdone: Error - Bad frame size 45416, forcing to 0
[588933.871089] ieee80211 phy0: rt2x00lib_rxdone: Error - Wrong frame size 0 max 3840
[607246.017267] ieee80211 phy0: rt2800usb_fill_rxdone: Error - Bad frame size 22643, forcing to 0
[607246.017303] ieee80211 phy0: rt2x00lib_rxdone: Error - Wrong frame size 0 max 3840
[1140423.929059] ieee80211 phy0: rt2800usb_fill_rxdone: Error - Bad frame size 46033, forcing to 0
[1140423.929092] ieee80211 phy0: rt2x00lib_rxdone: Error - Wrong frame size 0 max 3840

I have to restart NetwokManager to get it to reconnect.

I have been using this with Gentoo and wpa_supplicant without this problem occurring.

Any suggestions on how to get it to work properly with NetwokManager?

Offline

#2 2021-06-25 16:26:53

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,805

Re: Problem with Realtek USB wifi adapter

Which kernel/firmware did you use on gentoo. NetworkManager ultimately  uses wpa_supplicant anyway. Something that can occasionally have an effect here is MAC randomisation try to disable that: https://wiki.archlinux.org/title/Networ … domization

Last edited by V1del (2021-06-25 16:29:45)

Offline

#3 2021-06-28 08:28:04

BHReach
Member
Registered: 2008-12-28
Posts: 21

Re: Problem with Realtek USB wifi adapter

V1del wrote:

Which kernel/firmware did you use on gentoo. NetworkManager ultimately  uses wpa_supplicant anyway. Something that can occasionally have an effect here is MAC randomisation try to disable that: https://wiki.archlinux.org/title/Networ … domization

It is possible that that could fix the problem. I was thinking of running a cron job every 10 minutes to see if the interface is up, like this:

#!/bin/bash

var="$(cat /sys/class/net/wlan0/operstate)"
if [ $var != "up" ]; then
  systemctl restart NetworkManager.service
fi

That way it should never be down for more than 10 minutes.

Offline

Board footer

Powered by FluxBB