You are not logged in.

#1 2021-07-10 10:04:56

Freakzz
Member
Registered: 2020-12-01
Posts: 33

[SOLVED] Can't start 'default' network with virsh.

Currently trying to set up Virtual Manager to get some testing done. However, I haven't been able to create a vm. It gives me errors like 'default' network is not active. I did check by running

sudo virsh net-list --all

. Here's the output. It used to give me different errors before I updated ebtables and dnsmasq. Now the current errors I am getting are these (whenever I issue the command sudo virsh net-start default):

error: Failed to start network default
error: internal error: Failed to apply firewall rules /usr/bin/iptables -w --table filter --list-rules: iptables/1.8.7 Failed to initialize nft: Protocol not supported

Didn't find much online for an arch based system, so thought I'd ask here.

Last edited by Freakzz (2021-07-23 15:03:53)


Suffering from crippling rice addiction.

Offline

#2 2021-07-10 12:13:23

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,342

Re: [SOLVED] Can't start 'default' network with virsh.

Failed to initialize nft: Protocol not supported

Check https://wiki.archlinux.org/title/Libvirt#Networks to find the solution for that.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB