You are not logged in.

#1 2021-07-16 09:04:44

hepuyuan100
Member
Registered: 2021-06-15
Posts: 16

using ssh connect to a server, fail to start app. How to solve ?

my system is Archlinux, and using gnome.
I use ssh to connect to my school's server. Because I want to use the lumerical in my school's server (I don't have this application on my own labtop).
Now through ssh command, I succeed in connecting my account. I can see all the files. But when I tried to launcher Lumerical, it warn me:

```
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: xcb.

Abandon (core dumped)
```

Is there anyone can help me to solve this problem?

Offline

#2 2021-07-16 10:43:58

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,199
Website

Re: using ssh connect to a server, fail to start app. How to solve ?

Use X forwarding, if supported.

ssh -Y ...

PS: And don't crosspost.

Last edited by schard (2021-07-16 10:46:35)

Offline

#3 2021-07-16 10:47:13

hepuyuan100
Member
Registered: 2021-06-15
Posts: 16

Re: using ssh connect to a server, fail to start app. How to solve ?

Thanks, it works!!!!
I used "ssh -X ...." and found it's ok!
Thanks again! smile

Offline

#4 2021-07-16 10:48:59

hepuyuan100
Member
Registered: 2021-06-15
Posts: 16

Re: using ssh connect to a server, fail to start app. How to solve ?

I'm sorry for crossposting. I don't know this problem belongs to which part.

schard wrote:

Use X forwarding, if supported.

ssh -Y ...

PS: And don't crosspost.

Offline

Board footer

Powered by FluxBB