You are not logged in.

#1 2022-01-14 23:05:42

Wacken
Member
Registered: 2020-08-28
Posts: 3

wine doesn't work

hello. I'm currently trying to make my games also work on my arch laptop, which has almost the same setup as my arch desktop. I used steam with proton and lutris. But it seems i have a problem with wine, with which I'm sadly totally unfamiliar. I narrowed it down to the error "wine: could not load kernel32.dll, status c0000135". There are many supossed solutions, much say it depends on the default wine prefix. Therfore i deleted anything mentioning wine or lutris from my system and reinstalled wine. But when i did the winecfg with the set prefix it still gets the error mentioned before. I also tried with and without wine-mono and wine-gecko, but it seems i can't avoid the error. I also deinstalled nvidia and changed to nouveau, as there was some mention of it, that that could be the problem, but didn't get a solution and changed back to nvidia. Finnally i also tried wine-staging, but still get the same error Anyone who can help me with my problem or let me know something else, which I could try?

also the total error message most often when i try to do winecfg is

wine: created the configuration directory '/home/wacken/.wine'
002c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
wine: Unhandled page fault on execute access to 000000006111486E at address 000000006111486E (thread 002c), starting debugger...
002c:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 40 124" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
wine: could not load kernel32.dll, status c0000135
[myfancyprompt ~]$ 0048:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
wine: Unhandled page fault on execute access to 00007F746B7875C0 at address 00007F746B7875C0 (thread 0048), starting debugger...
0048:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 68 88" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
0040:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0040:err:winediag:nodrv_CreateWindow The explorer process failed to start.

sorry to bother, but I'm really quite frustradet, especially as it is quite important for me to get it working soonish enough

help would be appreciated

Last edited by Wacken (2022-01-16 21:00:56)

Offline

#2 2022-01-15 08:38:50

seth
Member
Registered: 2012-09-03
Posts: 29,850

Re: wine doesn't work

Couple of posts below yours: https://bbs.archlinux.org/viewtopic.php?id=273079

Edit: also please use code tags, https://bbs.archlinux.org/help.php#bbcode and the enter keys (you know, paragraphs and so…)

Last edited by seth (2022-01-15 08:39:43)

Offline

Board footer

Powered by FluxBB