You are not logged in.

#1 2022-01-28 21:42:11

x24hs
Member
Registered: 2022-01-28
Posts: 2

Wifi not working after update 5.16.3 and reboot

Hi,
I just updated to kernel 5.16.3 and then I did a reboot but wifi didn't work. My wifi card is Mediatek MT7921e, I don't know what to do. I tried with 'sudo modprobe -r m7921; modprobe mt7921e' but nothing happens.
Also, wlan0 disappeared when I did 'ip link'.
What can I do?

Thanks!

Offline

#2 2022-01-29 08:23:01

seth
Member
Registered: 2012-09-03
Posts: 32,129

Re: Wifi not working after update 5.16.3 and reboot

Read https://bbs.archlinux.org/viewtopic.php?id=57855 and post some useful information like

uname -a; lspci -k; lsusb; rfkill; ip a

And a complete system journal ("sudo journalctl -b", in doubt redirect that into a file and usb-walk it to a system w/ network access to upload it)

Offline

#3 2022-01-29 15:03:54

ofrank
Member
Registered: 2022-01-29
Posts: 1

Re: Wifi not working after update 5.16.3 and reboot

I had the same issue on version 5.16.3 of the kernel, downgrading my kernel is serving as a temporary fix.

Offline

#4 2022-01-29 15:16:34

seth
Member
Registered: 2012-09-03
Posts: 32,129

Re: Wifi not working after update 5.16.3 and reboot

Same data request and also "downgrade to what version"?
You can also check around https://lore.kernel.org/lkml/fed8a57f-8 … ing.org/T/

Edit: https://bbs.archlinux.org/viewtopic.php?id=273641

Last edited by seth (2022-01-29 16:07:11)

Offline

#5 2022-03-27 08:39:09

ceshiheike
Member
Registered: 2022-03-27
Posts: 1

Re: Wifi not working after update 5.16.3 and reboot

I fixed the problem by:

1) grep  the output of
     modinfo mt7921e | grep alias
for example:
    alias:          pci:v000014C3d00007961sv*sd*bc*sc*i*

2)  sudo vim /etc/modprobe.d/mt7921e.conf
add the following line:
alias pci:v000014C3d00000608sv*sd*bc*sc*i* mt7921e

3) sudo vim /etc/udev/rules.d/99-mt7921e.rules
add the following line:
SUBSYSTEM=="drivers", DEVPATH=="/sys/bus/pci/drivers/mt7921e", ATTR{new_id}="14c3 0608"

4) reboot
wifi is now working : )

Offline

Board footer

Powered by FluxBB