You are not logged in.

#1 2022-02-17 16:46:57

Overloader
Member
Registered: 2021-12-04
Posts: 10

installing ffmpeg breaks dependency

So I've somehow ran into the problem where when I try to update my packages I get this:

❯ doas pacman -Syu
doas (lukas@ArchPC) password:
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing ffmpeg (2:5.0-3) breaks dependency 'libavcodec.so=58-64' required by yuzu
:: installing ffmpeg (2:5.0-3) breaks dependency 'libavutil.so=56-64' required by yuzu
:: installing ffmpeg (2:5.0-3) breaks dependency 'libswscale.so=5-64' required by yuzu

I've read that uninstalling ffmpeg (With -Rnsc) And reinstalling it would fix it, but a ton of my packages would be removed as well that I would have to remember installing again. Is there any other solution?

Offline

#2 2022-02-17 16:51:23

seth
Member
Registered: 2012-09-03
Posts: 29,717

Re: installing ffmpeg breaks dependency

You need to update the yuzu AUR package.
Remove it, update the system and re-install yuzu

Offline

#3 2022-02-17 16:52:38

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,759
Website

Re: installing ffmpeg breaks dependency

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2022-02-17 16:52:38

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,334

Re: installing ffmpeg breaks dependency

It's not ffmpeg that's causing your issue, it's yuzu.

Uninstall that and your system will update properly, then rebuild and reinstall yuzu.
AUR packages are always the users responsibility to maintain.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#5 2022-02-17 16:52:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,406

Re: installing ffmpeg breaks dependency

No, you need to remove yuzu and update, and then rebuild yuzu against the new ffmpeg (potentially adjust/fix the PKGBUILD in the process) and/or install the ffmpeg4.4 compat package.

Edit: Triple fuck, whoops

Last edited by V1del (2022-02-17 16:53:55)

Offline

#6 2022-02-17 16:53:30

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,334

Re: installing ffmpeg breaks dependency

I think we have this covered smile


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#7 2022-06-07 00:13:06

tonytony
Member
Registered: 2022-06-06
Posts: 2

Re: installing ffmpeg breaks dependency

I just did a fresh install and I have the same error when I did pacman -Syyu. I tried to follow this thread and a few others but this is the most relevant one so I am wondering if you can help me here or do I need to post it in the newbie section because I am a newbie?  I don't know how to share my logs as I do not know how to access my files other than reading them.  I don't even know how to share a screenshot on this forum from my desktop.  I know it's something like    [img=screenshot]~/Desktop/screenshot.png[/img]       Please Help!

Offline

#8 2022-06-07 00:22:20

tonytony
Member
Registered: 2022-06-06
Posts: 2

Re: installing ffmpeg breaks dependency

I just did a fresh install and I have the same error when I did pacman -Syyu.  I tried to follow this thread and a few others but this is the most relevant one so I am wondering if you can help me here or do I need to post it in the newbie section because I am a newbie?  I don't know how to share my logs as I do not know how to access my files other than reading them.  I don't even know how to share a screenshot on this forum from my desktop.  I know it's something like    [img=black]~/Desktop/black.png[/img]

Offline

#9 2022-06-07 02:36:07

loqs
Member
Registered: 2014-03-06
Posts: 14,869

Re: installing ffmpeg breaks dependency

tonytony wrote:

I just did a fresh install and I have the same error when I did pacman -Syyu.

https://bbs.archlinux.org/viewtopic.php?id=57855
https://wiki.archlinux.org/title/Genera … _hijacking

tonytony wrote:

I don't know how to share my logs as I do not know how to access my files other than reading them.

https://wiki.archlinux.org/title/List_o … n_services

Offline

Board footer

Powered by FluxBB