You are not logged in.

#1 2022-03-11 02:37:07

From: Argentina
Registered: 2022-03-10
Posts: 126

[Solved] Fresh installation, /sbin/init does not exist

After the installation, when I select Arch in GRUB, it displays the following message:

/dev/sda2: clean, 59309/14622720 files
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck.

sh: can't access tty: job control turned off
[rootfs ]#

Here's info about the installation:


sda 8:0 0 223.6G 0 disk
sda1 8:1 0 500M 0 part /efi
sda2 8:2 0 223.1G part /

fdisk -l /dev/sda:

Disk /dev/sda: 223.57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: KINGSTON SA400S3
Units: sectors of 1 * 512 = 512 bytes
Sector Size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 976DAB58-391B-4958-A0BB-6302711EA499

Device       Start    End    Sectors    Size    Type
/dev/sda1    2048    1026047    1024000    500M    EFI System 
/dev/sda2    1026048    468862094    467836047    223.1G    Linux filesystem


# /dev/sda2
UUID=c8fe71ce-5138-4bcd-a577-2adb77172cc8    /    ext4    rw,relatime    0 1

# /dev/sda1
UUID=1F03-C685    /efi    vfat    rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro    0 2

efibootmgr -v:

BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0003,0001,0002,0004
Boot0001   cd      PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,65535,0)/HD(4,GPT,48c51e11-08c1-46c0-ae27-cdf88faf193d,0x74382800,0x384000)
Boot0002* CD      PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,65535,0)/HD(4,GPT,48c51e11-08c1-46c0-ae27-cdf88faf193d,0x74382800,0x384000)
Boot0003* Arch   HD(1,GPT,0fdb40e3-bc7a-4afb-8742-bb025ab6faa,0x800,0xfa000)/File(EFI\BOOT\BOOTX64.EFI)
Boot0004* UEFI:  KingstonDataTravaler 3.0, Partition 2 PciRoot(0x0)/Pci(0x14,0x0)/USB(2.0)/HD(2,GPT,120e661b-d065-f1c9-40fa-3e7c9f3aaaf8-0x39933d0,0x1000)..BO

I have to add a new boot option using efibootmgr (Boot0003* Arch). Before adding the boot option, Dell Support Assist said that a bootable device was not found.

Edit: for some reason, systemd-sysvcompat was not installed. So I installed and that's work.

Last edited by Adriik (2022-03-11 02:49:04)

I'm just someone. Please use [code] [/code] tags.
Command cheatsheetCommand not found?
If I write something wrong in English, please correct me.
♪ Muchachos, ahora nos volvimos a ilusionar ★★★ ♪


#2 2022-03-17 17:36:58

From: Norway
Registered: 2020-01-02
Posts: 268

Re: [Solved] Fresh installation, /sbin/init does not exist

How did you install Arch?
/sbin/init should be a link to /lib/systemd/systemd and systemd-sysvcompat is part of the base package, which should be installed right after formatting and mounting your partitions: … l_packages.
I think it would be a good idea to start over, and make sure you follow the installation guide carefully.
It's quite straightforward, and you should have no problems following it.


Board footer

Powered by FluxBB