You are not logged in.

#1 2022-03-22 12:32:33

c137
Member
Registered: 2022-02-15
Posts: 19

Can't put laptop to hibernate mode

I tried to set my laptop to hibernate mode with the command

systemctl hibernate
Failed to hibernate system via logind: Not enough swap space for hibernation

So I check my swap and memory size

swapon
NAME       TYPE      SIZE USED PRIO
/dev/zram0 partition  32G   0B  100
free
               total        used        free
Mem:        15835236     2506396     8183388
Swap:       33554428           0    33554428

and grub

# GRUB boot loader configuration

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="vt.global_cursor_default=0 nmi_watchdog=0 quiet loglevel=3 rd.systemd.show_status=false rd.udev.log_priority=3 amdgpu.backlight=0 acpi_backlight=vendor splash resume=/dev/zram0 resume_offset=0 zswap.enabled=0"
GRUB_CMDLINE_LINUX="rootfstype=btrfs"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
#GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1920x1080x32

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_DISABLE_OS_PROBER=false

GRUB_THEME=/boot/grub/themes/fallout-grub-theme/theme.txt

and /sys/power/resume*

cat /sys/power/resume
0:0
cat /sys/power/resume_offset
0

I checked the official wiki, but I still can't understand why I can't put my laptop to hibernate mode. I look forward to any suggestions

Thanks in advance.

Offline

#2 2022-03-23 01:46:47

fukawi2
Ex-Administratorino
From: .vic.au
Registered: 2007-09-28
Posts: 6,208
Website

Re: Can't put laptop to hibernate mode

MOD: Moving to Laptop Issues.

Offline

#3 2022-03-25 13:47:11

PonJar
Member
Registered: 2019-07-05
Posts: 25

Re: Can't put laptop to hibernate mode

Have you established that the resume offset of 0 is correct? The wiki shows how to look up the correct value on btrfs

Last edited by PonJar (2022-03-25 13:47:47)

Offline

#4 2022-04-04 15:35:36

c137
Member
Registered: 2022-02-15
Posts: 19

Re: Can't put laptop to hibernate mode

PonJar wrote:

Have you established that the resume offset of 0 is correct? The wiki shows how to look up the correct value on btrfs

I try to follow wiki
But I got a error

./btrfs_map_physical /dev/zram0
BTRFS_IOC_TREE_SEARCH: Inappropriate ioctl for device

Offline

Board footer

Powered by FluxBB