You are not logged in.

#1 2022-03-28 10:44:47

Arko
Member
Registered: 2020-04-11
Posts: 4

Invalid argument when trying to connect to samba share with nautilus

Hi,
When trying to connect to samba share with nautilus where password is needed, I get

Unhandled error message: Failed to retrieve share list from server: Invalid argument

I just installed my system yesterday, so I didn't do anything that could mess up with config. I installed samba, smbclient, polkit, gvfs, gvfs-smb. And used default samba config as my config.

Running nautilus from command line didn't show any errors or warnings.

In journalctl I only see this error:

Kerberos auth with 'adrian@WORKGROUP' (WORKGROUP\adrian) to access '(IP)' not possible

I can connect to the share with smbclient using the same name and workgroup without any issue. On ubuntu connecting to samba share with nautilus worked out of the box.

Mounting with cifs also works without any issue, but I don't want to mount share on startup or mount it everytime from command line

I also tried

client min protocol = CORE
server min protocol = CORE

but it also didn't work out.

Samba and smbclient version:

Version 4.16.0

Nautilus version:

GNOME nautilus 41.2

Anyone could help?

EDIT: connecting to sftp share with nautilus works flawless. I'm getting prompt for password and share mounts without any issue. So it must be something with samba or gvfs-smb

Last edited by Arko (2022-03-28 12:54:27)

Offline

#2 2022-03-28 12:15:03

leetxyz
Member
Registered: 2022-03-12
Posts: 2

Re: Invalid argument when trying to connect to samba share with nautilus

Got the same error on smbclient 4.16.0-1, downgrading to 4.15.6-1 fixes the issue.

Offline

#3 2022-03-28 12:22:05

Arko
Member
Registered: 2020-04-11
Posts: 4

Re: Invalid argument when trying to connect to samba share with nautilus

Thanks! That did the trick. For now I'm holding this package.

Offline

#4 2022-03-28 12:42:53

lv
Member
Registered: 2014-10-18
Posts: 6

Re: Invalid argument when trying to connect to samba share with nautilus

I created a bug report here with links to the associated upstream bug reports

Offline

#5 2022-03-28 12:54:50

seth
Member
Registered: 2012-09-03
Posts: 32,033

Re: Invalid argument when trying to connect to samba share with nautilus

On ubuntu and fedora, connecting to samba share with nautilus worked out of the box.

The error sounds like you're trying to browse the server, not access a share directly. That won't work w/o NT1 on both sides - regardless of the distro.

What address do you specify?
Does

smb://[[domain;]username[:password]@]server[/share[/path]]

work?
(ie. "smb://adrian:supersecretpassword@IP/sharename")

Edit: fuck.

Last edited by seth (2022-03-28 12:55:13)

Offline

#6 2022-03-29 00:38:01

Thermodynamic
Member
From: Germany
Registered: 2022-03-29
Posts: 1

Re: Invalid argument when trying to connect to samba share with nautilus

leetxyz wrote:

Got the same error on smbclient 4.16.0-1, downgrading to 4.15.6-1 fixes the issue.

Can confirm, downgrading solved the issue with Nemo on my main system (and the other Arch based ones too).
The issue persits in the newest version 4.16.0-2 of samba/smbclient.

To downgrade both:

$ sudo pacman -U /var/cache/pacman/pkg/smbclient-4.15.6-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/samba-4.15.6-1-x86_64.pkg.tar.zst

Last edited by Thermodynamic (2022-03-29 00:43:28)

Offline

#7 2022-03-30 04:29:03

asharch
Member
Registered: 2022-03-30
Posts: 1

Re: Invalid argument when trying to connect to samba share with nautilus

Got the same error using nemo file browser "Failed to retrieve share list from server: Invalid argument" after upgrade to smbclient 4.16.0-1 Also downgraded to 4.15.6-1 to fix the issue.

Offline

#8 2022-03-30 14:17:41

Strangiato
Member
Registered: 2020-01-10
Posts: 195

Re: Invalid argument when trying to connect to samba share with nautilus

Can confirm. I have fixed the problem by downgrading samba to 4.15.6-1 on the server and smbclient to 4.15.6-1 on the client, both running Arch Linux.

Last edited by Strangiato (2022-03-30 14:18:43)

Offline

#9 2022-03-30 18:04:34

ogghi
Member
Registered: 2013-09-05
Posts: 15

Re: Invalid argument when trying to connect to samba share with nautilus

Confirmed, was driving me crazy before! Downgrade to 4.15.6-1 works fine!

Offline

#10 2022-03-31 07:45:13

offlinehoster
Member
Registered: 2022-03-31
Posts: 1

Re: Invalid argument when trying to connect to samba share with nautilus

I already reported this issue to the Gnome people

https://gitlab.gnome.org/GNOME/nautilus/-/issues/2206

Offline

#11 2022-03-31 08:51:40

loqs
Member
Registered: 2014-03-06
Posts: 15,369

Re: Invalid argument when trying to connect to samba share with nautilus

Offline

#12 2022-03-31 08:58:35

ctony
Member
Registered: 2022-03-31
Posts: 1

Re: Invalid argument when trying to connect to samba share with nautilus

I confirm, it's ok

 pacman -U https://archive.archlinux.org/packages/path/smbclient-4.15.6-1-x86_64.pkg.tar.zst 

yesterday I tried to mount the shares from the terminal smbclient > it's ok except for a network drive that contains a $

I'm a simple user of sharing.
an idea to mount a share with $ in the name? //share/folder1$/folder2/

dmesg shows attempt to mount on drive but stops at $

Last edited by ctony (2022-03-31 08:59:45)

Offline

#13 2022-03-31 09:03:19

loqs
Member
Registered: 2014-03-06
Posts: 15,369

Re: Invalid argument when trying to connect to samba share with nautilus

@ctony there is a fixed PKGBUILD and fixed pre built packages in the Arch bug report if you want to upgrade again.

Offline

#14 2022-04-02 17:02:55

Ferdinand
Member
From: Norway
Registered: 2020-01-02
Posts: 249

Re: Invalid argument when trying to connect to samba share with nautilus

@seth, I don't think you got an answer, but you're spot on:

smb://username@host/share

works, but

smb://host/share

gives the

Failed to mount Windows share: Invalid argument

error - I tried both in Thunar and "gio mount" (which amounts to the same thing, I guess).

Offline

#15 2022-04-02 19:53:49

sheepdev
Member
From: Croatia
Registered: 2021-04-02
Posts: 1
Website

Re: Invalid argument when trying to connect to samba share with nautilus

Can confirm, same error, downgrading to smbclient 4.15.6-1 fixed it.

Offline

#16 2022-04-02 22:25:27

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 4,138

Re: Invalid argument when trying to connect to samba share with nautilus

That's enough +1 posts. There are active bugs at GNOME and the Arch bugtracker.

Closing for now to prevent more noise; Arko, if you want this thread reopened, use the Report link.


How to post. A sincere effort to use modest and proper language and grammar is a sign of respect toward the community.

Offline

Board footer

Powered by FluxBB