You are not logged in.

#1 2022-04-05 17:46:38

Corrupted
Member
Registered: 2021-07-07
Posts: 2

[SOLVED] Unable to switch wifi networks after setting active-backup

Hi all,

I recently changed my systemd-networkd configuration to bond my ethernet and wifi interfaces in active-backup mode. Since doing this I've been unable to use iwctl to switch networks after initially connecting. When attempting to connect, iwctl will show it's attempting to make the connection and around a half second later complains that there is "No station on device: wlan0" and shortly after Ill be put back onto the previous network.

Journalctl shows:

Apr 05 10:05:15 *** systemd-networkd[4303]: wlan0: Connected WiFi access point: *** (***)
Apr 05 10:05:15 *** kernel: wlan0: RX AssocResp from *** (capab=0x1411 status=0 aid=27)
Apr 05 10:05:15 *** kernel: rtw_8822be 0000:02:00.0: sta *** joined with macid 0
Apr 05 10:05:15 *** kernel: wlan0: associated
Apr 05 10:05:15 *** kernel: wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by ***
Apr 05 10:05:15 *** systemd-networkd[4303]: wlan0: Gained carrier
Apr 05 10:05:15 *** systemd-networkd[4303]: wlan0: found matching network '/etc/systemd/network/30-bond0-wireless.network', based on potentially unpredictable interface name.
Apr 05 10:05:15 *** systemd-networkd[4303]: wlan0: Reconfiguring with /etc/systemd/network/30-bond0-wireless.network.
Apr 05 10:05:15 *** kernel: wlan0: deauthenticating from *** by local choice (Reason: 3=DEAUTH_LEAVING)
Apr 05 10:05:15 *** kernel: rtw_8822be 0000:02:00.0: sta *** with macid 0 left
Apr 05 10:05:15 *** kernel: rtw_8822be 0000:02:00.0: stop vif *** on port 0
Apr 05 10:05:15 *** iwd[1103]: Received Deauthentication event, reason: 3, from_ap: false
Apr 05 10:05:15 *** iwd[1103]: Received error during CMD_TRIGGER_SCAN: Network is down (100)
Apr 05 10:05:15 *** systemd-networkd[4303]: wlan0: Link DOWN
Apr 05 10:05:15 *** systemd-networkd[4303]: wlan0: Lost carrier
Apr 05 10:05:16 *** kernel: rtw_8822be 0000:02:00.0: start vif *** on port 0
Apr 05 10:05:16 *** systemd-networkd[4303]: wlan0: Link UP
Apr 05 10:05:16 *** systemd-networkd[4303]: wlan0: Gained carrier
Apr 05 10:05:16 *** systemd-networkd[4303]: wlan0: found matching network '/etc/systemd/network/30-bond0-wireless.network', based on potentially unpredictable interface name.
Apr 05 10:05:16 *** systemd-networkd[4303]: wlan0: Lost carrier
Apr 05 10:05:16 *** iwd[1103]: Could not register frame watch type 00d0: -114
Apr 05 10:05:17 *** kernel: wlan0: authenticate with ***
Apr 05 10:05:17 *** kernel: wlan0: send auth to *** (try 1/3)
Apr 05 10:05:17 *** kernel: wlan0: authenticated
Apr 05 10:05:17 *** kernel: wlan0: associate with *** (try 1/3)
Apr 05 10:05:17 *** kernel: wlan0: RX AssocResp from *** (capab=0x1011 status=0 aid=18)
Apr 05 10:05:17 *** kernel: rtw_8822be 0000:02:00.0: sta *** joined with macid 0
Apr 05 10:05:17 *** kernel: wlan0: associated
Apr 05 10:05:17 *** systemd-networkd[4303]: wlan0: Connected WiFi access point: *** (***)
Apr 05 10:05:17 *** systemd-networkd[4303]: wlan0: Gained carrier
Apr 05 10:05:17 *** systemd-networkd[4303]: wlan0: found matching network '/etc/systemd/network/30-bond0-wireless.network', based on potentially unpredictable interface name.
Apr 05 10:05:17 *** kernel: wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by ***
Apr 05 10:05:17 *** kernel: bond0: (slave wlan0): link status definitely up, 0 Mbps full duplex
Apr 05 10:05:17 *** kernel: bond0: (slave wlan0): making interface the new active one

I may be wrong in my reading, but it looks as though networkd is taking down the wlan0 interface in the middle of iwd attempting to connect to the new network, causing the connection to fail. Am I correct in my reading of this? If so, how should I connect to a new network? I'm pretty new to this so I'm not sure if this is a limitation of my setup, a mistake I'm making or a bug of sorts.

Thanks!

Last edited by Corrupted (2022-04-06 18:35:39)

Offline

#2 2022-04-06 07:41:12

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: [SOLVED] Unable to switch wifi networks after setting active-backup

Try modifying /etc/systemd/network/30-bond0-wireless.network from

[Match]
Name=wlan0

[Network]
Bond=bond0

to

[Match]
MACAddress=MAC_address_of_the_WiFi_card

[Network]
Bond=bond0

Last edited by -thc (2022-04-06 07:43:24)

Offline

#3 2022-04-06 18:34:25

Corrupted
Member
Registered: 2021-07-07
Posts: 2

Re: [SOLVED] Unable to switch wifi networks after setting active-backup

-thc wrote:

Try modifying /etc/systemd/network/30-bond0-wireless.network from

[Match]
Name=wlan0

[Network]
Bond=bond0

to

[Match]
MACAddress=MAC_address_of_the_WiFi_card

[Network]
Bond=bond0

Thanks -thc. This seems to have fixed the issue I was having.

Offline

Board footer

Powered by FluxBB