You are not logged in.

#1 2022-04-05 18:00:51

strangechange
Member
Registered: 2017-03-06
Posts: 23

i2pd http

I want to use i2p. I tried before to use the i2pd package, as its a c++ and I don't need to install java with it.
https://i2pd.readthedocs.io/en/latest/tutorials/http/
It says to put a http/https proxy 127.0.0.1:4444. I did that in firefox, but it didn't work. I want normal settings for normal websites too, so I assume I need a second browser for the proxy settings. How do I make a second firefox?

Offline

#2 2022-04-06 07:30:38

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: i2pd http

You can use different firefox profiles.

Start firefox with

$ firefox -P

and create a profile named "incognito".

Use the "default" profile with a normal application start and the alternative profile by editing the command for an additional desktop shortcut to:

/usr/lib/firefox/firefox %u -P incognito

Offline

#3 2022-04-06 19:30:56

strangechange
Member
Registered: 2017-03-06
Posts: 23

Re: i2pd http

I made the new profile and tried all kinds of settings.
Do I need to put 127.0.0.1 at port 4447 in socks v5? Do I need Proxy DNS when using socks v5?
If I try an .i2p website its not working its always converting the link to some kind of search request.
127.0.0.1:7070 shows some traffic.

I didn't know how to make the additional shortcut. I can only start the new profile with

$ firefox -P incognito

so far
I assume /usr/lib/firefox/firefox is where it starts firefox, and what does the %u mean?

Last edited by strangechange (2022-04-06 19:32:18)

Offline

#4 2022-04-07 05:42:42

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: i2pd http

strangechange wrote:

I made the new profile and tried all kinds of settings.
Do I need to put 127.0.0.1 at port 4447 in socks v5? Do I need Proxy DNS when using socks v5?
If I try an .i2p website its not working its always converting the link to some kind of search request.
127.0.0.1:7070 shows some traffic.

You have to compile (i2pd-git from AUR), configure (tunnels.conf) and run i2pd correctly.
I can't help you - I don't use "magic tunnel" stuff like this.

strangechange wrote:

I didn't know how to make the additional shortcut.

That depends on your chosen desktop. Try dragging the shortcut from the start menu to the desktop or right-clicking the start menu entry or right-clicking the desktop itself.

strangechange wrote:

I assume /usr/lib/firefox/firefox is where it starts firefox, and what does the %u mean?

It means "URL" - you can drag and drop a URL on the icon for opening that URL.

Last edited by -thc (2022-04-07 09:30:50)

Offline

#5 2022-04-07 12:21:36

strangechange
Member
Registered: 2017-03-06
Posts: 23

Re: i2pd http

Why not the normal i2pd package called i2pd described in this article? There is a /var/lib/i2pd/tunnels.conf
https://wiki.archlinux.org/title/I2P

What do tunnels do? Why do I need to configure it? For now I just want browsing to work.

Offline

#6 2022-04-07 20:18:24

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: i2pd http

strangechange wrote:

Why not the normal i2pd package called i2pd described in this article?

When I clicked the i2pd link it was dead - but it isn't and I can't remember what had happened.
Nevermind. Yes, it makes sense to use i2pd from the standard repository.

strangechange wrote:

There is a /var/lib/i2pd/tunnels.conf
https://wiki.archlinux.org/title/I2P
What do tunnels do?

tunnels.conf configures other protocols (IRC/SMTP/POP3).

strangechange wrote:

Why do I need to configure it? For now I just want browsing to work.

O.K. You probably don't need SOCKS and tunnels.conf then.

BTW - port 7070 is the web console of i2pd. Try it: http://127.0.0.1:7070

After starting the service I was able to visit eepsites (-> planet.i2p) without changing any configuration except the proxy setting in firefox.

Offline

#7 2022-04-07 21:12:46

strangechange
Member
Registered: 2017-03-06
Posts: 23

Re: i2pd http

-thc wrote:

After starting the service I was able to visit eepsites (-> planet.i2p) without changing any configuration except the proxy setting in firefox.

For me when I type planet.i2p and press enter the adressbar gets converted to
https://duckduckgo.com/?t=ffab&q=planet.i2p
and then its saying

Hmm. We’re having trouble finding that site.

An error occurred during a connection to duckduckgo.com.

If that address is correct, here are three other things you can try:

    Try again later.
    Check your network connection.
    If you are connected but behind a firewall, check that Firefox has permission to access the Web.

I have searched in the options to no awail

Offline

#8 2022-04-08 04:59:50

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: i2pd http

Firefox does this when the proxy setting is incorrect, otherwise not working or off.
If the setup is correct and i2pd is not running, you get "The proxy server is refusing connections...".

Offline

#9 2022-04-08 15:32:50

strangechange
Member
Registered: 2017-03-06
Posts: 23

Re: i2pd http

Systemctl output

i2pd.service  loaded active running   I2P Router written in C++

Firefox Manual proxy configuration
HTTP 127.0.0.1 Port 4444
HTTPS 127.0.0.1 Port 4444
No proxy for localhost, 127.0.0.1

Firefox about:config media.peerconnection.ice.proxy_only true

127.0.0.1:7070 displays i2pd webconsole
Uptime: 1 hour, 19 minutes, 37 seconds
Network status: OK

planet.i2p, identiguy.i2p straight to https://duckduckgo.com/?t=ffab&q=identiguy.i2p
Hmm. We’re having trouble finding that site.
An error occurred during a connection to duckduckgo.com.

exact same settings as here: https://geti2p.net/en/about/browser-config

I don't know what to do now.

Offline

#10 2022-04-08 15:51:54

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: i2pd http

Try entering the complete URL:

http://planet.i2p
http://identiguy.i2p

Offline

#11 2022-04-08 17:37:09

strangechange
Member
Registered: 2017-03-06
Posts: 23

Re: i2pd http

http://planet.i2p/ is working
http://identiguy.i2p/ is working

What setting do I need to toggle in about:config?

If I put https instead I get

Secure Connection Failed

An error occurred during a connection to identiguy.i2p. SSL received a record that exceeded the maximum permissible length.

Error code: SSL_ERROR_RX_RECORD_TOO_LONG

But I don't have https-only mode enabled in the settings.

Last edited by strangechange (2022-04-08 17:38:06)

Offline

#12 2022-04-08 19:08:01

ua4000
Member
Registered: 2015-10-14
Posts: 259

Re: i2pd http

i2p pages usually don't provide https.
https://geti2p.net/en/faq#https

Offline

#13 2022-04-08 21:37:55

strangechange
Member
Registered: 2017-03-06
Posts: 23

Re: i2pd http

About the shortcut:
If I make

# ln -s /usr/lib/firefox/firefox .

How do I pass parameter -P incognito?
I have gnome 3 and don't think I can make shortcuts with it.

Offline

#14 2022-04-09 06:04:04

-thc
Member
Registered: 2017-03-15
Posts: 204

Re: i2pd http

strangechange wrote:

About the shortcut:
If I make

# ln -s /usr/lib/firefox/firefox .

How do I pass parameter -P incognito?

A symbolic link does not pass parameters to the binary. You can write a small shell script and link this to the desktop.

strangechange wrote:

I have gnome 3 and don't think I can make shortcuts with it.

You are right.
You can try nemo or the AUR package "gnome-shell-extension-desktop-icons".

Offline

Board footer

Powered by FluxBB